summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-03 16:04:44 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-05-03 16:04:44 +0000
commitf2e1ba4473f7cb10e44c7522ec14d2e6b036409f (patch)
treef7b1cd2b41c05a7d4c9b9a7c3675e4e32b18c7b1 /dev-cpp/commoncpp2
parentVersion bump. (diff)
downloadgentoo-2-f2e1ba4473f7cb10e44c7522ec14d2e6b036409f.tar.gz
gentoo-2-f2e1ba4473f7cb10e44c7522ec14d2e6b036409f.tar.bz2
gentoo-2-f2e1ba4473f7cb10e44c7522ec14d2e6b036409f.zip
Respect USE="gnutls".
(Portage version: 13599-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/commoncpp2')
-rw-r--r--dev-cpp/commoncpp2/ChangeLog8
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.6.3.ebuild10
2 files changed, 13 insertions, 5 deletions
diff --git a/dev-cpp/commoncpp2/ChangeLog b/dev-cpp/commoncpp2/ChangeLog
index c15362a342f8..257ee8d6448c 100644
--- a/dev-cpp/commoncpp2/ChangeLog
+++ b/dev-cpp/commoncpp2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-cpp/commoncpp2
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/ChangeLog,v 1.47 2009/03/22 17:45:22 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/ChangeLog,v 1.48 2009/05/03 16:04:44 arfrever Exp $
+
+ 03 May 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ commoncpp2-1.6.3.ebuild:
+ Respect USE="gnutls".
22 Mar 2009; Markus Meier <maekke@gentoo.org> commoncpp2-1.6.2.ebuild:
amd64 stable, bug #261567
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.6.3.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.6.3.ebuild
index 9b2fca999b6f..c621ef960f68 100644
--- a/dev-cpp/commoncpp2/commoncpp2-1.6.3.ebuild
+++ b/dev-cpp/commoncpp2/commoncpp2-1.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.6.3.ebuild,v 1.2 2009/03/09 04:21:03 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.6.3.ebuild,v 1.3 2009/05/03 16:04:44 arfrever Exp $
inherit eutils autotools
@@ -35,12 +35,16 @@ src_compile() {
sed -i "s/^DOXYGEN=.*/DOXYGEN=no/" configure || die "sed failed"
local myconf
- use gnutls || myconf="--with-openssl"
+ if use gnutls; then
+ myconf="--with-gnutls --without-openssl"
+ else
+ myconf="--without-gnutls --with-openssl"
+ fi
econf \
$(use_enable debug) \
$(use_with ipv6 ) \
- ${myconf} || die "econf failed"
+ ${myconf}
emake -j1 || die "emake failed"
}