summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-04-23 10:17:57 +0000
committerPeter Volkov <pva@gentoo.org>2010-04-23 10:17:57 +0000
commita42dc4be804a017dbf72910d8805a82904820dab (patch)
treeea788269aba0ec9b738be7c6a8831dff91318923 /dev-cpp/commoncpp2
parentDon't include headers from /usr/src/linux wrt #316759. (diff)
downloadgentoo-2-a42dc4be804a017dbf72910d8805a82904820dab.tar.gz
gentoo-2-a42dc4be804a017dbf72910d8805a82904820dab.tar.bz2
gentoo-2-a42dc4be804a017dbf72910d8805a82904820dab.zip
Version bump, bug #279505, thank Eric Womer for report. This should fix gcc-4.4 build issues.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/commoncpp2')
-rw-r--r--dev-cpp/commoncpp2/ChangeLog10
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.8.0.ebuild77
2 files changed, 85 insertions, 2 deletions
diff --git a/dev-cpp/commoncpp2/ChangeLog b/dev-cpp/commoncpp2/ChangeLog
index b2b1cfe321b7..a7dacc336610 100644
--- a/dev-cpp/commoncpp2/ChangeLog
+++ b/dev-cpp/commoncpp2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/commoncpp2
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/ChangeLog,v 1.49 2009/07/30 07:58:34 dirtyepic Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/ChangeLog,v 1.50 2010/04/23 10:17:57 pva Exp $
+
+*commoncpp2-1.8.0 (23 Apr 2010)
+
+ 23 Apr 2010; Peter Volkov <pva@gentoo.org> +commoncpp2-1.8.0.ebuild:
+ Version bump, bug #279505, thank Eric Womer for report. This should fix
+ gcc-4.4 build issues.
30 Jul 2009; Ryan Hill <dirtyepic@gentoo.org> commoncpp2-1.6.3.ebuild,
+files/commoncpp2-1.6.3-glibc-2.10.patch:
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.8.0.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.8.0.ebuild
new file mode 100644
index 000000000000..f4d9aeb5c4f0
--- /dev/null
+++ b/dev-cpp/commoncpp2/commoncpp2-1.8.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.8.0.ebuild,v 1.1 2010/04/23 10:17:57 pva Exp $
+
+EAPI="2"
+inherit eutils autotools
+
+DESCRIPTION="GNU Common C++ is a C++ framework offering portable support for threading, sockets, file access, daemons, persistence, serial I/O, XML parsing, and system services"
+SRC_URI="mirror://gnu/commoncpp/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/commoncpp/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug doc examples ipv6 gnutls"
+
+RDEPEND="gnutls? ( dev-libs/libgcrypt
+ net-libs/gnutls )
+ !gnutls? ( dev-libs/openssl )
+ sys-libs/zlib"
+DEPEND="doc? ( >=app-doc/doxygen-1.3.6 )
+ ${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/1.6.1-gcc42_atomicity.patch"
+ epatch "${FILESDIR}/1.6.2-configure_detect_netfilter.patch" # bug 236177
+ eautoreconf
+}
+
+src_configure() {
+ use doc || \
+ sed -i "s/^DOXYGEN=.*/DOXYGEN=no/" configure || die "sed failed"
+
+ local myconf
+ if use gnutls; then
+ myconf="--with-gnutls --without-openssl"
+ else
+ myconf="--without-gnutls --with-openssl"
+ fi
+
+ econf \
+ $(use_enable debug) \
+ $(use_with ipv6 ) \
+ ${myconf}
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS NEWS ChangeLog README THANKS TODO COPYING.addendum
+
+ # Only install html docs
+ # man and latex available, but seems a little wasteful
+ use doc && dohtml doc/html/*
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ cd demo
+ doins *.cpp *.h *.xml README
+ fi
+}
+
+pkg_postinst() {
+ ewarn "There's a change in the ABI between version 1.5.x and 1.6.x, please"
+ ewarn "run the following command to find broken packages and rebuild them:"
+ ewarn " revdep-rebuild --library=libccext2-1.5.so"
+}
+
+# Some of the tests hang forever
+#src_test() {
+# cd "${S}/tests"
+# emake || die "emake tests failed"
+# ./test.sh || die "tests failed"
+#}