summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2006-10-22 15:59:12 +0000
committerTiziano Müller <dev-zero@gentoo.org>2006-10-22 15:59:12 +0000
commit0b4dd929e28cd7b456fb462211b141ab69e1b903 (patch)
tree092a2bc62a635ccbfba777390cdf12abbfd81c85 /dev-cpp/commoncpp2
parentVersion bumped. (diff)
downloadgentoo-2-0b4dd929e28cd7b456fb462211b141ab69e1b903.tar.gz
gentoo-2-0b4dd929e28cd7b456fb462211b141ab69e1b903.tar.bz2
gentoo-2-0b4dd929e28cd7b456fb462211b141ab69e1b903.zip
'debug' and 'gnutls' USE-flags added. Dependencies corrected.
(Portage version: 2.1.2_pre3-r3)
Diffstat (limited to 'dev-cpp/commoncpp2')
-rw-r--r--dev-cpp/commoncpp2/ChangeLog5
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.5.1-r1.ebuild56
-rw-r--r--dev-cpp/commoncpp2/files/1.5.1-ssl_config.patch29
-rw-r--r--dev-cpp/commoncpp2/files/digest-commoncpp2-1.5.1-r13
4 files changed, 92 insertions, 1 deletions
diff --git a/dev-cpp/commoncpp2/ChangeLog b/dev-cpp/commoncpp2/ChangeLog
index 80f462729059..5201b6e83f93 100644
--- a/dev-cpp/commoncpp2/ChangeLog
+++ b/dev-cpp/commoncpp2/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-cpp/commoncpp2
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/ChangeLog,v 1.22 2006/10/21 20:52:02 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/ChangeLog,v 1.23 2006/10/22 15:59:12 dev-zero Exp $
+
+ 22 Oct 2006; Tiziano Müller <dev-zero@gentoo.org> ChangeLog:
+ 'debug' and 'gnutls' USE-flags added. Dependencies corrected.
*commoncpp2-1.5.1 (21 Oct 2006)
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.5.1-r1.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.5.1-r1.ebuild
new file mode 100644
index 000000000000..38116e2b89b0
--- /dev/null
+++ b/dev-cpp/commoncpp2/commoncpp2-1.5.1-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/commoncpp2/commoncpp2-1.5.1-r1.ebuild,v 1.1 2006/10/22 15:59:12 dev-zero Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="GNU Common C++ is a C++ framework offering portable support for threading, sockets, file access, daemons, persistence, serial I/O, XML parsing, and system services"
+SRC_URI="mirror://sourceforge/gnutelephony/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/commoncpp/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug doc ipv6 gnutls"
+
+RDEPEND="gnutls? ( dev-libs/libgcrypt
+ net-libs/gnutls )
+ !gnutls? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+DEPEND="doc? ( >=app-doc/doxygen-1.3.6 )
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/ccext2-as-needed.diff"
+ epatch "${FILESDIR}/${PV}-ssl_config.patch"
+ eautoconf
+}
+
+src_compile() {
+ use doc || \
+ sed -i "s/^DOXYGEN=.*/DOXYGEN=no/" configure || die "sed failed"
+
+ local myconf
+ if use gnutls ; then
+ myconf="--with-gnutls"
+ else
+ myconf="--with-openssl"
+ fi
+ econf \
+ $(use_enable debug) \
+ $(use_with ipv6 ) \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS NEWS ChangeLog README THANKS TODO COPYING.addendum
+
+ # Only install html docs
+ # man and latex available, but seems a little wasteful
+ use doc && dohtml doc/html/*
+}
diff --git a/dev-cpp/commoncpp2/files/1.5.1-ssl_config.patch b/dev-cpp/commoncpp2/files/1.5.1-ssl_config.patch
new file mode 100644
index 000000000000..675e99960721
--- /dev/null
+++ b/dev-cpp/commoncpp2/files/1.5.1-ssl_config.patch
@@ -0,0 +1,29 @@
+--- configure.ac.orig 2006-10-22 18:02:57.000000000 +0200
++++ configure.ac 2006-10-22 18:06:17.000000000 +0200
+@@ -247,6 +247,7 @@
+ ost_cv_extras=yes
+ AC_DEFINE(HAVE_EXTRAS, [1], [Enable extras])
+
++ AC_ARG_WITH(gnutls, [ --with-gnutls Enable gnutls support], [
+ AC_CHECK_HEADER(gnutls/gnutls.h,[
+ AC_CHECK_LIB(gnutls, gnutls_init, [
+ SSL_LIBS="-lgnutls -lgcrypt"
+@@ -254,13 +255,12 @@
+ AC_DEFINE(CCXX_SSL, [GNUTLS], [defines ssl])
+ AC_DEFINE(CCXX_GNUTLS, [1], [define gnutls])
+ ])
+-
+- ],[
+- AC_ARG_WITH(openssl, [ --with-openssl Enable openssl support],
+- [OST_LIB_SSL],
+- [OST_LIB_NOSSL])
++ ],[])
++ ], [
++ AC_ARG_WITH(openssl, [ --with-openssl Enable openssl support],
++ [OST_LIB_SSL],
++ [OST_LIB_NOSSL])
+ ])
+-
+ AC_ARG_WITH(compression, [ --without-compression Disable libz compression],
+ [OST_LIB_NOZLIB],
+ [OST_LIB_ZLIB])
diff --git a/dev-cpp/commoncpp2/files/digest-commoncpp2-1.5.1-r1 b/dev-cpp/commoncpp2/files/digest-commoncpp2-1.5.1-r1
new file mode 100644
index 000000000000..d9c6b02e1e54
--- /dev/null
+++ b/dev-cpp/commoncpp2/files/digest-commoncpp2-1.5.1-r1
@@ -0,0 +1,3 @@
+MD5 f2b1f011029de128496c33424f145864 commoncpp2-1.5.1.tar.gz 862555
+RMD160 ebfc941ea65bbf10f8d6485945748066280719b9 commoncpp2-1.5.1.tar.gz 862555
+SHA256 32e37df5f089c63d95a150b465d925ea33609c1fe3de952efbdca91add8c45d0 commoncpp2-1.5.1.tar.gz 862555