summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-10-29 22:46:43 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-10-29 22:46:43 +0000
commited8bb62df7030942bbbfaf068e20cbcf9a08e453 (patch)
tree96fee727a0cc5dc780e1d072acf4fe7ccc007f1c /dev-cpp/cairomm
parentNew version for GNOME 2.28. (diff)
downloadgentoo-2-ed8bb62df7030942bbbfaf068e20cbcf9a08e453.tar.gz
gentoo-2-ed8bb62df7030942bbbfaf068e20cbcf9a08e453.tar.bz2
gentoo-2-ed8bb62df7030942bbbfaf068e20cbcf9a08e453.zip
New version for GNOME 2.28.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/cairomm')
-rw-r--r--dev-cpp/cairomm/ChangeLog7
-rw-r--r--dev-cpp/cairomm/cairomm-1.8.2.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-cpp/cairomm/ChangeLog b/dev-cpp/cairomm/ChangeLog
index 019baf210889..769e93b85d0c 100644
--- a/dev-cpp/cairomm/ChangeLog
+++ b/dev-cpp/cairomm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/cairomm
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/cairomm/ChangeLog,v 1.35 2009/10/12 20:08:39 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/cairomm/ChangeLog,v 1.36 2009/10/29 22:46:43 eva Exp $
+
+*cairomm-1.8.2 (29 Oct 2009)
+
+ 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org> +cairomm-1.8.2.ebuild:
+ New version for GNOME 2.28.
12 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org -cairomm-1.2.4.ebuild,
cairomm-1.4.4.ebuild, -cairomm-1.5.0.ebuild,
diff --git a/dev-cpp/cairomm/cairomm-1.8.2.ebuild b/dev-cpp/cairomm/cairomm-1.8.2.ebuild
new file mode 100644
index 000000000000..1e7fa925e5f8
--- /dev/null
+++ b/dev-cpp/cairomm/cairomm-1.8.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/cairomm/cairomm-1.8.2.ebuild,v 1.1 2009/10/29 22:46:43 eva Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="C++ bindings for the Cairo vector graphics library"
+HOMEPAGE="http://cairographics.org/cairomm"
+SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc svg"
+
+# FIXME: svg support is automagic
+RDEPEND=">=x11-libs/cairo-1.8[svg?]
+ dev-libs/libsigc++:2"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ # don't waste time building examples because they are marked as "noinst"
+ sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || die "sed failed"
+
+ # don't waste time building tests
+ # they require the boost Unit Testing framework, that's not in base boost
+ sed -i 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' Makefile.in || die "sed failed"
+}
+
+src_configure() {
+ econf $(use_enable doc docs)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README ChangeLog || die "dodoc failed"
+}