summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2005-10-16 07:57:39 +0000
committerRyan Phillips <rphillips@gentoo.org>2005-10-16 07:57:39 +0000
commit29478585f3faa59a061204742fb0953e70db1280 (patch)
tree9e00fafd169c2f46e601d8826708b37cb90e9114 /dev-cpp/asio/asio-0.3.4.ebuild
parentKeyworded ~mips. (diff)
downloadgentoo-2-29478585f3faa59a061204742fb0953e70db1280.tar.gz
gentoo-2-29478585f3faa59a061204742fb0953e70db1280.tar.bz2
gentoo-2-29478585f3faa59a061204742fb0953e70db1280.zip
new package
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'dev-cpp/asio/asio-0.3.4.ebuild')
-rw-r--r--dev-cpp/asio/asio-0.3.4.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-cpp/asio/asio-0.3.4.ebuild b/dev-cpp/asio/asio-0.3.4.ebuild
new file mode 100644
index 000000000000..0fba6a301c86
--- /dev/null
+++ b/dev-cpp/asio/asio-0.3.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/asio/asio-0.3.4.ebuild,v 1.1 2005/10/16 07:57:39 rphillips Exp $
+
+DESCRIPTION="asynchronous network library"
+HOMEPAGE="http://asio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/asio/${P}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="ssl"
+
+DEPEND=">=dev-libs/boost-1.33.0
+ app-doc/doxygen
+ ssl? ( dev-libs/openssl )"
+RDEPEND=""
+
+src_install() {
+ einstall || die "install error"
+
+ dodoc README COPYING INSTALL
+ dodir /usr/share/doc/${PF}/
+ mv doc/* ${D}/usr/share/doc/${PF}/
+}