summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-12-17 21:58:29 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-12-17 21:58:29 +0000
commitc9120890fdd01d3a863c55302af108da04873caf (patch)
tree11f6ccc1086211b2a767f9cf014d71cc0e184c68 /dev-cpp/Ice
parentx86 stable, bug #244022 (diff)
downloadgentoo-2-c9120890fdd01d3a863c55302af108da04873caf.tar.gz
gentoo-2-c9120890fdd01d3a863c55302af108da04873caf.tar.bz2
gentoo-2-c9120890fdd01d3a863c55302af108da04873caf.zip
Fix bug 227475. Thanks to bonsaikitten, aka DrEevil, aka Evil Compile Person for reporting and Daniel Beßler <daniel@orgizm.net> for the patch.
(Portage version: 2.2_rc17/cvs/Linux 2.6.28-rc6 x86_64)
Diffstat (limited to 'dev-cpp/Ice')
-rw-r--r--dev-cpp/Ice/ChangeLog7
-rw-r--r--dev-cpp/Ice/Ice-3.2.1.ebuild5
-rw-r--r--dev-cpp/Ice/files/Ice-3.2.1-gcc43.patch275
3 files changed, 284 insertions, 3 deletions
diff --git a/dev-cpp/Ice/ChangeLog b/dev-cpp/Ice/ChangeLog
index e3888c80d642..00c44fdea3b0 100644
--- a/dev-cpp/Ice/ChangeLog
+++ b/dev-cpp/Ice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/Ice
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/Ice/ChangeLog,v 1.17 2008/11/11 14:56:33 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/Ice/ChangeLog,v 1.18 2008/12/17 21:58:29 loki_val Exp $
+
+ 17 Dec 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/Ice-3.2.1-gcc43.patch, Ice-3.2.1.ebuild:
+ Fix bug 227475. Thanks to bonsaikitten, aka DrEevil, aka Evil Compile
+ Person for reporting and Daniel Beßler <daniel@orgizm.net> for the patch.
*Ice-3.3.0-r1 (11 Nov 2008)
diff --git a/dev-cpp/Ice/Ice-3.2.1.ebuild b/dev-cpp/Ice/Ice-3.2.1.ebuild
index 703e613ff073..d38302288e3d 100644
--- a/dev-cpp/Ice/Ice-3.2.1.ebuild
+++ b/dev-cpp/Ice/Ice-3.2.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/Ice/Ice-3.2.1.ebuild,v 1.4 2007/09/25 19:41:02 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/Ice/Ice-3.2.1.ebuild,v 1.5 2008/12/17 21:58:29 loki_val Exp $
inherit eutils
@@ -35,6 +35,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${P}-Makefile.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch
MAKE_RULES="${S}/config/Make.rules"
diff --git a/dev-cpp/Ice/files/Ice-3.2.1-gcc43.patch b/dev-cpp/Ice/files/Ice-3.2.1-gcc43.patch
new file mode 100644
index 000000000000..fc1488b1e2db
--- /dev/null
+++ b/dev-cpp/Ice/files/Ice-3.2.1-gcc43.patch
@@ -0,0 +1,275 @@
+diff -ur Ice-3.2.1.orig/include/Ice/Outgoing.h Ice-3.2.1/include/Ice/Outgoing.h
+--- Ice-3.2.1.orig/include/Ice/Outgoing.h 2008-02-22 15:24:43.000000000 +0100
++++ Ice-3.2.1/include/Ice/Outgoing.h 2008-02-22 15:24:56.000000000 +0100
+@@ -16,6 +16,7 @@
+ #include <Ice/ReferenceF.h>
+ #include <Ice/BasicStream.h>
+ #include <Ice/Current.h>
++#include <memory>
+
+ namespace Ice
+ {
+diff -ur Ice-3.2.1.orig/src/FreezeScript/AssignVisitor.cpp Ice-3.2.1/src/FreezeScript/AssignVisitor.cpp
+--- Ice-3.2.1.orig/src/FreezeScript/AssignVisitor.cpp 2008-02-22 15:24:43.000000000 +0100
++++ Ice-3.2.1/src/FreezeScript/AssignVisitor.cpp 2008-02-22 15:26:34.000000000 +0100
+@@ -9,6 +9,7 @@
+
+ #include <FreezeScript/AssignVisitor.h>
+ #include <FreezeScript/Util.h>
++#include <climits>
+
+ using namespace std;
+
+diff -ur Ice-3.2.1.orig/src/FreezeScript/Data.cpp Ice-3.2.1/src/FreezeScript/Data.cpp
+--- Ice-3.2.1.orig/src/FreezeScript/Data.cpp 2008-02-22 15:24:43.000000000 +0100
++++ Ice-3.2.1/src/FreezeScript/Data.cpp 2008-02-22 15:26:21.000000000 +0100
+@@ -12,6 +12,7 @@
+ #include <FreezeScript/Util.h>
+ #include <FreezeScript/Exception.h>
+ #include <IceUtil/InputUtil.h>
++#include <climits>
+
+ using namespace std;
+ using namespace IceUtil;
+diff -ur Ice-3.2.1.orig/src/FreezeScript/DumpDescriptors.cpp Ice-3.2.1/src/FreezeScript/DumpDescriptors.cpp
+--- Ice-3.2.1.orig/src/FreezeScript/DumpDescriptors.cpp 2008-02-22 15:24:43.000000000 +0100
++++ Ice-3.2.1/src/FreezeScript/DumpDescriptors.cpp 2008-02-22 15:26:26.000000000 +0100
+@@ -15,6 +15,7 @@
+ #include <FreezeScript/Util.h>
+ #include <db_cxx.h>
+ #include <set>
++#include <climits>
+
+ using namespace std;
+
+diff -ur Ice-3.2.1.orig/src/FreezeScript/Transformer.cpp Ice-3.2.1/src/FreezeScript/Transformer.cpp
+--- Ice-3.2.1.orig/src/FreezeScript/Transformer.cpp 2008-02-22 15:24:43.000000000 +0100
++++ Ice-3.2.1/src/FreezeScript/Transformer.cpp 2008-02-22 15:26:16.000000000 +0100
+@@ -19,6 +19,7 @@
+ #include <Freeze/Initialize.h>
+ #include <IceXML/Parser.h>
+ #include <db_cxx.h>
++#include <climits>
+
+ using namespace std;
+
+diff -ur Ice-3.2.1.orig/src/Ice/ConnectionI.h Ice-3.2.1/src/Ice/ConnectionI.h
+--- Ice-3.2.1.orig/src/Ice/ConnectionI.h 2008-02-22 15:24:43.000000000 +0100
++++ Ice-3.2.1/src/Ice/ConnectionI.h 2008-02-22 15:24:56.000000000 +0100
+@@ -26,6 +26,7 @@
+ #include <Ice/TraceLevelsF.h>
+ #include <Ice/OutgoingAsyncF.h>
+ #include <Ice/EventHandler.h>
++#include <memory>
+
+ namespace IceInternal
+ {
+diff -ur Ice-3.2.1.orig/src/IceGrid/Activator.cpp Ice-3.2.1/src/IceGrid/Activator.cpp
+--- Ice-3.2.1.orig/src/IceGrid/Activator.cpp 2008-02-22 15:24:43.000000000 +0100
++++ Ice-3.2.1/src/IceGrid/Activator.cpp 2008-02-22 15:27:13.000000000 +0100
+@@ -22,6 +22,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
++#include <climits>
+
+ #ifndef _WIN32
+ # include <sys/wait.h>
+diff -ur Ice-3.2.1.orig/src/IceGrid/PlatformInfo.cpp Ice-3.2.1/src/IceGrid/PlatformInfo.cpp
+--- Ice-3.2.1.orig/src/IceGrid/PlatformInfo.cpp 2008-02-22 15:24:43.000000000 +0100
++++ Ice-3.2.1/src/IceGrid/PlatformInfo.cpp 2008-02-22 15:27:05.000000000 +0100
+@@ -17,6 +17,7 @@
+ #include <IceGrid/TraceLevels.h>
+
+ #include <IcePatch2/Util.h>
++#include <climits>
+
+ #if defined(_WIN32)
+ # include <direct.h> // For _getcwd
+diff -ur Ice-3.2.1.orig/src/IcePatch2/OS.cpp Ice-3.2.1/src/IcePatch2/OS.cpp
+--- Ice-3.2.1.orig/src/IcePatch2/OS.cpp 2008-02-22 15:24:43.000000000 +0100
++++ Ice-3.2.1/src/IcePatch2/OS.cpp 2008-02-22 15:26:56.000000000 +0100
+@@ -10,6 +10,7 @@
+ #include <IceUtil/DisableWarnings.h>
+ #include <OS.h>
+ #include <IceUtil/Unicode.h>
++#include <climits>
+
+ #ifdef __BCPLUSPLUS__
+ # include <dir.h>
+diff -ur Ice-3.2.1.orig/src/IceUtil/ArgVector.cpp Ice-3.2.1/src/IceUtil/ArgVector.cpp
+--- Ice-3.2.1.orig/src/IceUtil/ArgVector.cpp 2008-02-22 15:24:43.000000000 +0100
++++ Ice-3.2.1/src/IceUtil/ArgVector.cpp 2008-02-22 15:24:56.000000000 +0100
+@@ -9,6 +9,7 @@
+
+ #include <IceUtil/ArgVector.h>
+ #include <IceUtil/DisableWarnings.h>
++#include <cstring>
+
+ IceUtil::ArgVector::ArgVector(int argc, char *argv[])
+ {
+diff -ur Ice-3.2.1.orig/src/IceUtil/MD5.cpp Ice-3.2.1/src/IceUtil/MD5.cpp
+--- Ice-3.2.1.orig/src/IceUtil/MD5.cpp 2008-02-22 15:24:43.000000000 +0100
++++ Ice-3.2.1/src/IceUtil/MD5.cpp 2008-02-22 15:24:56.000000000 +0100
+@@ -9,6 +9,7 @@
+
+ #include <IceUtil/MD5.h>
+ #include <IceUtil/MD5I.h>
++#include <cstring>
+
+ using namespace std;
+
+diff -ur Ice-3.2.1.orig/src/IceUtil/OutputUtil.cpp Ice-3.2.1/src/IceUtil/OutputUtil.cpp
+--- Ice-3.2.1.orig/src/IceUtil/OutputUtil.cpp 2008-02-22 15:24:43.000000000 +0100
++++ Ice-3.2.1/src/IceUtil/OutputUtil.cpp 2008-02-22 15:24:56.000000000 +0100
+@@ -8,6 +8,7 @@
+ // **********************************************************************
+
+ #include <IceUtil/OutputUtil.h>
++#include <cstring>
+
+ using namespace std;
+ using namespace IceUtil;
+diff -ur Ice-3.2.1.orig/src/IceUtil/Random.cpp Ice-3.2.1/src/IceUtil/Random.cpp
+--- Ice-3.2.1.orig/src/IceUtil/Random.cpp 2008-02-22 15:24:43.000000000 +0100
++++ Ice-3.2.1/src/IceUtil/Random.cpp 2008-02-22 15:24:56.000000000 +0100
+@@ -9,6 +9,7 @@
+
+ #include <IceUtil/Random.h>
+ #include <IceUtil/StaticMutex.h>
++#include <cstring>
+
+ #ifdef _WIN32
+ # include <Wincrypt.h>
+diff -ur Ice-3.2.1.orig/src/IceUtil/ThreadException.cpp Ice-3.2.1/src/IceUtil/ThreadException.cpp
+--- Ice-3.2.1.orig/src/IceUtil/ThreadException.cpp 2008-02-22 15:24:43.000000000 +0100
++++ Ice-3.2.1/src/IceUtil/ThreadException.cpp 2008-02-22 15:24:56.000000000 +0100
+@@ -8,6 +8,7 @@
+ // **********************************************************************
+
+ #include <IceUtil/ThreadException.h>
++#include <cstring>
+
+ using namespace std;
+
+diff -ur Ice-3.2.1.orig/src/Slice/CPlusPlusUtil.cpp Ice-3.2.1/src/Slice/CPlusPlusUtil.cpp
+--- Ice-3.2.1.orig/src/Slice/CPlusPlusUtil.cpp 2008-02-22 15:24:43.000000000 +0100
++++ Ice-3.2.1/src/Slice/CPlusPlusUtil.cpp 2008-02-22 15:24:56.000000000 +0100
+@@ -8,6 +8,7 @@
+ // **********************************************************************
+
+ #include <Slice/CPlusPlusUtil.h>
++#include <cstring>
+
+ using namespace std;
+ using namespace Slice;
+diff -ur Ice-3.2.1.orig/src/Slice/DotNetNames.cpp Ice-3.2.1/src/Slice/DotNetNames.cpp
+--- Ice-3.2.1.orig/src/Slice/DotNetNames.cpp 2008-02-22 15:24:43.000000000 +0100
++++ Ice-3.2.1/src/Slice/DotNetNames.cpp 2008-02-22 15:24:56.000000000 +0100
+@@ -9,6 +9,7 @@
+
+ #include <Slice/DotNetNames.h>
+ #include <ctype.h>
++#include <cstring>
+
+ using namespace std;
+
+diff -ur Ice-3.2.1.orig/src/Slice/Grammar.cpp Ice-3.2.1/src/Slice/Grammar.cpp
+--- Ice-3.2.1.orig/src/Slice/Grammar.cpp 2008-02-22 15:24:43.000000000 +0100
++++ Ice-3.2.1/src/Slice/Grammar.cpp 2008-02-22 15:24:56.000000000 +0100
+@@ -165,6 +165,7 @@
+
+ #include <Slice/GrammarUtil.h>
+ #include <IceUtil/UUID.h>
++#include <cstring>
+
+ #ifdef _MSC_VER
+ // I get these warnings from some bison versions:
+diff -ur Ice-3.2.1.orig/src/Slice/Grammar.y Ice-3.2.1/src/Slice/Grammar.y
+--- Ice-3.2.1.orig/src/Slice/Grammar.y 2008-02-22 15:24:43.000000000 +0100
++++ Ice-3.2.1/src/Slice/Grammar.y 2008-02-22 15:24:56.000000000 +0100
+@@ -11,6 +11,7 @@
+
+ #include <Slice/GrammarUtil.h>
+ #include <IceUtil/UUID.h>
++#include <cstring>
+
+ #ifdef _MSC_VER
+ // I get these warnings from some bison versions:
+diff -ur Ice-3.2.1.orig/src/Slice/Parser.cpp Ice-3.2.1/src/Slice/Parser.cpp
+--- Ice-3.2.1.orig/src/Slice/Parser.cpp 2008-02-22 15:24:43.000000000 +0100
++++ Ice-3.2.1/src/Slice/Parser.cpp 2008-02-22 15:24:56.000000000 +0100
+@@ -10,6 +10,7 @@
+ #include <IceUtil/Functional.h>
+ #include <Slice/Parser.h>
+ #include <Slice/GrammarUtil.h>
++#include <cstring>
+ #ifdef __BCPLUSPLUS__
+ # include <iterator>
+ #endif
+diff -ur Ice-3.2.1.orig/src/Slice/Preprocessor.cpp Ice-3.2.1/src/Slice/Preprocessor.cpp
+--- Ice-3.2.1.orig/src/Slice/Preprocessor.cpp 2008-02-22 15:24:43.000000000 +0100
++++ Ice-3.2.1/src/Slice/Preprocessor.cpp 2008-02-22 15:24:56.000000000 +0100
+@@ -11,6 +11,7 @@
+ #include <IceUtil/StringUtil.h>
+ #include <algorithm>
+ #include <fstream>
++#include <cstring>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+
+diff -ur Ice-3.2.1.orig/src/Slice/PythonUtil.cpp Ice-3.2.1/src/Slice/PythonUtil.cpp
+--- Ice-3.2.1.orig/src/Slice/PythonUtil.cpp 2008-02-22 15:24:43.000000000 +0100
++++ Ice-3.2.1/src/Slice/PythonUtil.cpp 2008-02-22 15:25:32.000000000 +0100
+@@ -13,6 +13,7 @@
+ #ifdef __BCPLUSPLUS__
+ # include <iterator>
+ #endif
++#include <climits>
+
+ using namespace std;
+ using namespace Slice;
+diff -ur Ice-3.2.1.orig/src/slice2docbook/Gen.cpp Ice-3.2.1/src/slice2docbook/Gen.cpp
+--- Ice-3.2.1.orig/src/slice2docbook/Gen.cpp 2008-02-22 15:24:43.000000000 +0100
++++ Ice-3.2.1/src/slice2docbook/Gen.cpp 2008-02-22 15:24:56.000000000 +0100
+@@ -10,6 +10,7 @@
+ #include <IceUtil/DisableWarnings.h>
+ #include <IceUtil/Functional.h>
+ #include <Gen.h>
++#include <cstring>
+
+ #ifdef __BCPLUSPLUS__
+ # include <iterator>
+diff -ur Ice-3.2.1.orig/src/slice2freeze/Main.cpp Ice-3.2.1/src/slice2freeze/Main.cpp
+--- Ice-3.2.1.orig/src/slice2freeze/Main.cpp 2008-02-22 15:24:43.000000000 +0100
++++ Ice-3.2.1/src/slice2freeze/Main.cpp 2008-02-22 15:24:56.000000000 +0100
+@@ -12,6 +12,7 @@
+ #include <Slice/Preprocessor.h>
+ #include <Slice/CPlusPlusUtil.h>
+ #include <IceUtil/OutputUtil.h>
++#include <cstring>
+
+ using namespace std;
+ using namespace IceUtil;
+diff -ur Ice-3.2.1.orig/src/slice2java/Gen.cpp Ice-3.2.1/src/slice2java/Gen.cpp
+--- Ice-3.2.1.orig/src/slice2java/Gen.cpp 2008-02-22 15:24:43.000000000 +0100
++++ Ice-3.2.1/src/slice2java/Gen.cpp 2008-02-22 15:24:56.000000000 +0100
+@@ -15,6 +15,7 @@
+ #include <IceUtil/Iterator.h>
+
+ #include <limits>
++#include <cstring>
+
+ using namespace std;
+ using namespace Slice;
+diff -ur Ice-3.2.1.orig/src/slice2py/Main.cpp Ice-3.2.1/src/slice2py/Main.cpp
+--- Ice-3.2.1.orig/src/slice2py/Main.cpp 2008-02-22 15:24:43.000000000 +0100
++++ Ice-3.2.1/src/slice2py/Main.cpp 2008-02-22 15:24:56.000000000 +0100
+@@ -13,6 +13,7 @@
+ #include <Slice/PythonUtil.h>
+
+ #include <fstream>
++#include <cstring>
+
+ #include <sys/types.h>
+ #include <sys/stat.h>