summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2008-04-23 13:25:21 +0000
committerCaleb Tennis <caleb@gentoo.org>2008-04-23 13:25:21 +0000
commita8f326c180e30ae890315cf96713da1938c13b11 (patch)
treed432bd079766098164a47bd5575de1f0267917e3 /dev-cpp/Ice
parentadd New Ice ebuilds (diff)
downloadgentoo-2-a8f326c180e30ae890315cf96713da1938c13b11.tar.gz
gentoo-2-a8f326c180e30ae890315cf96713da1938c13b11.tar.bz2
gentoo-2-a8f326c180e30ae890315cf96713da1938c13b11.zip
Version bump, currently masked
(Portage version: 2.1.5_rc4)
Diffstat (limited to 'dev-cpp/Ice')
-rw-r--r--dev-cpp/Ice/ChangeLog10
-rw-r--r--dev-cpp/Ice/Ice-3.3.0_beta1.ebuild77
-rw-r--r--dev-cpp/Ice/files/Ice-3.3.0_beta1-Makefile.patch91
3 files changed, 176 insertions, 2 deletions
diff --git a/dev-cpp/Ice/ChangeLog b/dev-cpp/Ice/ChangeLog
index 67ec4f38ca21..490241438c44 100644
--- a/dev-cpp/Ice/ChangeLog
+++ b/dev-cpp/Ice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/Ice
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/Ice/ChangeLog,v 1.13 2007/09/25 19:41:02 angelos Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/Ice/ChangeLog,v 1.14 2008/04/23 13:25:21 caleb Exp $
+
+*Ice-3.3.0_beta1 (23 Apr 2008)
+
+ 23 Apr 2008; Caleb Tennis <caleb@gentoo.org>
+ +files/Ice-3.3.0_beta1-Makefile.patch, +Ice-3.3.0_beta1.ebuild:
+ Version bump, currently masked
25 Sep 2007; Christoph Mende <angelos@gentoo.org> Ice-3.2.1.ebuild:
Stable on amd64 wrt bug #192139
diff --git a/dev-cpp/Ice/Ice-3.3.0_beta1.ebuild b/dev-cpp/Ice/Ice-3.3.0_beta1.ebuild
new file mode 100644
index 000000000000..9a148df0f8c7
--- /dev/null
+++ b/dev-cpp/Ice/Ice-3.3.0_beta1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/Ice/Ice-3.3.0_beta1.ebuild,v 1.1 2008/04/23 13:25:21 caleb Exp $
+
+inherit eutils
+
+MY_P=Ice-3.3b
+
+DESCRIPTION="ICE middleware C++ bindings"
+HOMEPAGE="http://www.zeroc.com/index.html"
+SRC_URI="http://www.zeroc.com/download/Ice/3.3/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="ncurses test debug"
+
+RDEPEND=">=dev-libs/expat-2.0.1
+ >=app-arch/bzip2-1.0.4
+ >=dev-libs/openssl-0.9.8g
+ =sys-libs/db-4.6.21*
+ =dev-cpp/libmcpp-2.6.4"
+
+DEPEND="${RDEPEND}
+ ncurses? ( sys-libs/ncurses sys-libs/readline )
+ test? ( >=dev-lang/python-2.4 )"
+
+S=${WORKDIR}/${MY_P}/cpp
+
+pkg_setup() {
+ if built_with_use sys-libs/db nocxx; then
+ eerror "sys-libs/db must be compiled with C++ support!"
+ eerror "Remove the 'nocxx' use flag and try again."
+ die "Fix use flags and re-emerge"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+
+ MAKE_RULES="${S}/config/Make.rules"
+
+ #if use amd64; then
+ # sed -i -e "s:^#LP64:LP64:g" "${MAKE_RULES}" \
+ # || die "Failed to set lib64 directory"
+ #fi
+
+ if ! use ncurses; then
+ sed -i -e "s#^USE_READLINE.*#USE_READLINE ?= yes#g" \
+ "${MAKE_RULES}" || die "Failed to set no readline"
+ fi
+
+ if ! use debug; then
+ sed -i -e "s:#OPTIMIZE:OPTIMIZE:" \
+ "${MAKE_RULES}" || die "Failed to remove debug"
+ fi
+
+ sed -i -e \
+ "s:.*CXXFLAGS[^\+]*\=\s:CXXFLAGS = ${CXXFLAGS} :g" \
+ "${MAKE_RULES}.Linux" || die "CXXFLAGS patching failed!"
+}
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+ cp -dpR "${S}"/../slice "${D}"/usr/share/Ice
+}
+
+src_test() {
+ emake test || die "Test failed"
+}
diff --git a/dev-cpp/Ice/files/Ice-3.3.0_beta1-Makefile.patch b/dev-cpp/Ice/files/Ice-3.3.0_beta1-Makefile.patch
new file mode 100644
index 000000000000..c76f4ee12c71
--- /dev/null
+++ b/dev-cpp/Ice/files/Ice-3.3.0_beta1-Makefile.patch
@@ -0,0 +1,91 @@
+--- config/Make.rules.orig 2008-04-02 07:40:44.000000000 -0400
++++ config/Make.rules 2008-04-02 07:45:56.000000000 -0400
+@@ -11,13 +11,13 @@
+ # Select an installation base directory. The directory will be created
+ # if it does not exist.
+ #
+-prefix ?= /opt/Ice-$(VERSION)
++prefix ?= /$(DESTDIR)/usr
+
+ #
+ # The "root directory" for runpath embedded in executables. Can be unset
+ # to avoid adding a runpath to Ice executables.
+ #
+-embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
++#embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
+
+ #
+ # Define OPTIMIZE as yes if you want to build with
+@@ -125,7 +125,7 @@
+ endif
+
+ install_includedir = $(prefix)/include
+-install_docdir = $(prefix)/doc
++install_docdir = $(prefix)/share/doc/Ice-$(VERSION)
+
+ bindir = $(top_srcdir)/bin
+ libdir = $(top_srcdir)/lib
+@@ -161,18 +161,8 @@
+ BZIP2_LIBS = $(if $(BZIP2_HOME),-L$(BZIP2_HOME)/$(libsubdir)) -lbz2
+ BZIP2_RPATH_LINK = $(if $(BZIP2_HOME),$(call rpathlink,$(BZIP2_HOME)/$(libsubdir)))
+
+-ifneq ($(DB_HOME),)
+- DB_FLAGS = -I$(DB_HOME)/include
+- DB_LIBS = -L$(DB_HOME)/$(libsubdir) -ldb_cxx
+- DB_RPATH_LINK = $(call rpathlink,$(DB_HOME)/$(libsubdir))
+-else
+- ifeq ($(shell if [ -d /usr/include/db46 -a -d /usr/$(libsubdir)/db46 ] ; then echo yes; fi), yes)
+- DB_FLAGS = -I/usr/include/db46
+- DB_LIBS = -L/usr/$(libsubdir)/db46 -ldb_cxx
+- else
+- DB_LIBS = -ldb_cxx
+- endif
+-endif
++DB_FLAGS = -I/usr/include/db4.6
++DB_LIBS = -L/usr/$(libsubdir) -ldb_cxx-4.6
+
+ EXPAT_FLAGS = $(if $(EXPAT_HOME),-I$(EXPAT_HOME)/include)
+ EXPAT_LIBS = $(if $(EXPAT_HOME),-L$(EXPAT_HOME)/$(libsubdir)) -lexpat
+--- Makefile.orig 2008-04-02 09:51:02.000000000 -0400
++++ Makefile 2008-04-02 09:51:18.000000000 -0400
+@@ -11,11 +11,11 @@
+
+ include $(top_srcdir)/config/Make.rules
+
+-SUBDIRS = config src include test demo
++SUBDIRS = config src include
+
+ INSTALL_SUBDIRS = $(install_bindir) $(install_libdir) $(install_includedir)
+
+-install:: install-common
++install::
+ @for subdir in $(INSTALL_SUBDIRS); \
+ do \
+ if test ! -d $$subdir ; \
+--- config/Makefile.orig 2008-04-02 10:33:40.000000000 -0400
++++ config/Makefile 2008-04-02 10:34:26.000000000 -0400
+@@ -15,15 +15,15 @@
+ echo ""
+
+ install::
+- @if test ! -d $(prefix)/config ; \
++ @if test ! -d $(prefix)/share/Ice/config ; \
+ then \
+- echo "Creating $(prefix)/config..." ; \
+- $(call mkdir,$(prefix)/config) ; \
++ echo "Creating $(prefix)/share/Ice/config..." ; \
++ mkdir -p $(prefix)/share/Ice/config ; \
+ fi
+- $(call installdata,templates.xml,$(prefix)/config)
+- $(call installdata,convertssl.py,$(prefix)/config)
+- $(call installdata,upgradeicegrid.py,$(prefix)/config)
+- $(call installdata,icegrid-slice.3.1.ice.gz,$(prefix)/config)
+- $(call installdata,icegrid-slice.3.2.ice.gz,$(prefix)/config)
+- $(call installdata,icegrid-slice.3.3.ice.gz,$(prefix)/config)
++ $(call installdata,templates.xml,$(prefix)/share/Ice/config)
++ $(call installdata,convertssl.py,$(prefix)/share/Ice/config)
++ $(call installdata,upgradeicegrid.py,$(prefix)/share/Ice/config)
++ $(call installdata,icegrid-slice.3.1.ice.gz,$(prefix)/share/Ice/config)
++ $(call installdata,icegrid-slice.3.2.ice.gz,$(prefix)/share/Ice/config)
++ $(call installdata,icegrid-slice.3.3.ice.gz,$(prefix)/share/Ice/config)
+