summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-02-28 12:50:18 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-02-28 12:50:18 +0000
commit28c085e39987a38512c968de87e3bb0b072f9160 (patch)
tree2b11084d53899f4683b0588a4798769fe7b64bf6 /dev-cpp/Ice
parentAdd dev-cpp/Ice-3.2 beta to p.mask (diff)
downloadgentoo-2-28c085e39987a38512c968de87e3bb0b072f9160.tar.gz
gentoo-2-28c085e39987a38512c968de87e3bb0b072f9160.tar.bz2
gentoo-2-28c085e39987a38512c968de87e3bb0b072f9160.zip
bump to new beta version, package masked because it relies on db-4.5
(Portage version: 2.1.2-r12)
Diffstat (limited to 'dev-cpp/Ice')
-rw-r--r--dev-cpp/Ice/ChangeLog8
-rw-r--r--dev-cpp/Ice/Ice-3.2.0_beta1.ebuild67
-rw-r--r--dev-cpp/Ice/files/Ice-3.2.0_beta1-Makefile.patch81
-rw-r--r--dev-cpp/Ice/files/digest-Ice-3.2.0_beta13
4 files changed, 158 insertions, 1 deletions
diff --git a/dev-cpp/Ice/ChangeLog b/dev-cpp/Ice/ChangeLog
index 2582c3af4306..eb5cd4d1872b 100644
--- a/dev-cpp/Ice/ChangeLog
+++ b/dev-cpp/Ice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/Ice
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/Ice/ChangeLog,v 1.3 2007/02/03 03:14:53 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/Ice/ChangeLog,v 1.4 2007/02/28 12:50:18 caleb Exp $
+
+*Ice-3.2.0_beta1 (28 Feb 2007)
+
+ 28 Feb 2007; Caleb Tennis <caleb@gentoo.org>
+ +files/Ice-3.2.0_beta1-Makefile.patch, +Ice-3.2.0_beta1.ebuild:
+ Bump to new beta version, package masked because it relies on db-4.5
03 Feb 2007; Steve Dibb <beandog@gentoo.org> Ice-3.1.1.ebuild:
Add ~amd64, bug 142045
diff --git a/dev-cpp/Ice/Ice-3.2.0_beta1.ebuild b/dev-cpp/Ice/Ice-3.2.0_beta1.ebuild
new file mode 100644
index 000000000000..95e275bcf620
--- /dev/null
+++ b/dev-cpp/Ice/Ice-3.2.0_beta1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/Ice/Ice-3.2.0_beta1.ebuild,v 1.1 2007/02/28 12:50:18 caleb Exp $
+
+inherit eutils
+
+MY_P=${P/.0_beta1/b}
+
+DESCRIPTION="ICE middleware C++ bindings"
+HOMEPAGE="http://www.zeroc.com/index.html"
+SRC_URI="http://www.zeroc.com/download/Ice/3.2/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ncurses test debug"
+
+S=${WORKDIR}/${MY_P}
+
+DEPEND="ncurses? ( sys-libs/ncurses sys-libs/readline )
+ test? ( >=dev-lang/python-2.2 )
+ ~sys-libs/db-4.5.20
+ >=dev-libs/openssl-0.9.7"
+RDEPEND=">=dev-libs/expat-1.9
+ >=app-arch/bzip2-1.0"
+
+pkg_setup() {
+ if built_with_use sys-libs/db nocxx; then
+ eerror "sys-libs/db must be compiled with C++ support!"
+ eerror "Remove the 'nocxx' use flag and try again."
+ die "Fix use flags and re-emerge"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-Makefile.patch
+
+ if use amd64; then
+ sed -i -e "s:^#LP64:LP64:g" ${S}/config/Make.rules \
+ || die "Failed to set lib64 directory"
+ fi
+
+ if ! use ncurses; then
+ sed -i -e "s# USE_READLINE.*# USE_READLINE := no#g" \
+ ${S}/config/Make.rules || die "Failed to set no readline"
+ fi
+
+ if ! use debug; then
+ sed -i -e "s:#OPTIMIZE:OPTIMIZE:" \
+ ${S}/config/Make.rules || die "Failed to remove debug"
+ fi
+
+ sed -i -e \
+ "s:.*CXXFLAGS[^\+]*\=\s:CXXFLAGS = ${CXXFLAGS} :g" \
+ ${S}/config/Make.rules.Linux || die "CXXFLAGS patching failed!"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Install Failed!"
+}
+
+src_test() {
+ make test || die "Test failed"
+}
diff --git a/dev-cpp/Ice/files/Ice-3.2.0_beta1-Makefile.patch b/dev-cpp/Ice/files/Ice-3.2.0_beta1-Makefile.patch
new file mode 100644
index 000000000000..4fe2e06695f9
--- /dev/null
+++ b/dev-cpp/Ice/files/Ice-3.2.0_beta1-Makefile.patch
@@ -0,0 +1,81 @@
+--- config/Make.rules.orig 2007-02-27 15:49:03.000000000 -0500
++++ config/Make.rules 2007-02-27 15:51:08.000000000 -0500
+@@ -11,13 +11,13 @@
+ # Select an installation base directory. The directory will be created
+ # if it does not exist.
+ #
+-prefix ?= /opt/Ice-$(VERSION)
++prefix ?= $(DESTDIR)/usr
+
+ #
+ # The "root directory" for runpath embedded in executables. Can be unset
+ # to avoid adding a runpath to Ice executables.
+ #
+-embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
++#embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
+
+ #
+ # Define OPTIMIZE as yes if you want to build with
+@@ -125,9 +125,9 @@
+ install_bindir = $(prefix)/bin
+
+ install_includedir = $(prefix)/include
+-install_slicedir = $(prefix)/slice
+-install_schemadir = $(prefix)/schema
+-install_docdir = $(prefix)/doc
++install_slicedir = $(prefix)/share/Ice/slice
++install_schemadir = $(prefix)/share/Ice/schema
++install_docdir = $(prefix)/doc/Ice-$(VERSION)
+
+ INSTALL = cp -fp
+ INSTALL_PROGRAM = ${INSTALL}
+@@ -184,9 +184,9 @@
+ DB_LIBS = -L$(DB_HOME)/$(libsubdir) -ldb_cxx
+ DB_RPATH_LINK = $(call rpathlink,$(DB_HOME)/$(libsubdir))
+ else
+- ifeq ($(shell if [ -d /usr/include/db45 -a -d /usr/$(libsubdir)/db45 ] ; then echo yes; fi), yes)
+- DB_FLAGS = -I/usr/include/db45
+- DB_LIBS = -L/usr/$(libsubdir)/db45 -ldb_cxx
++ ifeq ($(shell if [ -d /usr/include/db4.5 -a -d /usr/$(libsubdir) ] ; then echo yes; fi), yes)
++ DB_FLAGS = -I/usr/include/db4.5
++ DB_LIBS = -L/usr/$(libsubdir) -ldb_cxx-4.5
+ else
+ DB_LIBS = -ldb_cxx
+ endif
+--- Makefile.orig 2007-02-27 15:53:01.000000000 -0500
++++ Makefile 2007-02-27 15:54:20.000000000 -0500
+@@ -11,7 +11,7 @@
+
+ include $(top_srcdir)/config/Make.rules
+
+-SUBDIRS = config src include test demo slice doc
++SUBDIRS = config src include slice doc
+
+ INSTALL_SUBDIRS = $(install_bindir) $(install_libdir) $(install_includedir) $(install_slicedir) $(install_docdir)
+
+@@ -19,7 +19,7 @@
+ @if test ! -d $(prefix) ; \
+ then \
+ echo "Creating $(prefix)..." ; \
+- $(call mkdir,$(prefix)) ; \
++ mkdir -p $(prefix) ; \
+ fi
+ ifneq ($(embedded_runpath_prefix),)
+ @if test -h $(embedded_runpath_prefix) ; \
+@@ -55,8 +55,8 @@
+ then \
+ ( cd doc && $(MAKE) install ) || exit 1 ; \
+ fi
+- $(call installdata,ICE_LICENSE,$(prefix))
+- $(call installdata,LICENSE,$(prefix))
++ $(call installdata,ICE_LICENSE,$(install_docdir))
++ $(call installdata,LICENSE,$(install_docdir))
+
+ clean::
+ @if test -d doc ; \
+@@ -65,4 +65,5 @@
+ fi
+
+ test::
++ @( cd test && $(MAKE) ) || exit 1
+ @python $(top_srcdir)/allTests.py
diff --git a/dev-cpp/Ice/files/digest-Ice-3.2.0_beta1 b/dev-cpp/Ice/files/digest-Ice-3.2.0_beta1
new file mode 100644
index 000000000000..36ecfe3e3be2
--- /dev/null
+++ b/dev-cpp/Ice/files/digest-Ice-3.2.0_beta1
@@ -0,0 +1,3 @@
+MD5 778f585c690edeca1d8c5e818cc75f09 Ice-3.2b.tar.gz 2168682
+RMD160 eb24d040850471d66daafaee089f0525bc267b4e Ice-3.2b.tar.gz 2168682
+SHA256 44e1bec31175cfd0ae7d645e482eadc4f3cf839e2a4b4dca30091049ec1faf53 Ice-3.2b.tar.gz 2168682