summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2012-11-30 12:40:17 +0000
committerGeorge Shapovalov <george@gentoo.org>2012-11-30 12:40:17 +0000
commitb2648282823f7636f930d53503cca25dc403ace7 (patch)
treec76ea528ff9a78d111969c2f92bdb8c1ada68327 /dev-ada
parentSeems like part of the commit was not included in the branch. Fixes bug#445240. (diff)
downloadgentoo-2-b2648282823f7636f930d53503cca25dc403ace7.tar.gz
gentoo-2-b2648282823f7636f930d53503cca25dc403ace7.tar.bz2
gentoo-2-b2648282823f7636f930d53503cca25dc403ace7.zip
minor update, fixes #251873
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/cbind/ChangeLog10
-rw-r--r--dev-ada/cbind/cbind-6.0.1.ebuild28
-rw-r--r--dev-ada/cbind/cbind-6.0.ebuild5
3 files changed, 39 insertions, 4 deletions
diff --git a/dev-ada/cbind/ChangeLog b/dev-ada/cbind/ChangeLog
index 2842aa80fd25..140cd34b771e 100644
--- a/dev-ada/cbind/ChangeLog
+++ b/dev-ada/cbind/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ada/cbind
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ada/cbind/ChangeLog,v 1.14 2008/12/08 10:32:32 george Exp $
+# Copyright 2002-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/cbind/ChangeLog,v 1.15 2012/11/30 12:40:17 george Exp $
+
+*cbind-6.0.1 (30 Nov 2012)
+
+ 30 Nov 2012; George Shapovalov <george@gentoo.org> +cbind-6.0.1.ebuild,
+ cbind-6.0.ebuild:
+ minor update, fixes #251873
08 Dec 2008; George Shapovalov <george@gentoo.org> cbind-6.0.ebuild:
fixed MAKEOPTS setting (#250132)
diff --git a/dev-ada/cbind/cbind-6.0.1.ebuild b/dev-ada/cbind/cbind-6.0.1.ebuild
new file mode 100644
index 000000000000..61943321b79c
--- /dev/null
+++ b/dev-ada/cbind/cbind-6.0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/cbind/cbind-6.0.1.ebuild,v 1.1 2012/11/30 12:40:17 george Exp $
+
+# !NOTE!
+# this is a utility, no libs generated, no reason to do the gnat.eclass dance
+# so, "inherit gnat" should not appear here!
+
+DESCRIPTION="This tool is designed to aid in the creation of Ada bindings to C."
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+HOMEPAGE="http://www.rational.com/"
+LICENSE="GMGPL"
+
+DEPEND="virtual/ada"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+src_compile() {
+ MAKEOPTS="${MAKEOPTS} -j1" emake || die
+}
+
+src_install () {
+ make PREFIX="${D}"/usr/ install || die
+ dodoc README DOCS
+}
diff --git a/dev-ada/cbind/cbind-6.0.ebuild b/dev-ada/cbind/cbind-6.0.ebuild
index 8f737d3a9899..6c67936c03ee 100644
--- a/dev-ada/cbind/cbind-6.0.ebuild
+++ b/dev-ada/cbind/cbind-6.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ada/cbind/cbind-6.0.ebuild,v 1.7 2008/12/08 10:32:32 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/cbind/cbind-6.0.ebuild,v 1.8 2012/11/30 12:40:17 george Exp $
# !NOTE!
# this is a utility, no libs generated, no reason to do the gnat.eclass dance
@@ -12,6 +12,7 @@ HOMEPAGE="http://www.rational.com/"
LICENSE="GMGPL"
DEPEND="virtual/ada"
+RDEPEND="${DEPEND}"
SLOT="0"
KEYWORDS="~x86 ~amd64"