summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2009-03-24 14:30:58 +0000
committerGeorge Shapovalov <george@gentoo.org>2009-03-24 14:30:58 +0000
commit77f05d6ede569448d5f346951f91d3288f61efc7 (patch)
tree965b1cc2c6a14e42097e0d5241b5090abaa695bf /dev-ada
parentTaking maintainership for genstef (diff)
downloadgentoo-2-77f05d6ede569448d5f346951f91d3288f61efc7.tar.gz
gentoo-2-77f05d6ede569448d5f346951f91d3288f61efc7.tar.bz2
gentoo-2-77f05d6ede569448d5f346951f91d3288f61efc7.zip
added new version, upstream made it again compatible with new gnat (#250060)
(Portage version: 2.2_rc27/cvs/Linux x86_64)
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/aunit/ChangeLog10
-rw-r--r--dev-ada/aunit/aunit-2.03.ebuild50
2 files changed, 58 insertions, 2 deletions
diff --git a/dev-ada/aunit/ChangeLog b/dev-ada/aunit/ChangeLog
index 78d021641ead..3eabd2ec57f1 100644
--- a/dev-ada/aunit/ChangeLog
+++ b/dev-ada/aunit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ada/aunit
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ada/aunit/ChangeLog,v 1.12 2008/01/24 21:33:32 george Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/aunit/ChangeLog,v 1.13 2009/03/24 14:30:58 george Exp $
+
+*aunit-2.03 (24 Mar 2009)
+
+ 24 Mar 2009; George Shapovalov <george@gentoo.org> +aunit-2.03.ebuild:
+ added new version, upstream made it again compatible with new gnat
+ (#250060)
24 Jan 2008; George Shapovalov <george@gentoo.org> aunit-1.05.ebuild,
aunit-2.01.ebuild:
diff --git a/dev-ada/aunit/aunit-2.03.ebuild b/dev-ada/aunit/aunit-2.03.ebuild
new file mode 100644
index 000000000000..b25cdaf162d5
--- /dev/null
+++ b/dev-ada/aunit/aunit-2.03.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/aunit/aunit-2.03.ebuild,v 1.1 2009/03/24 14:30:58 george Exp $
+
+inherit gnat
+
+IUSE=""
+
+DESCRIPTION="Aunit, Ada unit testing framework"
+SRC_URI="http://dev.gentoo.org/~george/src/${P}.tar.bz2"
+HOMEPAGE="https://libre.adacore.com/aunit/"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+
+DEPEND="virtual/ada"
+
+lib_compile() {
+ cd aunit
+ SUPPORT_EXCEPTION=yes SUPPORT_CALENDAR=yes gnatmake -Paunit_build
+ SUPPORT_EXCEPTION=yes SUPPORT_CALENDAR=yes gnatmake -Paunit_build_dyn
+}
+
+lib_install() {
+ mv aunit/lib/* ${DL}
+ chmod 0444 ${DL}/*.ali
+}
+
+src_install () {
+ dodir ${AdalibSpecsDir}/${PN}
+ insinto ${AdalibSpecsDir}/${PN}
+ doins aunit/*/*.ad? aunit/framework/*/*.ad?
+
+ dodir ${AdalibDataDir}/${PN}
+ insinto ${AdalibDataDir}/${PN}
+ doins -r support/aunit.xml template/
+
+ #set up environment
+ echo "LDPATH=%DL%" > ${LibEnv}
+ echo "ADA_OBJECTS_PATH=%DL%" >> ${LibEnv}
+ echo "ADA_INCLUDE_PATH=/usr/include/ada/${PN}" >> ${LibEnv}
+
+ gnat_src_install
+
+ dodoc README docs/aunit.txt
+ dohtml docs/aunit.{html,css}
+ doinfo docs/aunit.info
+ cp -dPr test/ docs/aunit.pdf "${D}/usr/share/doc/${PF}"
+}