summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2003-10-28 12:12:43 +0000
committerDavid Holm <dholm@gentoo.org>2003-10-28 12:12:43 +0000
commit6eecccf6a08dc700bb0e17e6872a254ce5fe3772 (patch)
treeb34ddfe044f8a20d6040cd9a80608c1a8c54d1f0 /dev-ada
parentNew ebuild, xUnit testing framework for Ada (diff)
downloadgentoo-2-6eecccf6a08dc700bb0e17e6872a254ce5fe3772.tar.gz
gentoo-2-6eecccf6a08dc700bb0e17e6872a254ce5fe3772.tar.bz2
gentoo-2-6eecccf6a08dc700bb0e17e6872a254ce5fe3772.zip
New ebuild, xUnit testing framework for Ada
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/aunit/ChangeLog9
-rw-r--r--dev-ada/aunit/Manifest4
-rw-r--r--dev-ada/aunit/aunit-1.01.ebuild45
-rw-r--r--dev-ada/aunit/files/digest-aunit-1.011
-rw-r--r--dev-ada/aunit/metadata.xml6
5 files changed, 63 insertions, 2 deletions
diff --git a/dev-ada/aunit/ChangeLog b/dev-ada/aunit/ChangeLog
new file mode 100644
index 000000000000..d2bc5c56d492
--- /dev/null
+++ b/dev-ada/aunit/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-ada/aunit
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/aunit/ChangeLog,v 1.1 2003/10/28 12:12:36 dholm Exp $
+
+*aunit-1.01 (28 Oct 2003)
+
+ 28 Oct 2003; David Holm <dholm@gentoo.org> aunit-1.01.ebuild, metadata.xml:
+ Aunit provides an xUnit testing framework for Ada.
+
diff --git a/dev-ada/aunit/Manifest b/dev-ada/aunit/Manifest
index 0ea4fc678e2f..e862c749cd92 100644
--- a/dev-ada/aunit/Manifest
+++ b/dev-ada/aunit/Manifest
@@ -1,4 +1,4 @@
-MD5 620c76435733bf4192c82621d771d5e2 aunit-1.01.ebuild 1205
+MD5 78528b98adbd47d3f219ffc657d9dd3a aunit-1.01.ebuild 1298
MD5 0073e69559ad552ecd9a1091c106e6d5 metadata.xml 673
-MD5 767fff0e7e8fc987491d3942794a43a1 ChangeLog 281
+MD5 02eb3e83ed4c05d05334552043a7a04c ChangeLog 366
MD5 fa3fdc5b8a2b4efa5e436a011485c878 files/digest-aunit-1.01 61
diff --git a/dev-ada/aunit/aunit-1.01.ebuild b/dev-ada/aunit/aunit-1.01.ebuild
new file mode 100644
index 000000000000..b71214a3ce2f
--- /dev/null
+++ b/dev-ada/aunit/aunit-1.01.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/aunit/aunit-1.01.ebuild,v 1.1 2003/10/28 12:12:36 dholm Exp $
+
+IUSE=""
+
+inherit gnat
+
+DESCRIPTION="Aunit, Ada unit testing framework"
+SRC_URI="http://libre.act-europe.fr/aunit/aunit-1.01.tar.gz"
+
+HOMEPAGE="http://libre.act-europe.fr/aunit/"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+SLOT="0"
+
+DEPEND=">=dev-lang/gnat-3.14p"
+
+src_install () {
+ #makefile does not do much, so we need to install stuff manually
+ dodir /usr/lib/ada/adainclude/${PN}
+ chmod -x aunit/framework/text_reporter/*
+ cp aunit/framework/*.ad? aunit/text_reporter/*.ad? \
+ ${D}/usr/lib/ada/adainclude/${PN}
+
+ # Install documentation.
+ dodoc COPYING AUnit.html
+
+ dodir /usr/share/${PN}
+ cp -r template test ${D}/usr/share/${PN}
+
+ #set up environment
+ dodir /etc/env.d
+ echo "ADA_INCLUDE_PATH=\${ADA_INCLUDE_PATH}:/usr/lib/ada/adainclude/${PN}" \
+ >> ${D}/etc/env.d/55aunit
+}
+
+pkg_postinst(){
+ einfo "The envaironment has been set up to make gnat automatically find files for"
+ einfo "Aunit. In order to immediately activate these settings please do:"
+ einfo "env-update"
+ einfo "source /etc/profile"
+ einfo "Otherwise the settings will become active next time you login"
+}
diff --git a/dev-ada/aunit/files/digest-aunit-1.01 b/dev-ada/aunit/files/digest-aunit-1.01
new file mode 100644
index 000000000000..7868db9e1b5a
--- /dev/null
+++ b/dev-ada/aunit/files/digest-aunit-1.01
@@ -0,0 +1 @@
+MD5 2ee22dd2862eae1c23205df33f4ee4ff aunit-1.01.tar.gz 27221
diff --git a/dev-ada/aunit/metadata.xml b/dev-ada/aunit/metadata.xml
new file mode 100644
index 000000000000..83f771493132
--- /dev/null
+++ b/dev-ada/aunit/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ada</herd>
+<longdescription>AUnit is a set of Ada packages based on the xUnit family of unit test frameworks. It's intended as a developer's tool to facilitate confident writing and evolution of Ada software. It is purposely lightweight, as one of its main goals is to make it easy to develop and run unit tests, rather than to generate artifacts for process management. The framework supports easy composition of sets of unit tests to provide flexibility in determining what tests to run for a given purpose.</longdescription>
+</pkgmetadata>