summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2006-09-08 13:35:24 +0000
committerGeorge Shapovalov <george@gentoo.org>2006-09-08 13:35:24 +0000
commit2b940c4d7e080837a67f9396fa44a56949ff97de (patch)
tree86ad4bd903f86295437b85d715b0b83a6b6c8cf3 /dev-ada
parentStable on amd64 per bug #146793 (diff)
downloadgentoo-2-2b940c4d7e080837a67f9396fa44a56949ff97de.tar.gz
gentoo-2-2b940c4d7e080837a67f9396fa44a56949ff97de.tar.bz2
gentoo-2-2b940c4d7e080837a67f9396fa44a56949ff97de.zip
added new version to go with gnat-gcc-3.4.6.2006. Removed ppc from KEYWORDS of 3.15p
(Portage version: 2.1.1_rc1-r4)
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/asis/ChangeLog11
-rw-r--r--dev-ada/asis/asis-3.15p.ebuild4
-rw-r--r--dev-ada/asis/asis-3.4.6.2006.ebuild133
-rw-r--r--dev-ada/asis/files/digest-asis-3.4.6.20063
4 files changed, 148 insertions, 3 deletions
diff --git a/dev-ada/asis/ChangeLog b/dev-ada/asis/ChangeLog
index 0c90b20c4b49..23358e863c5c 100644
--- a/dev-ada/asis/ChangeLog
+++ b/dev-ada/asis/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-ada/asis
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ada/asis/ChangeLog,v 1.19 2006/05/13 21:26:23 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/asis/ChangeLog,v 1.20 2006/09/08 13:35:24 george Exp $
+
+*asis-3.4.6.2006 (08 Sep 2006)
+
+ 08 Sep 2006; George Shapovalov <george@gentoo.org>
+ +asis-3.4.6.2006.ebuild, asis-3.15p.ebuild:
+ added new version to go with gnat-gcc-3.4.6.2006. Installs into gnat's dirs,
+ extending the compiler (as it is supposed). See #111340 for details
+ Removed ppc from KEYWORDS of 3.15p as gnat-3.15p is masked in ppc profile
+ (and will soon be pulled anyways).
13 May 2006; George Shapovalov <george@gentoo.org> asis-3.15p.ebuild,
asis-3.44.ebuild:
diff --git a/dev-ada/asis/asis-3.15p.ebuild b/dev-ada/asis/asis-3.15p.ebuild
index e85885358f4f..6abce8a145c0 100644
--- a/dev-ada/asis/asis-3.15p.ebuild
+++ b/dev-ada/asis/asis-3.15p.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ada/asis/asis-3.15p.ebuild,v 1.16 2006/05/13 21:26:23 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/asis/asis-3.15p.ebuild,v 1.17 2006/09/08 13:35:24 george Exp $
inherit eutils
@@ -14,7 +14,7 @@ DEPEND="=dev-lang/gnat-3.15p*"
RDEPEND=""
SLOT="0"
-KEYWORDS="x86 ppc"
+KEYWORDS="x86"
IUSE=""
src_unpack() {
diff --git a/dev-ada/asis/asis-3.4.6.2006.ebuild b/dev-ada/asis/asis-3.4.6.2006.ebuild
new file mode 100644
index 000000000000..7583337572e7
--- /dev/null
+++ b/dev-ada/asis/asis-3.4.6.2006.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/asis/asis-3.4.6.2006.ebuild,v 1.1 2006/09/08 13:35:24 george Exp $
+
+inherit eutils flag-o-matic gnatbuild
+
+ACT_Ver=$(get_version_component_range 4)
+Gnat_Name="gnat-gpl"
+
+S="${WORKDIR}/asis-${ACT_Ver}-src"
+DESCRIPTION="The Ada Semantic Interface Specification (semantic analysis and tools tied to compiler)"
+SRC_URI="http://dev.gentoo.org/~george/src/asis-gpl-${ACT_Ver}-src.tgz"
+
+HOMEPAGE="https://libre2.adacore.com/"
+
+LICENSE="GPL-2"
+
+IUSE="doc"
+RDEPEND="=dev-lang/gnat-gpl-${PV}*"
+DEPEND="${RDEPEND}
+ doc? ( virtual/tetex
+ app-text/texi2html )"
+
+# saving slot as defined in gnatbuild.eclass
+eSLOT=${SLOT}
+# To avoid having two packages we combine both te name indication and the slot
+# from gnatbuild.eclass in ASIS' SLOT
+# eSLOT depends only on PV, so it is really static
+SLOT="ACT-${eSLOT}"
+
+KEYWORDS="~amd64 ~x86"
+#IUSE="doc"
+
+# it may be even better to force plain -O2 -pipe -ftracer here
+replace-flags -O3 -O2
+
+
+pkg_setup() {
+ currGnat=$(eselect --no-color gnat show | grep "gnat-" | awk '{ print $1 }')
+ if [[ "${currGnat}" != "${CTARGET}-${Gnat_Name}-${eSLOT}" ]]; then
+ echo
+ eerror "The active gnat profile does not correspond to the selected"
+ eerror "version of asis! Please install the appropriate gnat (if you"
+ eerror "did not so yet) and run:"
+ einfo "eselect gnat set ${CTARGET}-${Gnat_Name}-${eSLOT}"
+ eerror "and then emerge =dev-ada/asis-${PV} again.."
+ echo
+ die
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ sed -i -e "s:\"gcc\":\"gnatgcc\":" asis/a4g-contt.adb
+ sed -i -e "s:\"gcc\":\"gnatgcc\":" \
+ -e "s:environment settings for gcc:environment for gnatgcc:" \
+ asis/a4g-gnat_int.adb
+ sed -i -e "s:\"gcc#\":\"gnatgcc#\":" gnat/snames.adb
+}
+
+
+src_compile() {
+ # Build the shared library first, we need -fPIC here
+ gnatmake -Pasis_bld -XBLD=prod -XOPSYS=default_Unix -cargs ${CFLAGS} -fPIC \
+ || die "building libasis.a failed"
+ gnatgcc -shared -Wl,-soname,libasis-${ACT_Ver}.so \
+ -o obj/libasis-${ACT_Ver}.so obj/*.o -lc \
+ || die "building libasis.so failed"
+
+ # build tools
+ for fn in tools/*; do
+ pushd ${fn}
+ gnatmake -P${fn:6}.gpr || die "building ${fn:6} failed"
+ popd
+ done
+
+ # common stuff is just docs in this case
+ if use doc; then
+ emake -C documentation all || die "Failed while compiling documentation"
+ fi
+}
+
+
+src_install () {
+ # we need to adjust some vars defined in gnatbuild.eclass so that they use
+ # gnat-gpl instead of asis
+ LIBPATH=${LIBPATH/${PN}/${Gnat_Name}}
+ BINPATH=${BINPATH/${PN}/${Gnat_Name}}
+ DATAPATH=${DATAPATH/${PN}/${Gnat_Name}}
+
+ # install the lib
+ mkdir -p ${D}${LIBPATH}/adalib
+ chmod 0755 obj/libasis-${ACT_Ver}.so
+ cp obj/libasis-${ACT_Ver}.so ${D}${LIBPATH}/adalib
+ insinto ${LIBPATH}/adalib
+ doins obj/*.ali
+ chmod 0644 lib/libasis.a
+ newins lib/libasis.a libasis-${ACT_Ver}.a
+ # make appropriate symlinks
+ cd ${D}${LIBPATH}/adalib
+ ln -s libasis-${ACT_Ver}.so libasis.so
+ ln -s libasis-${ACT_Ver}.a libasis.a
+ cd ${S}
+ # sources
+ insinto ${LIBPATH}/adainclude
+ doins gnat/*.ad[sb]
+ doins asis/*.ad[sb]
+
+ # tools
+ mkdir -p ${D}${BINPATH}
+ for fn in tools/{asistant,gnat*}; do
+ cp ${fn}/${fn:6} ${D}${BINPATH}
+ done
+
+ # docs and examples
+ dodoc documentation/*.txt
+ dohtml documentation/*.html
+ # info's should go into gnat-gpl dirs
+ insinto ${DATAPATH}/info/
+ doins documentation/*.info
+
+ insinto /usr/share/doc/${PF}
+ doins -r documentation/*.pdf examples/ tutorial/ templates/
+}
+
+pkg_postinst() {
+ echo
+ einfo "The ASIS is installed for the active gnat compiler at gnat's location."
+ einfo "No further configuration is necessary. Enjoy."
+ echo
+}
diff --git a/dev-ada/asis/files/digest-asis-3.4.6.2006 b/dev-ada/asis/files/digest-asis-3.4.6.2006
new file mode 100644
index 000000000000..b133ac0d47ab
--- /dev/null
+++ b/dev-ada/asis/files/digest-asis-3.4.6.2006
@@ -0,0 +1,3 @@
+MD5 f415da57e567ee77e55ba192bf40a954 asis-gpl-2006-src.tgz 2118559
+RMD160 e1ea4792f2a1ff34762f5362054f9560528d9629 asis-gpl-2006-src.tgz 2118559
+SHA256 61838a94b19bd8a132c6053ee691ab51b39a54fd1bd10c98d9a10efd63663e2d asis-gpl-2006-src.tgz 2118559