summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-03 10:37:38 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-03 10:37:38 +0000
commitcabee1c8d8af5ffadb720e7ee41d046abd0befab (patch)
treef64629a13bc071d524215771f23e85f186c8ccdb /berlin-base
parentiproute2 now commented-out (diff)
downloadgentoo-2-cabee1c8d8af5ffadb720e7ee41d046abd0befab.tar.gz
gentoo-2-cabee1c8d8af5ffadb720e7ee41d046abd0befab.tar.bz2
gentoo-2-cabee1c8d8af5ffadb720e7ee41d046abd0befab.zip
Added cfg generation and init.d script
Diffstat (limited to 'berlin-base')
-rwxr-xr-xberlin-base/omniORB/files/omniORB35
-rw-r--r--berlin-base/omniORB/omniORB-303.ebuild12
2 files changed, 45 insertions, 2 deletions
diff --git a/berlin-base/omniORB/files/omniORB b/berlin-base/omniORB/files/omniORB
new file mode 100755
index 000000000000..1d1e4a6a54da
--- /dev/null
+++ b/berlin-base/omniORB/files/omniORB
@@ -0,0 +1,35 @@
+#!/bin/sh
+#RCUPDATE:3 4:75:This line is required for script management
+
+. /etc/rc.d/config/functions
+
+SERVICE=omniORB
+EXE="/opt/berlin/bin/omniNames"
+opts="start stop restart"
+
+start() {
+ if [ ! -d "/var/log/omniORB" ] ; then
+ install -d /var/log/omniORB
+ fi
+ if [ "/var/log/omniORB/omninames*" ] ; then
+ rm -f /var/log/omniORB/omninames*
+ fi
+ ebegin "Starting ${SERVICE}"
+ exec $EXE -start 8200 -logdir /var/log/omniORB -errlog /var/log/omniORB/omniORB.errors 1>&2 &
+ eend $? "Error starting ${SERVICE}."
+}
+
+stop() {
+ ebegin "Stopping ${SERVICE}"
+ killall $EXE 1>&2
+ eend $? "Error stopping ${SERVICE}."
+}
+
+restart() {
+ stop
+ start
+}
+
+doservice ${@}
+
+
diff --git a/berlin-base/omniORB/omniORB-303.ebuild b/berlin-base/omniORB/omniORB-303.ebuild
index 2df05f70527b..75ca314a42b0 100644
--- a/berlin-base/omniORB/omniORB-303.ebuild
+++ b/berlin-base/omniORB/omniORB-303.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Your Name <your email>
-# $Header: /var/cvsroot/gentoo-x86/berlin-base/omniORB/omniORB-303.ebuild,v 1.4 2001/05/02 22:48:26 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/berlin-base/omniORB/omniORB-303.ebuild,v 1.5 2001/05/03 10:37:38 achim Exp $
A="${PN}_${PV}.tar.gz omniORBpy_1_3.tar.gz"
S=${WORKDIR}/omni
@@ -63,6 +63,9 @@ src_install () {
cp -af lib/python/* ${D}/${T}/lib/python/
doman man/man[15]/*.[15]
+ exeinto /etc/rc.d/init.d
+ doexe ${FILESDIR}/omniORB
+
dodoc CHANGES* COPYING* CREDITS PORTING README* ReleaseNote_omniORB_303 THIS_IS_omniORB_3_0_3
cd doc
docinto print
@@ -76,4 +79,9 @@ src_install () {
dodoc omniORB/*.{gif,html}
}
-
+pkg_postinst() {
+ if [ ! -e "${ROOT}etc/omniORB.cfg" ] ; then
+ echo "ORBInintialHost `uname -n`" > ${ROOT}etc/omniORB.cfg
+ echo "ORBInitialPort 8200" > ${ROOT}etc/omniORB.cfg
+ fi
+}