summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2013-07-06 20:52:28 +0000
committerUlrich Müller <ulm@gentoo.org>2013-07-06 20:52:28 +0000
commit7858dc80d647d0f0366f4b1b7ca911c818ab3d09 (patch)
tree933233b5b4a84db24edc55bf930b7cade898990a /app-xemacs
parentVersion bump. Stop sed-ing upstream's version requirements out of pavement.py. (diff)
downloadgentoo-2-7858dc80d647d0f0366f4b1b7ca911c818ab3d09.tar.gz
gentoo-2-7858dc80d647d0f0366f4b1b7ca911c818ab3d09.tar.bz2
gentoo-2-7858dc80d647d0f0366f4b1b7ca911c818ab3d09.zip
Fix compile failure, bug 395897 comment #1. Remove old.
(Portage version: 2.1.12.11/cvs/Linux x86_64, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'app-xemacs')
-rw-r--r--app-xemacs/gentoo-syntax/ChangeLog8
-rw-r--r--app-xemacs/gentoo-syntax/gentoo-syntax-1.18.ebuild17
-rw-r--r--app-xemacs/gentoo-syntax/gentoo-syntax-1.19.ebuild12
3 files changed, 15 insertions, 22 deletions
diff --git a/app-xemacs/gentoo-syntax/ChangeLog b/app-xemacs/gentoo-syntax/ChangeLog
index fdd90f2ae578..9d99b855bd15 100644
--- a/app-xemacs/gentoo-syntax/ChangeLog
+++ b/app-xemacs/gentoo-syntax/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-xemacs/gentoo-syntax
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-xemacs/gentoo-syntax/ChangeLog,v 1.29 2012/06/08 12:02:12 phajdan.jr Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-xemacs/gentoo-syntax/ChangeLog,v 1.30 2013/07/06 20:52:28 ulm Exp $
+
+ 06 Jul 2013; Ulrich Müller <ulm@gentoo.org> -gentoo-syntax-1.18.ebuild,
+ gentoo-syntax-1.19.ebuild:
+ Fix compile failure, bug 395897 comment #1. Remove old.
08 Jun 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org>
gentoo-syntax-1.19.ebuild:
diff --git a/app-xemacs/gentoo-syntax/gentoo-syntax-1.18.ebuild b/app-xemacs/gentoo-syntax/gentoo-syntax-1.18.ebuild
deleted file mode 100644
index dd202e97ae80..000000000000
--- a/app-xemacs/gentoo-syntax/gentoo-syntax-1.18.ebuild
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-xemacs/gentoo-syntax/gentoo-syntax-1.18.ebuild,v 1.3 2012/01/04 18:20:54 phajdan.jr Exp $
-
-inherit xemacs-elisp eutils
-
-DESCRIPTION="An Emacs mode for editing ebuilds and other Gentoo specific files."
-HOMEPAGE="http://www.gentoo.org/proj/en/lisp/emacs/index.xml"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-RDEPEND=">=app-editors/xemacs-21.4.20-r5
- app-xemacs/sh-script"
-DEPEND="${RDEPEND}"
diff --git a/app-xemacs/gentoo-syntax/gentoo-syntax-1.19.ebuild b/app-xemacs/gentoo-syntax/gentoo-syntax-1.19.ebuild
index ffc2f67c64eb..4c60a100bbf8 100644
--- a/app-xemacs/gentoo-syntax/gentoo-syntax-1.19.ebuild
+++ b/app-xemacs/gentoo-syntax/gentoo-syntax-1.19.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-xemacs/gentoo-syntax/gentoo-syntax-1.19.ebuild,v 1.3 2012/06/08 12:02:12 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-xemacs/gentoo-syntax/gentoo-syntax-1.19.ebuild,v 1.4 2013/07/06 20:52:28 ulm Exp $
inherit xemacs-elisp eutils
DESCRIPTION="An Emacs mode for editing ebuilds and other Gentoo specific files."
HOMEPAGE="http://www.gentoo.org/proj/en/lisp/emacs/index.xml"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
@@ -15,3 +15,9 @@ IUSE=""
RDEPEND=">=app-editors/xemacs-21.4.20-r5
app-xemacs/sh-script"
DEPEND="${RDEPEND}"
+
+src_compile() {
+ ${XEMACS_BATCH_CLEAN} -eval "(add-to-list 'load-path \".\")" \
+ -f batch-byte-compile gentoo-syntax.el || die
+ xemacs-elisp-make-autoload-file *.el || die
+}