summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2013-07-06 22:07:30 +0000
committerUlrich Müller <ulm@gentoo.org>2013-07-06 22:07:30 +0000
commitc2baed86316abc0eedf35aa0df46bf04d2f0ecc2 (patch)
tree76478965995a0c871c2e33bc9e8a39112edabf38 /app-xemacs/ebuild-mode/ebuild-mode-1.19.ebuild
parentstable amd64, x86 wrt #474384 (diff)
downloadgentoo-2-c2baed86316abc0eedf35aa0df46bf04d2f0ecc2.tar.gz
gentoo-2-c2baed86316abc0eedf35aa0df46bf04d2f0ecc2.tar.bz2
gentoo-2-c2baed86316abc0eedf35aa0df46bf04d2f0ecc2.zip
Version bump. Move app-xemacs/gentoo-syntax to app-xemacs/ebuild-mode.
(Portage version: 2.1.12.11/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 9433907D693FB5B8!)
Diffstat (limited to 'app-xemacs/ebuild-mode/ebuild-mode-1.19.ebuild')
-rw-r--r--app-xemacs/ebuild-mode/ebuild-mode-1.19.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-xemacs/ebuild-mode/ebuild-mode-1.19.ebuild b/app-xemacs/ebuild-mode/ebuild-mode-1.19.ebuild
new file mode 100644
index 000000000000..7c918f9ffe0a
--- /dev/null
+++ b/app-xemacs/ebuild-mode/ebuild-mode-1.19.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-xemacs/ebuild-mode/ebuild-mode-1.19.ebuild,v 1.1 2013/07/06 22:07:30 ulm Exp $
+
+inherit xemacs-elisp eutils
+
+MY_PN="gentoo-syntax"
+DESCRIPTION="An Emacs mode for editing ebuilds and other Gentoo specific files."
+HOMEPAGE="http://www.gentoo.org/proj/en/lisp/emacs/index.xml"
+SRC_URI="mirror://gentoo/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=app-editors/xemacs-21.4.20-r5
+ app-xemacs/sh-script"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_compile() {
+ ${XEMACS_BATCH_CLEAN} -eval "(add-to-list 'load-path \".\")" \
+ -f batch-byte-compile gentoo-syntax.el || die
+ xemacs-elisp-make-autoload-file *.el || die
+}