summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-08-03 10:25:05 +0000
committerTim Harder <radhermit@gentoo.org>2012-08-03 10:25:05 +0000
commitfd29a5387ea39523e444958c34cb56a11d75746b (patch)
tree6d7f1398976dab4e6460b60b67b5d89b66d89a0e /app-vim
parentRemove old. (diff)
downloadgentoo-2-fd29a5387ea39523e444958c34cb56a11d75746b.tar.gz
gentoo-2-fd29a5387ea39523e444958c34cb56a11d75746b.tar.bz2
gentoo-2-fd29a5387ea39523e444958c34cb56a11d75746b.zip
Initial import. Required by new versions of app-vim/gist.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/webapi/ChangeLog10
-rw-r--r--app-vim/webapi/Manifest4
-rw-r--r--app-vim/webapi/metadata.xml5
-rw-r--r--app-vim/webapi/webapi-0.1.ebuild17
4 files changed, 36 insertions, 0 deletions
diff --git a/app-vim/webapi/ChangeLog b/app-vim/webapi/ChangeLog
new file mode 100644
index 000000000000..6367321e17ed
--- /dev/null
+++ b/app-vim/webapi/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-vim/webapi
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/webapi/ChangeLog,v 1.1 2012/08/03 10:25:05 radhermit Exp $
+
+*webapi-0.1 (03 Aug 2012)
+
+ 03 Aug 2012; Tim Harder <radhermit@gentoo.org> +webapi-0.1.ebuild,
+ +metadata.xml:
+ Initial import. Required by new versions of app-vim/gist.
+
diff --git a/app-vim/webapi/Manifest b/app-vim/webapi/Manifest
new file mode 100644
index 000000000000..2292da124943
--- /dev/null
+++ b/app-vim/webapi/Manifest
@@ -0,0 +1,4 @@
+DIST webapi-0.1.tar.bz2 19686 SHA256 250f51f3dfbffe6b91864429df3cb98b6a5cce64c1d99fdcab0e348de214de6d SHA512 9bc4e34876b19e60cda06d6c4ccb7ca0dbed235b30b2c1407e057170bca40e17d7aa7557a51e4b64cfc16a46acda3d6012d9cdeca5029ce98ac8c8313f708f95 WHIRLPOOL c30767b12c428e98e438f052422ce407787fd0c36b67c4030789b9657c7436384c7764422ffc19c90d0632a5fc9aa7529484796bd54796fa13a99273c537a68a
+EBUILD webapi-0.1.ebuild 365 SHA256 827a593e3bc1c111b598380e2154d88b69fd4290f4fcfc381dbe8798b3f71e94 SHA512 fda843d083cd4e4b718555d04df6abf9be353168afc53e80e0e8f09f750a79a84d52faebf442f2f85bb74891b725309d057cce25c2232515938906073b08055f WHIRLPOOL 21bc83106b81272f22b7e02aa5d1ea186cde58d93ac12b9566f3cef440b8bf863d1f5d38f69404bc8d09623678c919439c44c1fbf99c79cd77552c41f09b9221
+MISC ChangeLog 289 SHA256 b137fd24d26dca4d8ce4dd824a898be75564ff915f0d884edf9e32bf3ad1bd26 SHA512 07eb860c6425f0f9786c1bbaaf65d63aa7ade8f761fbca26b5623fbd5d3e2b304d70b213b2dbcd483d4d27fdc8832166561581fb11c8b6bc33230649e785dd77 WHIRLPOOL 177f8bd7903e48d2eab8abdd672ff7756ebc4af16826c57b4f55441c0dd75dd18cde3b76ecb5c705dba63addcf49ab079b109e41498126733349add3377606c0
+MISC metadata.xml 156 SHA256 64d20c782589b423a6e75ba6fff7edead1ec8fbae742d27dd57f5299e8328500 SHA512 7dc1d902106e794e1a12bde5dcacb8b7143584cba9c61e72ac5728dd952663144c1b0efc949fbbc9fcec03b396b5e060e8263eaad7d70cd82d6d5b350c62f0c1 WHIRLPOOL 4381a5d144e783e5979d394720b32f7d95818a8571f748e72c5ece965c4e0375b1aec0c34f6f506a9f9fc255f1b69a220fdb74d1dbb8aabc92ec48afa44ab883
diff --git a/app-vim/webapi/metadata.xml b/app-vim/webapi/metadata.xml
new file mode 100644
index 000000000000..5fcb67350f69
--- /dev/null
+++ b/app-vim/webapi/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>vim</herd>
+</pkgmetadata>
diff --git a/app-vim/webapi/webapi-0.1.ebuild b/app-vim/webapi/webapi-0.1.ebuild
new file mode 100644
index 000000000000..25d0be6c4fa5
--- /dev/null
+++ b/app-vim/webapi/webapi-0.1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/webapi/webapi-0.1.ebuild,v 1.1 2012/08/03 10:25:05 radhermit Exp $
+
+EAPI=4
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: interface to Web APIs"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=4019"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-misc/curl"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"