summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2015-02-10 11:59:52 +0000
committerJauhien Piatlicki <jauhien@gentoo.org>2015-02-10 11:59:52 +0000
commitb96c40c097a2dc6de497537a962227a52d5b5808 (patch)
tree324b0616fd7a0abe98e76dd55e32257dfa7cac7a /app-vim
parentDrop myself from metadata, add maintainer-needed (diff)
downloadgentoo-2-b96c40c097a2dc6de497537a962227a52d5b5808.tar.gz
gentoo-2-b96c40c097a2dc6de497537a962227a52d5b5808.tar.bz2
gentoo-2-b96c40c097a2dc6de497537a962227a52d5b5808.zip
version bump, move live ebuild to rust overlay
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0xB2EFA1D4)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/rust-mode/ChangeLog11
-rw-r--r--app-vim/rust-mode/rust-mode-0.11.0.ebuild23
-rw-r--r--app-vim/rust-mode/rust-mode-0.12.0.ebuild23
-rw-r--r--app-vim/rust-mode/rust-mode-1.0.0_alpha.ebuild18
-rw-r--r--app-vim/rust-mode/rust-mode-9999.ebuild23
5 files changed, 27 insertions, 71 deletions
diff --git a/app-vim/rust-mode/ChangeLog b/app-vim/rust-mode/ChangeLog
index 19b05ecb5ea8..7182db3a4e0c 100644
--- a/app-vim/rust-mode/ChangeLog
+++ b/app-vim/rust-mode/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-vim/rust-mode
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/rust-mode/ChangeLog,v 1.2 2014/10/18 12:43:35 jauhien Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/rust-mode/ChangeLog,v 1.3 2015/02/10 11:59:52 jauhien Exp $
+
+*rust-mode-1.0.0_alpha (10 Feb 2015)
+
+ 10 Feb 2015; Jauhien Piatlicki <jauhien@gentoo.org>
+ +rust-mode-1.0.0_alpha.ebuild, -rust-mode-0.11.0.ebuild,
+ -rust-mode-0.12.0.ebuild, -rust-mode-9999.ebuild:
+ version bump, move live ebuild to rust overlay
*rust-mode-9999 (18 Oct 2014)
diff --git a/app-vim/rust-mode/rust-mode-0.11.0.ebuild b/app-vim/rust-mode/rust-mode-0.11.0.ebuild
deleted file mode 100644
index 0ca05957c8d5..000000000000
--- a/app-vim/rust-mode/rust-mode-0.11.0.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/rust-mode/rust-mode-0.11.0.ebuild,v 1.1 2014/10/18 11:50:31 jauhien Exp $
-
-EAPI="5"
-
-inherit vim-plugin
-
-DESCRIPTION="Rust mode for vim"
-HOMEPAGE="http://www.rust-lang.org/"
-SRC_URI="http://static.rust-lang.org/dist/rust-${PV}.tar.gz"
-
-LICENSE="|| ( MIT Apache-2.0 )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="!!<=app-admin/eselect-rust-0.1_pre20140820
- !<=dev-lang/rust-0.11.0-r1:0.11
- !<=dev-lang/rust-999:nightly
- !<=dev-lang/rust-9999-r2:git
-"
-
-S="${WORKDIR}/rust-${PV}/src/etc/vim"
diff --git a/app-vim/rust-mode/rust-mode-0.12.0.ebuild b/app-vim/rust-mode/rust-mode-0.12.0.ebuild
deleted file mode 100644
index 4f9e93b822a2..000000000000
--- a/app-vim/rust-mode/rust-mode-0.12.0.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/rust-mode/rust-mode-0.12.0.ebuild,v 1.1 2014/10/18 11:50:31 jauhien Exp $
-
-EAPI="5"
-
-inherit vim-plugin
-
-DESCRIPTION="Rust mode for vim"
-HOMEPAGE="http://www.rust-lang.org/"
-SRC_URI="http://static.rust-lang.org/dist/rust-${PV}.tar.gz"
-
-LICENSE="|| ( MIT Apache-2.0 )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="!!<=app-admin/eselect-rust-0.1_pre20140820
- !<=dev-lang/rust-0.11.0-r1:0.11
- !<=dev-lang/rust-999:nightly
- !<=dev-lang/rust-9999-r2:git
-"
-
-S="${WORKDIR}/rust-${PV}/src/etc/vim"
diff --git a/app-vim/rust-mode/rust-mode-1.0.0_alpha.ebuild b/app-vim/rust-mode/rust-mode-1.0.0_alpha.ebuild
new file mode 100644
index 000000000000..0750a045a006
--- /dev/null
+++ b/app-vim/rust-mode/rust-mode-1.0.0_alpha.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/rust-mode/rust-mode-1.0.0_alpha.ebuild,v 1.1 2015/02/10 11:59:52 jauhien Exp $
+
+EAPI="5"
+
+inherit vim-plugin
+
+MY_PV="rustc-1.0.0-alpha"
+DESCRIPTION="Rust mode for vim"
+HOMEPAGE="http://www.rust-lang.org/"
+SRC_URI="http://static.rust-lang.org/dist/${MY_PV}-src.tar.gz"
+
+LICENSE="|| ( MIT Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${MY_PV}/src/etc/vim"
diff --git a/app-vim/rust-mode/rust-mode-9999.ebuild b/app-vim/rust-mode/rust-mode-9999.ebuild
deleted file mode 100644
index 2a740a468737..000000000000
--- a/app-vim/rust-mode/rust-mode-9999.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/rust-mode/rust-mode-9999.ebuild,v 1.1 2014/10/18 12:43:35 jauhien Exp $
-
-EAPI="5"
-
-inherit vim-plugin git-r3
-
-DESCRIPTION="Rust mode for vim"
-HOMEPAGE="http://www.rust-lang.org/"
-EGIT_REPO_URI="git://github.com/rust-lang/rust.git"
-
-LICENSE="|| ( MIT Apache-2.0 )"
-SLOT="0"
-KEYWORDS=""
-
-DEPEND="!!<=app-admin/eselect-rust-0.1_pre20140820
- !<=dev-lang/rust-0.11.0-r1:0.11
- !<=dev-lang/rust-999:nightly
- !<=dev-lang/rust-9999-r2:git
-"
-
-S="${S}/src/etc/vim"