summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Kelly <pioto@gentoo.org>2006-09-21 14:25:15 +0000
committerMike Kelly <pioto@gentoo.org>2006-09-21 14:25:15 +0000
commit9c81fa83c8820142bc388f86dbc9da8000ea3e5d (patch)
tree35123130528489abfe0d7af4be398879cc80d733 /app-vim
parentre-add gnome deps to compiz (diff)
downloadgentoo-2-9c81fa83c8820142bc388f86dbc9da8000ea3e5d.tar.gz
gentoo-2-9c81fa83c8820142bc388f86dbc9da8000ea3e5d.tar.bz2
gentoo-2-9c81fa83c8820142bc388f86dbc9da8000ea3e5d.zip
Version bump, thanks to TGL (bug #128990).
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/cream/ChangeLog7
-rw-r--r--app-vim/cream/cream-0.36.ebuild154
-rw-r--r--app-vim/cream/files/digest-cream-0.3615
3 files changed, 175 insertions, 1 deletions
diff --git a/app-vim/cream/ChangeLog b/app-vim/cream/ChangeLog
index 458be9910930..0ad14c79c4bf 100644
--- a/app-vim/cream/ChangeLog
+++ b/app-vim/cream/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/cream
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/cream/ChangeLog,v 1.31 2006/09/16 14:42:35 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/cream/ChangeLog,v 1.32 2006/09/21 14:25:15 pioto Exp $
+
+*cream-0.36 (21 Sep 2006)
+
+ 21 Sep 2006; Mike Kelly <pioto@pioto.org> +cream-0.36.ebuild:
+ Version bump, thanks to TGL (bug #128990).
16 Sep 2006; Tobias Scherbaum <dertobi123@gentoo.org> cream-0.34.ebuild:
ppc stable
diff --git a/app-vim/cream/cream-0.36.ebuild b/app-vim/cream/cream-0.36.ebuild
new file mode 100644
index 000000000000..568aff9a24ec
--- /dev/null
+++ b/app-vim/cream/cream-0.36.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/cream/cream-0.36.ebuild,v 1.1 2006/09/21 14:25:15 pioto Exp $
+
+inherit vim-plugin eutils fdo-mime
+
+DESCRIPTION="An easy-to-use configuration of the GVim text editor"
+HOMEPAGE="http://cream.sourceforge.net"
+
+DICT_EN="eng_2.0.2"
+DICT_FR="fre_2.1"
+DICT_ES="spa_3.0"
+DICT_DE="ger_2.0.1"
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ linguas_en? ( ${HOMEPAGE}/cream-spell-dict-${DICT_EN}.zip )
+ linguas_fr? ( ${HOMEPAGE}/cream-spell-dict-${DICT_FR}.zip )
+ linguas_es? ( ${HOMEPAGE}/cream-spell-dict-${DICT_ES}.zip )
+ linguas_de? ( ${HOMEPAGE}/cream-spell-dict-${DICT_DE}.zip )"
+
+IUSE="linguas_en linguas_fr linguas_es linguas_de"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+
+DEPEND="
+ >=app-editors/gvim-6.4
+ app-arch/unzip"
+RDEPEND="
+ >=app-editors/gvim-6.4
+ dev-util/ctags"
+
+VIM_PLUGIN_HELPTEXT=\
+"Cream is completly independent from the rest of your Vim/GVim setup.
+To launch GVim in Cream mode, use this wrapper script:
+\ % cream [filename...]
+
+Cream's documentation has been installed in ${ROOT}usr/share/doc/${PF}
+In particular, you may want to read:
+
+\ - the Cream features list:
+file://${ROOT}usr/share/doc/${PF}/html/features.html
+
+\ - the Cream shortcuts list:
+file://${ROOT}usr/share/doc/${PF}/html/keyboardshortcuts.html
+
+\ - the Cream FAQ:
+file://${ROOT}usr/share/doc/${PF}/html/faq.html"
+
+# Utility function to rename a Vim help file and its links/anchors:
+# prefix_help_file prefix file [pattern ...]
+prefix_help_file() {
+ local prefix="${1}" ; shift
+ local helpfile="${1}" ; shift
+ while [[ -n "${1}" ]] ; do
+ sed -i "s:\([*|]\)\(${1}[*|]\):\1${prefix}-\2:g" "${helpfile}" \
+ || die "Failed to sed \"${1}\" on \"${helpfile}\""
+ shift
+ done
+ mv "${helpfile}" "${helpfile%/*}/${prefix}-${helpfile##*/}" \
+ || die "Failed to rename \"${helpfile}\""
+}
+
+src_unpack() {
+ mkdir -p ${S}/spelldicts
+
+ # install spell dictionaries into ${S}/spelldicts
+ local my_a
+ for my_a in ${A} ; do
+ if [ -z ${my_a/*spell-dict*/} ] ; then
+ cd ${S}/spelldicts
+ unpack ${my_a}
+ else
+ cd ${WORKDIR}
+ unpack ${my_a}
+ fi
+ done
+
+ # change installation path + fix the wrapper command (disable plugins)
+ cd ${S}
+ cat >cream <<EOF
+#!/bin/sh
+gvim --noplugin -U NONE -u "\\\$VIM/cream/creamrc" "\$@"
+EOF
+ sed -i "/let \$CREAM/s:VIMRUNTIME:VIM:" creamrc || die "sed #1 broke"
+
+ # make taglist ebuild aware, bug #66052
+ epatch ${FILESDIR}/${PN}-0.30-ebuilds.patch
+
+ # more filetypes for EnhancedCommentify, including the Gentoo ones
+ epatch ${FILESDIR}/enhancedcommentify-2.1-gentooisms.patch
+ epatch ${FILESDIR}/enhancedcommentify-2.1-extra-ft-support.patch
+
+ # rename vim help files to avoid conflicts with other vim packages
+ prefix_help_file cream help/EnhancedCommentify.txt \
+ 'EnhancedCommentify' 'EnhComm-[a-zA-Z]\+'
+ prefix_help_file cream help/opsplorer.txt \
+ 'opsplorer\.txt' 'opsplorer_[a-z_]\+'
+}
+
+src_install() {
+ # install launcher and menu entry
+ dobin cream
+ domenu cream.desktop
+ doicon cream.svg cream.png
+
+ # install shared vim files
+ insinto /usr/share/vim/cream
+ doins *.vim creamrc
+ local dir
+ for dir in addons bitmaps filetypes lang spelldicts ; do
+ insinto /usr/share/vim/cream/${dir}
+ doins ${dir}/*
+ done
+ insinto /usr/share/vim/vimfiles/doc
+ doins help/*.txt
+
+ # install docs
+ dodoc docs/{CHANGELOG,DEVELOPER,KEYBOARD,PressRelease,README,RELEASE}.txt
+ dohtml docs-html/*
+ # html doc may be opened from Cream GUI
+ dosym ../../doc/${PF}/html /usr/share/vim/cream/docs-html
+}
+
+pkg_setup() {
+ einfo "Cream comes with several dictionaries for spell checking. In"
+ einfo "all cases, at least a small English dictionary will be installed."
+ einfo
+ einfo "To specify which optional dictionaries are installed, set the"
+ einfo "LINGUAS variable in /etc/make.conf. For example, to install full"
+ einfo "English and French dictionaries, use:"
+ einfo " LINGUAS=\"en fr\""
+ einfo
+ einfo "Available dictionaries are:"
+ for dict in "English en" "French fr" "German de" "Spanish es" ; do
+ # portage bug: shouldn't get a QA notice for linguas stuff...
+ einfo " ${dict% *} \t(${dict#* }) $( ( \
+ use linguas_${dict#* } &>/dev/null && \
+ echo '(Will be installed)' ) || echo '(Will not be installed)' )"
+ done
+ einfo
+ # give the user time to cancel if necessary
+ epause
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ vim-plugin_pkg_postinst
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ vim-plugin_pkg_postrm
+}
diff --git a/app-vim/cream/files/digest-cream-0.36 b/app-vim/cream/files/digest-cream-0.36
new file mode 100644
index 000000000000..d29a66192e12
--- /dev/null
+++ b/app-vim/cream/files/digest-cream-0.36
@@ -0,0 +1,15 @@
+MD5 e235b944826e82010caf939992b425b9 cream-0.36.tar.gz 759442
+RMD160 123240f8b9be824bbb2c5def1705105fcf7db39f cream-0.36.tar.gz 759442
+SHA256 6754a8fc7c191d8753c77bdbc3e672bf11e695b732175ce1f8fb25cee7926d05 cream-0.36.tar.gz 759442
+MD5 e50dc96c6f79558e8680fbc2bec7b250 cream-spell-dict-eng_2.0.2.zip 1778434
+RMD160 9b963f601d9ce331e7553765f3e9a232e473e271 cream-spell-dict-eng_2.0.2.zip 1778434
+SHA256 fc1a117fa2ebf25254c503e31969f3b5584648965e3fdda3171995f64793ef51 cream-spell-dict-eng_2.0.2.zip 1778434
+MD5 8620c26f37e5484dd84c49a5e14102a1 cream-spell-dict-fre_2.1.zip 872841
+RMD160 28efaffd7a1325229aeb1e5aa85a4072df0a91ff cream-spell-dict-fre_2.1.zip 872841
+SHA256 d15039be170dadba0011915609446aa48e82e27d692c414be6427caa6134b0b7 cream-spell-dict-fre_2.1.zip 872841
+MD5 b2eac7ab57cd1d9dfd621bd0cfc9fc60 cream-spell-dict-ger_2.0.1.zip 894848
+RMD160 50321a0d6b22a5761c587c93269bf3b1908b6e48 cream-spell-dict-ger_2.0.1.zip 894848
+SHA256 62fbfa9ab7a42c4c0d8d7723f865be7e8c216b5215a15d7430ed0cfb3c993eae cream-spell-dict-ger_2.0.1.zip 894848
+MD5 2a9d85363a14bbc986eccbfa8accd4b1 cream-spell-dict-spa_3.0.zip 1710280
+RMD160 5418c029358b11bb339ca0b0dc0965e7381333b2 cream-spell-dict-spa_3.0.zip 1710280
+SHA256 b26ac0bbf905508b446cfb4424fad5923d4e5e6afe5cd20a313be67269485602 cream-spell-dict-spa_3.0.zip 1710280