summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-08-21 02:37:34 +0000
committerAron Griffis <agriffis@gentoo.org>2003-08-21 02:37:34 +0000
commit52e7433756bdbcd744a1871b5bbd42da0ef5bae7 (patch)
treed3116f4013b798cfacabc9126d660924c9e73986 /app-vim
parentchange help key binding (diff)
downloadgentoo-2-52e7433756bdbcd744a1871b5bbd42da0ef5bae7.tar.gz
gentoo-2-52e7433756bdbcd744a1871b5bbd42da0ef5bae7.tar.bz2
gentoo-2-52e7433756bdbcd744a1871b5bbd42da0ef5bae7.zip
change help key binding
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/info/ChangeLog7
-rw-r--r--app-vim/info/Manifest4
-rw-r--r--app-vim/info/files/digest-info-1.7-r11
-rw-r--r--app-vim/info/info-1.7-r1.ebuild21
4 files changed, 30 insertions, 3 deletions
diff --git a/app-vim/info/ChangeLog b/app-vim/info/ChangeLog
index 59710befe88f..fce5a8e092f3 100644
--- a/app-vim/info/ChangeLog
+++ b/app-vim/info/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/info
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/info/ChangeLog,v 1.2 2003/08/19 02:12:24 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/info/ChangeLog,v 1.3 2003/08/21 02:37:30 agriffis Exp $
+
+*info-1.7-r1 (20 Aug 2003)
+
+ 20 Aug 2003; Aron Griffis <agriffis@gentoo.org> info-1.7-r1.ebuild:
+ Fix help key binding to be H instead of h
18 Aug 2003; Aron Griffis <agriffis@gentoo.org> info-1.7.ebuild:
Mark stable on alpha and x86
diff --git a/app-vim/info/Manifest b/app-vim/info/Manifest
index 98d0dce37289..a2b9112e5962 100644
--- a/app-vim/info/Manifest
+++ b/app-vim/info/Manifest
@@ -1,6 +1,6 @@
MD5 4883c210efa5762e55a46fa428d1e7c1 info-1.7.ebuild 396
-MD5 1c0ca4768638a0d8c72fa339aedbd5ad info-1.7-r1.ebuild 697
-MD5 401e26044ddc0b527fe67ac410da5e4b ChangeLog 438
+MD5 5b956e71421d3244b9c6a10394b314e8 info-1.7-r1.ebuild 700
+MD5 f1b52198baf7423329f3f8157f7dc954 ChangeLog 581
MD5 f3583430b2f7b0686cafd606b08bf203 metadata.xml 156
MD5 157a1f6c9fbbd5c2904a73d97f4ecdaa files/digest-info-1.7 59
MD5 157a1f6c9fbbd5c2904a73d97f4ecdaa files/digest-info-1.7-r1 59
diff --git a/app-vim/info/files/digest-info-1.7-r1 b/app-vim/info/files/digest-info-1.7-r1
new file mode 100644
index 000000000000..7b6e59627a40
--- /dev/null
+++ b/app-vim/info/files/digest-info-1.7-r1
@@ -0,0 +1 @@
+MD5 0a5a6f8473677d00fcbe9797243c2f51 info-1.7.tar.bz2 3958
diff --git a/app-vim/info/info-1.7-r1.ebuild b/app-vim/info/info-1.7-r1.ebuild
new file mode 100644
index 000000000000..046a3b34b5b0
--- /dev/null
+++ b/app-vim/info/info-1.7-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/info/info-1.7-r1.ebuild,v 1.1 2003/08/21 02:37:30 agriffis Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: GNU info documentation browser"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=21"
+LICENSE="BSD"
+KEYWORDS="x86 alpha"
+DEPEND="${DEPEND} >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${P}/plugin
+
+ # The 'h' key is a bad choice for help. 'H' would have been a
+ # much better choice. I sent this suggestion to the maintainer,
+ # but no reply.
+ sed -i 's/\(noremap <buffer> \)h/\1H/' info.vim || die 'sed failed'
+}