summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-09-09 06:53:37 +0000
committerTim Harder <radhermit@gentoo.org>2011-09-09 06:53:37 +0000
commit3cc4bae4b5cd664943df35ff7c4eff5ddb7018a0 (patch)
tree9c3d3ff47db529adafb34bfde5c0dab17af5a54b /app-vim
parentVersion bump. (diff)
downloadgentoo-2-3cc4bae4b5cd664943df35ff7c4eff5ddb7018a0.tar.gz
gentoo-2-3cc4bae4b5cd664943df35ff7c4eff5ddb7018a0.tar.bz2
gentoo-2-3cc4bae4b5cd664943df35ff7c4eff5ddb7018a0.zip
Version bump. Use github mirror.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/vimpress/ChangeLog7
-rw-r--r--app-vim/vimpress/vimpress-2.1.5.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/app-vim/vimpress/ChangeLog b/app-vim/vimpress/ChangeLog
index 38607da97275..385c90151699 100644
--- a/app-vim/vimpress/ChangeLog
+++ b/app-vim/vimpress/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/vimpress
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/vimpress/ChangeLog,v 1.1 2011/06/10 21:12:51 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimpress/ChangeLog,v 1.2 2011/09/09 06:53:37 radhermit Exp $
+
+*vimpress-2.1.5 (09 Sep 2011)
+
+ 09 Sep 2011; Tim Harder <radhermit@gentoo.org> +vimpress-2.1.5.ebuild:
+ Version bump. Use github mirror.
*vimpress-2.1.0 (10 Jun 2011)
diff --git a/app-vim/vimpress/vimpress-2.1.5.ebuild b/app-vim/vimpress/vimpress-2.1.5.ebuild
new file mode 100644
index 000000000000..f2c0979e41dd
--- /dev/null
+++ b/app-vim/vimpress/vimpress-2.1.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimpress/vimpress-2.1.5.ebuild,v 1.1 2011/09/09 06:53:37 radhermit Exp $
+
+EAPI=4
+
+inherit vim-plugin
+
+MY_PN="VimRepress"
+DESCRIPTION="vim plugin: manage wordpress blogs from vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3510"
+SRC_URI="https://github.com/vim-scripts/${MY_PN}/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="vim"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )
+ || ( dev-lang/python:2.7 dev-lang/python:2.6 )
+ dev-python/markdown"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${MY_PN}-* "${S}"
+}
+
+src_prepare() {
+ rm README || die
+}