summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-08-07 00:11:26 +0000
committerTim Harder <radhermit@gentoo.org>2012-08-07 00:11:26 +0000
commit2bd73676074c47f8cc4bd72637ab662d78c32b73 (patch)
tree8c19510d2fc67ae30c8b1352c0129d57aee5b4bf /app-vim
parentRemove obsolete shapelib mask (diff)
downloadgentoo-2-2bd73676074c47f8cc4bd72637ab662d78c32b73.tar.gz
gentoo-2-2bd73676074c47f8cc4bd72637ab662d78c32b73.tar.bz2
gentoo-2-2bd73676074c47f8cc4bd72637ab662d78c32b73.zip
Version bump.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/cctree/ChangeLog7
-rw-r--r--app-vim/cctree/cctree-1.61.ebuild27
2 files changed, 33 insertions, 1 deletions
diff --git a/app-vim/cctree/ChangeLog b/app-vim/cctree/ChangeLog
index aefd901dbb6f..cd67e11aee3f 100644
--- a/app-vim/cctree/ChangeLog
+++ b/app-vim/cctree/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/cctree
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/cctree/ChangeLog,v 1.5 2012/08/03 10:44:15 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/cctree/ChangeLog,v 1.6 2012/08/07 00:11:26 radhermit Exp $
+
+*cctree-1.61 (07 Aug 2012)
+
+ 07 Aug 2012; Tim Harder <radhermit@gentoo.org> +cctree-1.61.ebuild:
+ Version bump.
03 Aug 2012; Tim Harder <radhermit@gentoo.org> -cctree-1.51.ebuild,
-cctree-1.55.ebuild:
diff --git a/app-vim/cctree/cctree-1.61.ebuild b/app-vim/cctree/cctree-1.61.ebuild
new file mode 100644
index 000000000000..ab8493f47e11
--- /dev/null
+++ b/app-vim/cctree/cctree-1.61.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/cctree/cctree-1.61.ebuild,v 1.1 2012/08/07 00:11:26 radhermit Exp $
+
+EAPI=4
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Cscope based source-code browser and code flow analysis tool"
+HOMEPAGE="http://sites.google.com/site/vimcctree/"
+LICENSE="as-is"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-util/cscope"
+
+src_prepare() {
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir doc
+ sed -e '/" Name Of File/,/".\+Community/!d' -e 's/^" \?//' \
+ -e 's/\(Name Of File: \)\([^.]\+\)\.vim/\1*\L\2.txt*/' \
+ ftplugin/${PN}.vim > doc/${PN}.txt
+}