summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-12-23 07:03:54 +0000
committerTim Harder <radhermit@gentoo.org>2013-12-23 07:03:54 +0000
commit279e44350925fcf5700295fb6a4e2343f9abcf77 (patch)
tree0c6e8953f6d90fde442502ad097363998dc5ee7e /app-vim
parentVersion bump (bug #494786), add support for run-help data (bug #431402), and ... (diff)
downloadgentoo-2-279e44350925fcf5700295fb6a4e2343f9abcf77.tar.gz
gentoo-2-279e44350925fcf5700295fb6a4e2343f9abcf77.tar.bz2
gentoo-2-279e44350925fcf5700295fb6a4e2343f9abcf77.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/command-t/ChangeLog7
-rw-r--r--app-vim/command-t/command-t-1.6.1.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/app-vim/command-t/ChangeLog b/app-vim/command-t/ChangeLog
index f119651d634d..dd916c975ca7 100644
--- a/app-vim/command-t/ChangeLog
+++ b/app-vim/command-t/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/command-t
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/command-t/ChangeLog,v 1.12 2013/12/17 09:12:28 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/command-t/ChangeLog,v 1.13 2013/12/23 07:03:54 radhermit Exp $
+
+*command-t-1.6.1 (23 Dec 2013)
+
+ 23 Dec 2013; Tim Harder <radhermit@gentoo.org> +command-t-1.6.1.ebuild:
+ Version bump.
*command-t-1.6 (17 Dec 2013)
diff --git a/app-vim/command-t/command-t-1.6.1.ebuild b/app-vim/command-t/command-t-1.6.1.ebuild
new file mode 100644
index 000000000000..064458397f98
--- /dev/null
+++ b/app-vim/command-t/command-t-1.6.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/command-t/command-t-1.6.1.ebuild,v 1.1 2013/12/23 07:03:54 radhermit Exp $
+
+EAPI="5"
+USE_RUBY="ruby18 ruby19 ruby20"
+
+inherit vim-plugin ruby-ng
+
+DESCRIPTION="vim plugin: fast file navigation for vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3025
+ https://wincent.com/products/command-t"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="|| ( app-editors/vim[ruby] app-editors/gvim[ruby] )"
+
+each_ruby_configure() {
+ cd ruby/${PN}
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ cd ruby/${PN}
+ emake V=1
+ rm *.o *.c *.h *.log extconf.rb depend Makefile || die
+}
+
+each_ruby_install() {
+ local sitelibdir=$(ruby_rbconfig_value "sitelibdir")
+ insinto ${sitelibdir}/${PN}
+ doins -r ruby/${PN}/*
+}
+
+all_ruby_install() {
+ rm -r ruby || die
+ vim-plugin_src_install
+}