summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2004-03-28 20:01:47 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2004-03-28 20:01:47 +0000
commitec65e0d4afb89e39110d002c696b96129bdd955c (patch)
tree4b8b45cb48f2d7ff2d7d478a1781363539c2e54b /app-vim/vimcommander/vimcommander-1.54.2.2.ebuild
parentInitial import (Manifest recommit) (diff)
downloadgentoo-2-ec65e0d4afb89e39110d002c696b96129bdd955c.tar.gz
gentoo-2-ec65e0d4afb89e39110d002c696b96129bdd955c.tar.bz2
gentoo-2-ec65e0d4afb89e39110d002c696b96129bdd955c.zip
bump, #46013
Diffstat (limited to 'app-vim/vimcommander/vimcommander-1.54.2.2.ebuild')
-rw-r--r--app-vim/vimcommander/vimcommander-1.54.2.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-vim/vimcommander/vimcommander-1.54.2.2.ebuild b/app-vim/vimcommander/vimcommander-1.54.2.2.ebuild
new file mode 100644
index 000000000000..7a6264562803
--- /dev/null
+++ b/app-vim/vimcommander/vimcommander-1.54.2.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimcommander/vimcommander-1.54.2.2.ebuild,v 1.1 2004/03/28 20:01:47 ciaranm Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Total Commander style file explorer"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=808"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~sparc ~x86"
+
+function src_unpack() {
+ unpack ${A}
+ mkdir ${S}/doc || die "can't make doc dir"
+
+ # This plugin uses an 'automatic documentation install' trick. This
+ # causes problems for us during the unmerge. Fortunately, sed can fix
+ # this for us.
+ sed -e '1,/^=== START_DOC$/d' \
+ -e '/^=== END_DOC/,$d' \
+ -e "s/#version#/v${PV}/" \
+ ${S}/plugin/vimcommander.vim > ${S}/doc/vimcommander.txt \
+ || die "help extraction failed"
+
+ echo -ne "\n\n vim:tw=78:ts=8:ft=help:norl:" >> ${S}/doc/vimcommander.txt
+
+ sed -i -e 's/" \(let b:vimcommander_install_doc=\)[01]/\10/' \
+ ${S}/plugin/vimcommander.vim \
+ || die "help extract disable failed"
+}