summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-05-22 03:09:02 +0000
committerTim Harder <radhermit@gentoo.org>2011-05-22 03:09:02 +0000
commit963db55d2a9dcd457c17abce12dc423f832918d5 (patch)
tree98bf5c94fa1b27d2ac135c067d872f7efbb845f2 /app-vim/unite
parentFix build failure on FreeBSD: bug #348938 (diff)
downloadgentoo-2-963db55d2a9dcd457c17abce12dc423f832918d5.tar.gz
gentoo-2-963db55d2a9dcd457c17abce12dc423f832918d5.tar.bz2
gentoo-2-963db55d2a9dcd457c17abce12dc423f832918d5.zip
Initial import.
(Portage version: 2.2.0_alpha33/cvs/Linux x86_64)
Diffstat (limited to 'app-vim/unite')
-rw-r--r--app-vim/unite/ChangeLog10
-rw-r--r--app-vim/unite/metadata.xml14
-rw-r--r--app-vim/unite/unite-2.0.ebuild20
3 files changed, 44 insertions, 0 deletions
diff --git a/app-vim/unite/ChangeLog b/app-vim/unite/ChangeLog
new file mode 100644
index 000000000000..0c117e3d5958
--- /dev/null
+++ b/app-vim/unite/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-vim/unite
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/unite/ChangeLog,v 1.1 2011/05/22 03:09:02 radhermit Exp $
+
+*unite-2.0 (22 May 2011)
+
+ 22 May 2011; Tim Harder <radhermit@gentoo.org> +unite-2.0.ebuild,
+ +metadata.xml:
+ Initial import.
+
diff --git a/app-vim/unite/metadata.xml b/app-vim/unite/metadata.xml
new file mode 100644
index 000000000000..ef7e62c357fc
--- /dev/null
+++ b/app-vim/unite/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+ <longdescription lang="en">
+ Unite searches and displays information from arbitrary sources like files,
+ buffers, recently used files or registers. You can run one of defined action
+ on a target displayed.
+
+ The differences between unite and similar plugins like fuzzyfinder or ku are
+ that unite doesn't use the built-in completion interface of Vim, and integrates
+ sources at the same time.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-vim/unite/unite-2.0.ebuild b/app-vim/unite/unite-2.0.ebuild
new file mode 100644
index 000000000000..248fa226335d
--- /dev/null
+++ b/app-vim/unite/unite-2.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/unite/unite-2.0.ebuild,v 1.1 2011/05/22 03:09:02 radhermit Exp $
+
+EAPI=4
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: unite all sources"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3396"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="unite.txt"
+
+src_prepare() {
+ # remove unused tests
+ rm -rf test
+}