summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-08-27 07:19:15 +0000
committerTim Harder <radhermit@gentoo.org>2013-08-27 07:19:15 +0000
commit9eb807207ad9d3840fea50c4acbd8f9311c533db (patch)
tree1522150d320682470fae66c43d20372790d82e31 /app-vim/syntastic
parentVersion bump. (diff)
downloadgentoo-2-9eb807207ad9d3840fea50c4acbd8f9311c533db.tar.gz
gentoo-2-9eb807207ad9d3840fea50c4acbd8f9311c533db.tar.bz2
gentoo-2-9eb807207ad9d3840fea50c4acbd8f9311c533db.zip
Version bump.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-vim/syntastic')
-rw-r--r--app-vim/syntastic/ChangeLog7
-rw-r--r--app-vim/syntastic/syntastic-3.1.0.ebuild27
2 files changed, 33 insertions, 1 deletions
diff --git a/app-vim/syntastic/ChangeLog b/app-vim/syntastic/ChangeLog
index 71b1764dd15b..ae85052b1a2e 100644
--- a/app-vim/syntastic/ChangeLog
+++ b/app-vim/syntastic/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/syntastic
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/syntastic/ChangeLog,v 1.1 2013/07/24 08:12:23 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/syntastic/ChangeLog,v 1.2 2013/08/27 07:19:15 radhermit Exp $
+
+*syntastic-3.1.0 (27 Aug 2013)
+
+ 27 Aug 2013; Tim Harder <radhermit@gentoo.org> +syntastic-3.1.0.ebuild:
+ Version bump.
*syntastic-9999 (24 Jul 2013)
*syntastic-3.0.0 (24 Jul 2013)
diff --git a/app-vim/syntastic/syntastic-3.1.0.ebuild b/app-vim/syntastic/syntastic-3.1.0.ebuild
new file mode 100644
index 000000000000..88699c8df6b8
--- /dev/null
+++ b/app-vim/syntastic/syntastic-3.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/syntastic/syntastic-3.1.0.ebuild,v 1.1 2013/08/27 07:19:15 radhermit Exp $
+
+EAPI=5
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: syntax checking using external tools"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2736 https://github.com/scrooloose/syntastic/"
+SRC_URI="https://github.com/scrooloose/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="WTFPL-2"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_prepare() {
+ rm -r _assets LICENCE README.markdown || die
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "Syntastic has many optional dependencies depending on the type"
+ elog "of syntax checking being performed. Look in the related files in"
+ elog "the syntax_checkers directory to help figure out what programs"
+ elog "different languages need."
+ fi
+}