summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-07-21 00:50:21 +0000
committerTim Harder <radhermit@gentoo.org>2011-07-21 00:50:21 +0000
commit7a34da38ef0cebbf7238027837b2640e163af95b (patch)
tree4f6d1629b2424a8c71622ea114f0cec7fbd60bde /app-vim/minibufexpl
parentUse correct license. (diff)
downloadgentoo-2-7a34da38ef0cebbf7238027837b2640e163af95b.tar.gz
gentoo-2-7a34da38ef0cebbf7238027837b2640e163af95b.tar.bz2
gentoo-2-7a34da38ef0cebbf7238027837b2640e163af95b.zip
Version bump.
(Portage version: 2.2.0_alpha45/cvs/Linux x86_64)
Diffstat (limited to 'app-vim/minibufexpl')
-rw-r--r--app-vim/minibufexpl/ChangeLog7
-rw-r--r--app-vim/minibufexpl/minibufexpl-6.4.2.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/app-vim/minibufexpl/ChangeLog b/app-vim/minibufexpl/ChangeLog
index 12b1517eb485..7f02ace66ccb 100644
--- a/app-vim/minibufexpl/ChangeLog
+++ b/app-vim/minibufexpl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/minibufexpl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/minibufexpl/ChangeLog,v 1.26 2011/05/20 07:39:49 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/minibufexpl/ChangeLog,v 1.27 2011/07/21 00:50:21 radhermit Exp $
+
+*minibufexpl-6.4.2 (21 Jul 2011)
+
+ 21 Jul 2011; Tim Harder <radhermit@gentoo.org> +minibufexpl-6.4.2.ebuild:
+ Version bump.
*minibufexpl-6.4.1_p5 (20 May 2011)
diff --git a/app-vim/minibufexpl/minibufexpl-6.4.2.ebuild b/app-vim/minibufexpl/minibufexpl-6.4.2.ebuild
new file mode 100644
index 000000000000..bb9592559477
--- /dev/null
+++ b/app-vim/minibufexpl/minibufexpl-6.4.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/minibufexpl/minibufexpl-6.4.2.ebuild,v 1.1 2011/07/21 00:50:21 radhermit Exp $
+
+EAPI=4
+
+inherit vim-plugin
+
+MY_PN="${PN}.vim"
+DESCRIPTION="vim plugin: easily switch between buffers"
+HOMEPAGE="https://github.com/fholgado/minibufexpl.vim"
+SRC_URI="https://github.com/fholgado/${MY_PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="as-is"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="minibufexpl.txt"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${MY_PN}-* "${S}"
+}
+
+src_prepare() {
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir "${S}"/doc
+ sed -e '1,/"=\+$/d' -e '/"=\+$/,9999d' -e 's/^" \?//' \
+ -e 's/\(Name Of File: \)\([^.]\+\)\.vim/\1*\2.txt*/' \
+ plugin/minibufexpl.vim \
+ > doc/minibufexpl.txt
+
+ # Discard unwanted files
+ rm -f .gitignore README project.html
+}