summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-07-17 19:27:30 +0000
committerAli Polatel <hawking@gentoo.org>2008-07-17 19:27:30 +0000
commit643f37d50cb523e592b1f766524f2567d1f89495 (patch)
treea2fb6894321455d6b70fa669f38114ff11038aaa /app-vim/gentoo-syntax
parentStable on ppc64; bug #231943 (diff)
downloadgentoo-2-643f37d50cb523e592b1f766524f2567d1f89495.tar.gz
gentoo-2-643f37d50cb523e592b1f766524f2567d1f89495.tar.bz2
gentoo-2-643f37d50cb523e592b1f766524f2567d1f89495.zip
Version bump. Add support for GLEP56, update recognized variables in make.conf, #199788. Recognize directories under /etc/portage, #229035.
(Portage version: -svn.wrabbit)
Diffstat (limited to 'app-vim/gentoo-syntax')
-rw-r--r--app-vim/gentoo-syntax/ChangeLog11
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20080717.ebuild48
2 files changed, 57 insertions, 2 deletions
diff --git a/app-vim/gentoo-syntax/ChangeLog b/app-vim/gentoo-syntax/ChangeLog
index 68fab58fcba7..914f99045039 100644
--- a/app-vim/gentoo-syntax/ChangeLog
+++ b/app-vim/gentoo-syntax/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-vim/gentoo-syntax
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/ChangeLog,v 1.84 2007/08/09 15:57:36 dertobi123 Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/ChangeLog,v 1.85 2008/07/17 19:27:30 hawking Exp $
+
+*gentoo-syntax-20080717 (17 Jul 2008)
+
+ 17 Jul 2008; Ali Polatel <hawking@gentoo.org>
+ +gentoo-syntax-20080717.ebuild:
+ Version bump. Add support for GLEP56, update recognized variables in
+ make.conf, #199788. Recognize directories under /etc/portage, #229035.
09 Aug 2007; Tobias Scherbaum <dertobi123@gentoo.org>
gentoo-syntax-20070506.ebuild:
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20080717.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20080717.ebuild
new file mode 100644
index 000000000000..ec5415183555
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20080717.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/gentoo-syntax-20080717.ebuild,v 1.1 2008/07/17 19:27:30 hawking Exp $
+
+inherit eutils vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo Ebuild, Eclass, GLEP, ChangeLog and Portage Files syntax highlighting, filetype and indent settings"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ else
+ elog "Note for developers and anyone else who edits ebuilds:"
+ elog " This release of gentoo-syntax now contains filetype rules to set"
+ elog " fileencoding for ebuilds and ChangeLogs to utf-8 as per GLEP 31."
+ elog " If you find this feature breaks things, please submit a bug and"
+ elog " assign it to vim@gentoo.org. You can use the 'ignore-glep31' USE"
+ elog " flag to remove these rules."
+ fi
+ echo
+ epause 5
+}