summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-08-10 21:22:56 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-08-10 21:22:56 +0000
commit1262cabd7dd9558a5e1ef6102be88eca99783950 (patch)
tree7037bcb4d1493ec27fb9a7196c7b8dd46a8cdd09 /app-vim/ebnf-syntax/ebnf-syntax-1.1-r1.ebuild
parentVersion bump, bug #101156. (diff)
downloadgentoo-2-1262cabd7dd9558a5e1ef6102be88eca99783950.tar.gz
gentoo-2-1262cabd7dd9558a5e1ef6102be88eca99783950.tar.bz2
gentoo-2-1262cabd7dd9558a5e1ef6102be88eca99783950.zip
Don't use hi link, bug #101799
(Portage version: 2.0.51.22-r2 flaming goat edition)
Diffstat (limited to 'app-vim/ebnf-syntax/ebnf-syntax-1.1-r1.ebuild')
-rw-r--r--app-vim/ebnf-syntax/ebnf-syntax-1.1-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-vim/ebnf-syntax/ebnf-syntax-1.1-r1.ebuild b/app-vim/ebnf-syntax/ebnf-syntax-1.1-r1.ebuild
new file mode 100644
index 000000000000..e3b1226a3964
--- /dev/null
+++ b/app-vim/ebnf-syntax/ebnf-syntax-1.1-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/ebnf-syntax/ebnf-syntax-1.1-r1.ebuild,v 1.1 2005/08/10 21:19:06 ciaranm Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: EBNF (ISO/IEC 14997) file syntax highlighting"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=545"
+LICENSE="as-is"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides syntax highlighting for EBNF (ISO/IEC 14997) files."
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ # don't use hi link, bug #101799.
+ sed -i -e 's,hi link,hi def link,' syntax/ebnf.vim || die "sed failed"
+}
+