summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-06-25 09:17:05 +0000
committerTim Harder <radhermit@gentoo.org>2011-06-25 09:17:05 +0000
commitafe6807a5ec0138948ace532e218d83230e5ac66 (patch)
treea3b144ac691cd963d4d7fd1e6b18871bb4836a78 /app-vim/cctree
parentrevbump to use the new python3.2 patch (diff)
downloadgentoo-2-afe6807a5ec0138948ace532e218d83230e5ac66.tar.gz
gentoo-2-afe6807a5ec0138948ace532e218d83230e5ac66.tar.bz2
gentoo-2-afe6807a5ec0138948ace532e218d83230e5ac66.zip
Version bump. Use github mirror.
(Portage version: 2.2.0_alpha40/cvs/Linux x86_64)
Diffstat (limited to 'app-vim/cctree')
-rw-r--r--app-vim/cctree/ChangeLog7
-rw-r--r--app-vim/cctree/cctree-1.55.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/app-vim/cctree/ChangeLog b/app-vim/cctree/ChangeLog
index a81273704911..7bc98d7a1551 100644
--- a/app-vim/cctree/ChangeLog
+++ b/app-vim/cctree/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/cctree
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/cctree/ChangeLog,v 1.2 2011/05/20 19:14:31 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/cctree/ChangeLog,v 1.3 2011/06/25 09:17:05 radhermit Exp $
+
+*cctree-1.55 (25 Jun 2011)
+
+ 25 Jun 2011; Tim Harder <radhermit@gentoo.org> +cctree-1.55.ebuild:
+ Version bump. Use github mirror.
20 May 2011; Tim Harder <radhermit@gentoo.org> cctree-1.51.ebuild:
Fix description.
diff --git a/app-vim/cctree/cctree-1.55.ebuild b/app-vim/cctree/cctree-1.55.ebuild
new file mode 100644
index 000000000000..013bf1e12b1c
--- /dev/null
+++ b/app-vim/cctree/cctree-1.55.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/cctree/cctree-1.55.ebuild,v 1.1 2011/06/25 09:17:05 radhermit Exp $
+
+EAPI=4
+
+inherit vim-plugin
+
+MY_PN="CCTree"
+DESCRIPTION="vim plugin: Cscope based source-code browser and code flow analysis tool"
+HOMEPAGE="http://sites.google.com/site/vimcctree/"
+SRC_URI="https://github.com/vim-scripts/${MY_PN}/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="as-is"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="cctree.txt"
+
+RDEPEND="dev-util/cscope"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${MY_PN}-* "${S}"
+}
+
+src_prepare() {
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir doc
+ sed -e '/" Name Of File/,/".\+Community/!d' -e 's/^" \?//' \
+ -e 's/\(Name Of File: \)\([^.]\+\)\.vim/\1*\L\2.txt*/' \
+ ftplugin/cctree.vim > doc/cctree.txt
+
+ rm README
+}