summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-12-10 00:30:10 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-12-10 00:30:10 +0000
commitffd4502396f064e756fff51b23cca478fd06c432 (patch)
tree0ada4e073efaf2501fc979c262d6296daaa0a6a1 /app-text
parentDrop ~ppc and ~ppc64 keywords due to unkeyworded gobject-introspection, bug #... (diff)
downloadgentoo-2-ffd4502396f064e756fff51b23cca478fd06c432.tar.gz
gentoo-2-ffd4502396f064e756fff51b23cca478fd06c432.tar.bz2
gentoo-2-ffd4502396f064e756fff51b23cca478fd06c432.zip
Version bump.
(Portage version: 2.2.0_alpha7/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/xchm/ChangeLog7
-rw-r--r--app-text/xchm/xchm-1.18.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/app-text/xchm/ChangeLog b/app-text/xchm/ChangeLog
index 5117b1cf3317..b9d9f548c4e4 100644
--- a/app-text/xchm/ChangeLog
+++ b/app-text/xchm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/xchm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xchm/ChangeLog,v 1.12 2010/08/31 00:17:44 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xchm/ChangeLog,v 1.13 2010/12/10 00:30:10 dirtyepic Exp $
+
+*xchm-1.18 (10 Dec 2010)
+
+ 10 Dec 2010; Ryan Hill <dirtyepic@gentoo.org> +xchm-1.18.ebuild:
+ Version bump.
31 Aug 2010; Ryan Hill <dirtyepic@gentoo.org> -xchm-1.14.ebuild,
-xchm-1.15.ebuild:
diff --git a/app-text/xchm/xchm-1.18.ebuild b/app-text/xchm/xchm-1.18.ebuild
new file mode 100644
index 000000000000..0e78a4c6d411
--- /dev/null
+++ b/app-text/xchm/xchm-1.18.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xchm/xchm-1.18.ebuild,v 1.1 2010/12/10 00:30:10 dirtyepic Exp $
+
+EAPI=2
+
+WX_GTK_VER="2.8"
+
+inherit eutils wxwidgets flag-o-matic fdo-mime gnome2-utils
+
+DESCRIPTION="Utility for viewing Microsoft .chm files."
+HOMEPAGE="http://xchm.sf.net"
+SRC_URI="mirror://sourceforge/xchm/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="nls"
+DEPEND=">=dev-libs/chmlib-0.36
+ x11-libs/wxGTK:2.8[X]"
+RDEPEND=${DEPEND}
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+ econf ${myconf} \
+ $(use_enable nls) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS README ChangeLog
+
+ cp "${D}"/usr/share/pixmaps/xchm-32.xpm "${D}"/usr/share/pixmaps/xchm.xpm
+ rm -f "${D}"/usr/share/pixmaps/xchm-*.xpm
+ rm -f "${D}"/usr/share/pixmaps/xchmdoc*.xpm
+
+ insinto /usr/share/applications
+ doins "${FILESDIR}"/xchm.desktop
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}"/xchm.xml
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}