summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-08-13 21:13:57 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-08-13 21:13:57 +0000
commitfce066a4e1f9c14dc982cfd91fee07694203dd4c (patch)
tree89c1243f9161ac135604dc2b71fddfd2a54ff2d7 /app-text
parentVersion bump, closes #328713. Load of bug fixes, closes #301658. Clean up old... (diff)
downloadgentoo-2-fce066a4e1f9c14dc982cfd91fee07694203dd4c.tar.gz
gentoo-2-fce066a4e1f9c14dc982cfd91fee07694203dd4c.tar.bz2
gentoo-2-fce066a4e1f9c14dc982cfd91fee07694203dd4c.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/iso-codes/ChangeLog8
-rw-r--r--app-text/iso-codes/iso-codes-3.19.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/app-text/iso-codes/ChangeLog b/app-text/iso-codes/ChangeLog
index 55135cc09759..41ba2d641d46 100644
--- a/app-text/iso-codes/ChangeLog
+++ b/app-text/iso-codes/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/iso-codes
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/ChangeLog,v 1.88 2010/05/31 21:17:26 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/ChangeLog,v 1.89 2010/08/13 21:13:57 eva Exp $
+
+*iso-codes-3.19 (13 Aug 2010)
+
+ 13 Aug 2010; Gilles Dartiguelongue <eva@gentoo.org>
+ +iso-codes-3.19.ebuild:
+ Version bump.
31 May 2010; Gilles Dartiguelongue <eva@gentoo.org>
-iso-codes-3.11.1.ebuild, -iso-codes-3.14.ebuild:
diff --git a/app-text/iso-codes/iso-codes-3.19.ebuild b/app-text/iso-codes/iso-codes-3.19.ebuild
new file mode 100644
index 000000000000..cbfc050b7d84
--- /dev/null
+++ b/app-text/iso-codes/iso-codes-3.19.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/iso-codes-3.19.ebuild,v 1.1 2010/08/13 21:13:57 eva Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Provides the list of country and language names"
+HOMEPAGE="http://alioth.debian.org/projects/pkg-isocodes/"
+SRC_URI="ftp://pkg-isocodes.alioth.debian.org/pub/pkg-isocodes/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="sys-devel/gettext"
+
+src_prepare() {
+ local linguas_bak=${LINGUAS}
+ local mylinguas=""
+
+ for norm in iso_15924 iso_3166 iso_3166_2 iso_4217 iso_639 iso_639_3; do
+ einfo "Preparing ${norm}"
+
+ mylinguas=""
+ LINGUAS=${linguas_bak}
+ strip-linguas -i "${S}/${norm}"
+
+ for loc in ${LINGUAS}; do
+ mylinguas="${mylinguas} ${loc}.po"
+ done
+
+ if [ -n "${mylinguas}" ]; then
+ sed -e "s:pofiles =.*:pofiles = ${mylinguas}:" \
+ -e "s:mofiles =.*:mofiles = ${mylinguas//.po/.mo}:" \
+ -i "${S}/${norm}/Makefile.am" "${S}/${norm}/Makefile.in" \
+ || die "sed in ${norm} folder failed"
+ fi
+ done
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc ChangeLog README TODO || die "dodoc failed"
+}