summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-01-17 23:47:21 +0000
committerTim Harder <radhermit@gentoo.org>2011-01-17 23:47:21 +0000
commitfaa5434ddd008006bb7454880d4359e8feb4ee0c (patch)
tree59a3492f5e6ad7d1563f6887a14b3d140d0a1af1 /app-text
parentcleanup, bump, eapi=2, stable amd64 x86 (diff)
downloadgentoo-2-faa5434ddd008006bb7454880d4359e8feb4ee0c.tar.gz
gentoo-2-faa5434ddd008006bb7454880d4359e8feb4ee0c.tar.bz2
gentoo-2-faa5434ddd008006bb7454880d4359e8feb4ee0c.zip
Version bump and remove old. Apply temporary patch for bug #349979 by Till Matthiesen and use cmake build system.
(Portage version: 2.2.0_alpha15/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/apvlv/ChangeLog11
-rw-r--r--app-text/apvlv/apvlv-0.0.9.4.ebuild38
-rw-r--r--app-text/apvlv/apvlv-0.1.0.ebuild53
-rw-r--r--app-text/apvlv/files/apvlv-0.1.0-poppler-0.16.patch11
4 files changed, 73 insertions, 40 deletions
diff --git a/app-text/apvlv/ChangeLog b/app-text/apvlv/ChangeLog
index e4dc2d1ab330..1eb0b6c9ca38 100644
--- a/app-text/apvlv/ChangeLog
+++ b/app-text/apvlv/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/apvlv
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/apvlv/ChangeLog,v 1.8 2010/12/04 10:35:49 phajdan.jr Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/apvlv/ChangeLog,v 1.9 2011/01/17 23:47:21 radhermit Exp $
+
+*apvlv-0.1.0 (17 Jan 2011)
+
+ 17 Jan 2011; Tim Harder <radhermit@gentoo.org> -apvlv-0.0.9.4.ebuild,
+ +apvlv-0.1.0.ebuild, +files/apvlv-0.1.0-poppler-0.16.patch:
+ Version bump and remove old. Apply temporary patch for bug #349979 by Till
+ Matthiesen and use cmake build system.
04 Dec 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> apvlv-0.0.9.8.ebuild:
x86 stable wrt bug #347115
diff --git a/app-text/apvlv/apvlv-0.0.9.4.ebuild b/app-text/apvlv/apvlv-0.0.9.4.ebuild
deleted file mode 100644
index 6b5bf4a7bc69..000000000000
--- a/app-text/apvlv/apvlv-0.0.9.4.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/apvlv/apvlv-0.0.9.4.ebuild,v 1.3 2010/05/25 21:10:11 pacho Exp $
-
-EAPI=2
-inherit eutils
-
-DESCRIPTION="Alf's PDF Viewer Like Vim"
-HOMEPAGE="http://code.google.com/p/apvlv/"
-SRC_URI="http://apvlv.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug djvu"
-
-RDEPEND=">=x11-libs/gtk+-2.4:2
- >=app-text/poppler-0.12.3-r3[cairo]
- djvu? ( app-text/djvu )"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_configure() {
- econf \
- $(use_enable debug) \
- --disable-dependency-tracking \
- --with-sysconfdir=/etc/${PN} \
- --with-docdir=/usr/share/doc/${PF} \
- --with-mandir=/usr/share/man \
- $(use_with djvu)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS NEWS README THANKS TODO
- newicon icons/pdf.png ${PN}.png
- make_desktop_entry ${PN} "Alf's PDF Viewer Like Vim" ${PN} "Office;Viewer"
-}
diff --git a/app-text/apvlv/apvlv-0.1.0.ebuild b/app-text/apvlv/apvlv-0.1.0.ebuild
new file mode 100644
index 000000000000..24ef93cf7044
--- /dev/null
+++ b/app-text/apvlv/apvlv-0.1.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/apvlv/apvlv-0.1.0.ebuild,v 1.1 2011/01/17 23:47:21 radhermit Exp $
+
+EAPI=3
+
+inherit eutils cmake-utils
+
+MY_P="${P}-Source"
+DESCRIPTION="Alf's PDF Viewer Like Vim"
+HOMEPAGE="http://code.google.com/p/apvlv/"
+SRC_URI="http://apvlv.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug djvu"
+
+RDEPEND=">=x11-libs/gtk+-2.10.4:2
+ >=app-text/poppler-0.12.3-r3[cairo]
+ djvu? ( app-text/djvu )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # bug #349979
+ has_version ">=app-text/poppler-0.15.0" && epatch "${FILESDIR}"/${P}-poppler-0.16.patch
+
+ # Remove prefixes so it works with the cmake-utils eclass
+ sed -i -e "s:APVLV_::" src/CMakeLists.txt
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DSYSCONFDIR=/etc/${PN}
+ -DDOCDIR=/usr/share/doc/${PF}
+ -DMANDIR=/usr/share/man
+ -DWITH_UMD=OFF
+ $(cmake-utils_use_enable debug)
+ $(cmake-utils_use_with djvu)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc AUTHORS NEWS README THANKS TODO
+ newicon icons/pdf.png ${PN}.png
+ make_desktop_entry ${PN} "Alf's PDF Viewer Like Vim" ${PN} "Office;Viewer"
+}
diff --git a/app-text/apvlv/files/apvlv-0.1.0-poppler-0.16.patch b/app-text/apvlv/files/apvlv-0.1.0-poppler-0.16.patch
new file mode 100644
index 000000000000..3c7df684b3fa
--- /dev/null
+++ b/app-text/apvlv/files/apvlv-0.1.0-poppler-0.16.patch
@@ -0,0 +1,11 @@
+--- apvlv-0.1.0-Source/src/ApvlvFile.cpp.orig
++++ apvlv-0.1.0-Source/src/ApvlvFile.cpp
+@@ -285,7 +285,7 @@
+ {
+ PopplerRectangle rect = { x1, y1, x2, y2 };
+ PopplerPage *page = poppler_document_get_page (mDoc, pn);
+- *out = poppler_page_get_text (page, POPPLER_SELECTION_WORD, &rect);
++ *out = poppler_page_get_selected_text (page, POPPLER_SELECTION_WORD, &rect);
+ if (*out != NULL)
+ {
+ return true;