summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-15 15:35:46 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-15 15:35:46 +0000
commitfa9c2000bb440d535732486bb07d5eb9b59d1453 (patch)
tree500ed3bd2c691e1518663526f66ac48641e65626 /app-text
parentremoved 0.1.4 ebuild (diff)
downloadgentoo-2-fa9c2000bb440d535732486bb07d5eb9b59d1453.tar.gz
gentoo-2-fa9c2000bb440d535732486bb07d5eb9b59d1453.tar.bz2
gentoo-2-fa9c2000bb440d535732486bb07d5eb9b59d1453.zip
Remove -Werror and other unnecessary flags from ./configure wrt #408289. USE="static-libs" and remove useless libtool files.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/sword/ChangeLog6
-rw-r--r--app-text/sword/sword-1.6.2.ebuild57
2 files changed, 39 insertions, 24 deletions
diff --git a/app-text/sword/ChangeLog b/app-text/sword/ChangeLog
index 9683be35c4ab..59b291c48e05 100644
--- a/app-text/sword/ChangeLog
+++ b/app-text/sword/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/sword
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sword/ChangeLog,v 1.61 2012/03/15 12:55:41 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sword/ChangeLog,v 1.62 2012/03/15 15:35:46 ssuominen Exp $
+
+ 15 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> sword-1.6.2.ebuild:
+ Remove -Werror and other unnecessary flags from ./configure wrt #408289.
+ USE="static-libs" and remove useless libtool files.
15 Mar 2012; Agostino Sarubbo <ago@gentoo.org> sword-1.6.2.ebuild:
Stable for amd64, wrt bug #408255
diff --git a/app-text/sword/sword-1.6.2.ebuild b/app-text/sword/sword-1.6.2.ebuild
index d91033ac3c69..2acadea43d38 100644
--- a/app-text/sword/sword-1.6.2.ebuild
+++ b/app-text/sword/sword-1.6.2.ebuild
@@ -1,19 +1,18 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sword/sword-1.6.2.ebuild,v 1.3 2012/03/15 12:55:41 ago Exp $
-
-EAPI="3"
+# $Header: /var/cvsroot/gentoo-x86/app-text/sword/sword-1.6.2.ebuild,v 1.4 2012/03/15 15:35:46 ssuominen Exp $
+EAPI=4
inherit flag-o-matic
DESCRIPTION="Library for Bible reading software."
HOMEPAGE="http://www.crosswire.org/sword/"
-SRC_URI="http://www.crosswire.org/ftpmirror/pub/sword/source/v1.6/${P}.tar.gz"
-LICENSE="GPL-2"
+SRC_URI="http://www.crosswire.org/ftpmirror/pub/${PN}/source/v${PV%.*}/${P}.tar.gz"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc ~x86 ~x86-fbsd ~ppc-macos"
-IUSE="curl debug doc icu"
+IUSE="curl debug doc icu static-libs"
RDEPEND="sys-libs/zlib
curl? ( net-misc/curl )
@@ -21,43 +20,55 @@ RDEPEND="sys-libs/zlib
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+DOCS="AUTHORS CODINGSTYLE ChangeLog README"
+
src_prepare() {
+ sed -i \
+ -e '/FLAGS/s:-g3::' -e '/FLAGS/s:-O0::' \
+ -e '/FLAGS/s:-O2::' -e '/FLAGS/s:-O3::' \
+ configure || die
+
+ sed -i -e '/FLAGS/s:-Werror::' configure || die #408289
sed -i -e '/^#inc.*curl.*types/d' src/mgr/curl*.cpp || die #378055
- cat > "${T}"/sword.conf <<- _EOF
- [Install]
- DataPath=${EPREFIX}/usr/share/sword/
- _EOF
+ cat <<-EOF > "${T}"/${PN}.conf
+ [Install]
+ DataPath=${EPREFIX}/usr/share/${PN}/
+ EOF
}
src_configure() {
+ # TODO: Why is this here and can we remove it?
strip-flags
- econf --with-zlib \
- --with-conf \
- $(use_with curl) \
+
+ econf \
+ $(use_enable static-libs static) \
$(use_enable debug) \
- $(use_with icu) || die "configure failed"
+ --with-zlib \
+ $(use_with icu) \
+ --with-conf \
+ $(use_with curl)
}
src_install() {
- make DESTDIR="${D}" install || die "install failed"
- dodoc AUTHORS CODINGSTYLE ChangeLog README
- if use doc ;then
+ default
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
+ if use doc; then
rm -rf examples/.cvsignore
rm -rf examples/cmdline/.cvsignore
rm -rf examples/cmdline/.deps
- cp -R samples examples "${ED}/usr/share/doc/${PF}/"
+ cp -R samples examples "${ED}"/usr/share/doc/${PF}/
fi
- # global configuration file
+
insinto /etc
- doins "${T}/sword.conf"
+ doins "${T}"/${PN}.conf
}
pkg_postinst() {
- echo
elog "Check out http://www.crosswire.org/sword/modules/"
elog "to download modules that you would like to use with SWORD."
elog "Follow module installation instructions found on"
- elog "the web or in ${EPREFIX}/usr/share/doc/${PF}/"
- echo
+ elog "the web or in ${EROOT}/usr/share/doc/${PF}/"
}