summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-01-18 21:53:13 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-01-18 21:53:13 +0000
commitf98ee93bb0f25d34d03564ef6c35e36203a5d3b2 (patch)
tree9b08df3ea1e412009c44fba432d29886388f435e /app-text
parentPatch for parallel building not needed after all. (diff)
downloadgentoo-2-f98ee93bb0f25d34d03564ef6c35e36203a5d3b2.tar.gz
gentoo-2-f98ee93bb0f25d34d03564ef6c35e36203a5d3b2.tar.bz2
gentoo-2-f98ee93bb0f25d34d03564ef6c35e36203a5d3b2.zip
Bump to 3.5.1. Fix python xml module dependency problem, bug #233166.
(Portage version: 2.2_rc20/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/iso-codes/ChangeLog10
-rw-r--r--app-text/iso-codes/iso-codes-3.5.1.ebuild39
2 files changed, 47 insertions, 2 deletions
diff --git a/app-text/iso-codes/ChangeLog b/app-text/iso-codes/ChangeLog
index a040bffe7a68..d9abd85e18fd 100644
--- a/app-text/iso-codes/ChangeLog
+++ b/app-text/iso-codes/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/iso-codes
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/ChangeLog,v 1.56 2008/11/22 16:07:44 jer Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/ChangeLog,v 1.57 2009/01/18 21:53:13 eva Exp $
+
+*iso-codes-3.5.1 (18 Jan 2009)
+
+ 18 Jan 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +iso-codes-3.5.1.ebuild:
+ Bump to 3.5.1. Fix python xml module dependency problem, bug #233166.
22 Nov 2008; Jeroen Roovers <jer@gentoo.org> iso-codes-3.3.ebuild:
Stable for HPPA (bug #246056).
diff --git a/app-text/iso-codes/iso-codes-3.5.1.ebuild b/app-text/iso-codes/iso-codes-3.5.1.ebuild
new file mode 100644
index 000000000000..9dfa16b51f15
--- /dev/null
+++ b/app-text/iso-codes/iso-codes-3.5.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/iso-codes-3.5.1.ebuild,v 1.1 2009/01/18 21:53:13 eva Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="Provides the list of country and language names"
+HOMEPAGE="http://alioth.debian.org/projects/pkg-isocodes/"
+SRC_URI="ftp://pkg-isocodes.alioth.debian.org/pub/pkg-isocodes/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=""
+DEPEND="sys-devel/gettext
+ || (
+ >=dev-lang/python-2.3[-build]
+ dev-python/pyxml )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # fix install location for multilib machines
+ sed -e 's:(datadir)/pkgconfig:(libdir)/pkgconfig:g' \
+ -i Makefile.am || die "sed failed"
+
+ eautomake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc ChangeLog README TODO
+}