summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-09-02 07:07:27 +0000
committerMamoru Komachi <usata@gentoo.org>2004-09-02 07:07:27 +0000
commitf769b400a473578cd7c1ccf4887b2345fef4ccfe (patch)
tree57ef528495b7ec66696177d1eb9d8de63a18cc75 /app-text
parentquick portage test. (Manifest recommit) (diff)
downloadgentoo-2-f769b400a473578cd7c1ccf4887b2345fef4ccfe.tar.gz
gentoo-2-f769b400a473578cd7c1ccf4887b2345fef4ccfe.tar.bz2
gentoo-2-f769b400a473578cd7c1ccf4887b2345fef4ccfe.zip
Fixed corrupted totex when installing noweb for the first time. See bug #50429.
Diffstat (limited to 'app-text')
-rw-r--r--app-text/noweb/ChangeLog7
-rw-r--r--app-text/noweb/noweb-2.9-r3.ebuild10
-rw-r--r--app-text/noweb/noweb-2.9-r4.ebuild11
3 files changed, 23 insertions, 5 deletions
diff --git a/app-text/noweb/ChangeLog b/app-text/noweb/ChangeLog
index f90767e91b13..6e2c20aa32e0 100644
--- a/app-text/noweb/ChangeLog
+++ b/app-text/noweb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/noweb
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/noweb/ChangeLog,v 1.16 2004/09/01 09:36:37 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/noweb/ChangeLog,v 1.17 2004/09/02 07:07:27 usata Exp $
+
+ 02 Sep 2004; Mamoru KOMACHI <usata@gentoo.org> noweb-2.9-r3.ebuild,
+ noweb-2.9-r4.ebuild:
+ Fixed corrupted totex when installing noweb for the first time.
+ See bug #50429.
*noweb-2.9-r4 (01 Sep 2004)
diff --git a/app-text/noweb/noweb-2.9-r3.ebuild b/app-text/noweb/noweb-2.9-r3.ebuild
index 91d0ca4c4a84..bf376f09b8cb 100644
--- a/app-text/noweb/noweb-2.9-r3.ebuild
+++ b/app-text/noweb/noweb-2.9-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/noweb/noweb-2.9-r3.ebuild,v 1.10 2004/09/01 09:36:37 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/noweb/noweb-2.9-r3.ebuild,v 1.11 2004/09/02 07:07:27 usata Exp $
inherit eutils
@@ -29,11 +29,17 @@ src_unpack() {
# make touch only touches the files required, not the whole
# tree as with find . -type f | xargs touch <obz@gentoo.org>
- make touch
+ #make touch
}
src_compile() {
+ # noweb tries to use notangle and noweb; see bug #50429
+ ( cd c; emake CFLAGS="${CFLAGS}" LIBSRC="awk" ) || die
+ export PATH="${PATH}:${T}"
+ emake BIN=${T} LIB=${T} LIBSRC="awk" install-code \
+ || die "make temporal install failed."
+
emake CFLAGS="${CFLAGS}" LIBSRC="awk" || die
}
diff --git a/app-text/noweb/noweb-2.9-r4.ebuild b/app-text/noweb/noweb-2.9-r4.ebuild
index 30d9a1740a10..98f9005f9409 100644
--- a/app-text/noweb/noweb-2.9-r4.ebuild
+++ b/app-text/noweb/noweb-2.9-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/noweb/noweb-2.9-r4.ebuild,v 1.1 2004/09/01 09:36:37 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/noweb/noweb-2.9-r4.ebuild,v 1.2 2004/09/02 07:07:27 usata Exp $
inherit eutils
@@ -30,13 +30,20 @@ src_unpack() {
# make touch only touches the files required, not the whole
# tree as with find . -type f | xargs touch <obz@gentoo.org>
- make touch
+ #make touch || die "make touch failed."
}
src_compile() {
local libsrc
use icon && libsrc="icon" || libsrc="awk"
+
+ # noweb tries to use notangle and noweb; see bug #50429
+ ( cd c; emake CFLAGS="${CFLAGS}" LIBSRC="$libsrc" ) || die
+ export PATH="${PATH}:${T}"
+ emake BIN=${T} LIB=${T} LIBSRC="$libsrc" install-code \
+ || die "make temporal install failed."
+
emake CFLAGS="${CFLAGS}" LIBSRC="$libsrc" || die
}