summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-10-18 21:10:36 +0000
committerDan Armak <danarmak@gentoo.org>2001-10-18 21:10:36 +0000
commitf6afe62c0e89324fa0fa995424637440f4b8117c (patch)
tree2c153fb6948d78e4da90bc0b0b107f8e2ad38a5e /app-text
parentfixes for "use build" (diff)
downloadgentoo-2-f6afe62c0e89324fa0fa995424637440f4b8117c.tar.gz
gentoo-2-f6afe62c0e89324fa0fa995424637440f4b8117c.tar.bz2
gentoo-2-f6afe62c0e89324fa0fa995424637440f4b8117c.zip
new rc6-initscript dictd
Diffstat (limited to 'app-text')
-rw-r--r--app-text/dictd/dictd-1.5.5-r6.ebuild48
-rw-r--r--app-text/dictd/files/1.5.5-r6/dict.conf6
-rw-r--r--app-text/dictd/files/1.5.5-r6/dictd.conf22
-rw-r--r--app-text/dictd/files/1.5.5-r6/dictd.rc674
-rw-r--r--app-text/dictd/files/1.5.5-r6/site.info6
-rw-r--r--app-text/dictd/files/digest-dictd-1.5.5-r61
6 files changed, 157 insertions, 0 deletions
diff --git a/app-text/dictd/dictd-1.5.5-r6.ebuild b/app-text/dictd/dictd-1.5.5-r6.ebuild
new file mode 100644
index 000000000000..9c00701fa26a
--- /dev/null
+++ b/app-text/dictd/dictd-1.5.5-r6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Michael Conrad Tilstra <michael@gentoo.org> <tadpol@tadpol.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/dictd/dictd-1.5.5-r6.ebuild,v 1.1 2001/10/18 21:10:36 danarmak Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Dictionary Client/Server for the DICT protocol"
+SRC_URI="ftp://ftp.dict.org/pub/dict/${A}"
+HOMEPAGE="http://www.dict.org"
+
+DEPEND="virtual/glibc sys-devel/gcc"
+
+src_compile() {
+
+ ./configure --prefix=/usr --mandir=/usr/share/man \
+ --with-etcdir=/etc/dict --host=${CHOST} || die
+ make || die
+}
+
+src_install () {
+ # gotta set up the dirs for it....
+ dodir /usr/bin
+ dodir /usr/sbin
+ dodir /usr/share/man/man1
+ dodir /usr/share/man/man8
+
+ #Now install it.
+ make prefix=${D}/usr man1_prefix=${D}/usr/share/man/man1 \
+ man8_prefix=${D}/usr/share/man/man8 conf=${D}/etc/dict install || die
+
+ #Install docs
+ dodoc README TODO COPYING ChangeLog ANNOUNCE
+ dodoc doc/dicf.ms doc/rfc.ms doc/rfc.sh doc/rfc2229.txt
+ dodoc doc/security.doc doc/toc.ms
+
+ #conf files.
+ dodir /etc/dict
+ insinto /etc/dict
+ doins ${FILESDIR}/${PVR}/dict.conf
+ doins ${FILESDIR}/${PVR}/dictd.conf
+ doins ${FILESDIR}/${PVR}/site.info
+
+ #startups for dictd
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/${PVR}/dictd.rc6 dictd
+}
+
diff --git a/app-text/dictd/files/1.5.5-r6/dict.conf b/app-text/dictd/files/1.5.5-r6/dict.conf
new file mode 100644
index 000000000000..e06c3d296ec3
--- /dev/null
+++ b/app-text/dictd/files/1.5.5-r6/dict.conf
@@ -0,0 +1,6 @@
+# This is the configuration file for dict.
+# Usually all you will ever need here is the server keywords.
+# Refer to the dict manpage for other options.
+# It will only check the second server if the first fails
+server localhost
+server dict.org
diff --git a/app-text/dictd/files/1.5.5-r6/dictd.conf b/app-text/dictd/files/1.5.5-r6/dictd.conf
new file mode 100644
index 000000000000..4cded974f973
--- /dev/null
+++ b/app-text/dictd/files/1.5.5-r6/dictd.conf
@@ -0,0 +1,22 @@
+# dictd configuration file.
+# whipped up by michael conrad tilstra <michael@gentoo.org>
+
+# Informational message
+site site.info
+
+# who's allowed. You might want to change this.
+access {
+ allow *
+}
+
+# Dictionaries are listed below.
+# The initrc script scans /usr/lib/dict and adds all of the dictionaries
+# it finds here.
+#
+# The initrc script will delete everything after the the last line and
+# replace it with what it finds. So add all of your things above.
+#
+# If this is a problem for people, contact me and
+# we can work out a different method.
+#
+#LASTLINE
diff --git a/app-text/dictd/files/1.5.5-r6/dictd.rc6 b/app-text/dictd/files/1.5.5-r6/dictd.rc6
new file mode 100644
index 000000000000..3ff4a2973f32
--- /dev/null
+++ b/app-text/dictd/files/1.5.5-r6/dictd.rc6
@@ -0,0 +1,74 @@
+#!/sbin/runscript
+
+EXEC=/usr/sbin/dictd
+EARGS="-s "
+DICTDCONF=/etc/dict/dictd.conf
+TMPCONF=/etc/dict/dictd.conf.$$
+
+prepconfig() {
+ if [ ! -e ${DICTDCONF} ]
+ then
+ eerror "dictd not started. Config file not found."
+ exit 1
+ fi
+ # if no dictionaries, skip startup.
+
+ # The new way of doing this is to scan /usr/lib/dict and tweek the conf
+ DLIBDIR=/usr/lib/dict
+
+ einfo "Scanning for dictionaries..."
+ if [ ! -d "${DLIBDIR}" ]; then
+ eerror "${DLIBDIR} doesn't exist, no dictionaries found."
+ exit 1
+ fi
+ pushd ${DLIBDIR} >/dev/null
+ INDEXFILES=`ls *.index`
+ if [ -z "$INDEXFILES" ]; then
+ eerror "No dictionaries installed."
+ exit 1
+ fi
+
+ cat $DICTDCONF | sed -e '/^#LASTLINE/,$d' > $TMPCONF
+ echo "#LASTLINE" >> $TMPCONF
+
+ CNT=0
+ for i in $INDEXFILES
+ do
+ DNAME=`echo $i | awk -F . '{print $1;}'`
+ #two possible names for a matching dictionary, check which is there.
+ if [ -f ${DNAME}.dict.dz ]; then
+ DICT=${DNAME}.dict.dz
+ elif [ -f ${DNAME}.dict ];then
+ DICT=${DNAME}.dict
+ else
+ einfo "Index $i has no matching dictionaray..."
+ fi
+
+ #ok, go an index, and a dixtionary, append.
+ echo "database $DNAME { data \"${DLIBDIR}/${DICT}\"" >> $TMPCONF
+ echo " index \"${DLIBDIR}/$i\" }" >> $TMPCONF
+
+ CNT=`expr $CNT + 1`
+ done
+ popd >/dev/null
+ mv ${TMPCONF} ${DICTDCONF}
+ einfo "Done, $CNT dictionary indexes found."
+}
+
+depend() {
+ need localmount
+}
+
+start() {
+ ebegin "Starting ${SERVICE}"
+ prepconfig
+ start-stop-daemon --start --quiet --exec $EXEC -- $EARGS
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SERVICE}"
+ start-stop-daemon --stop --quiet --name ${SERVICE} --exec $EXEC
+ eend $?
+}
+
diff --git a/app-text/dictd/files/1.5.5-r6/site.info b/app-text/dictd/files/1.5.5-r6/site.info
new file mode 100644
index 000000000000..23bfdeb61102
--- /dev/null
+++ b/app-text/dictd/files/1.5.5-r6/site.info
@@ -0,0 +1,6 @@
+Welcome to your dictionary server dictd!
+
+This is an example site information file. It should contain information
+about any restricted databases and how users can obtain access. If may
+also contain other random data as you see fit.
+
diff --git a/app-text/dictd/files/digest-dictd-1.5.5-r6 b/app-text/dictd/files/digest-dictd-1.5.5-r6
new file mode 100644
index 000000000000..875329fc7519
--- /dev/null
+++ b/app-text/dictd/files/digest-dictd-1.5.5-r6
@@ -0,0 +1 @@
+MD5 67307b6e5d0337f354b275c377506c63 dictd-1.5.5.tar.gz