summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-01-29 18:52:04 +0000
committerChris Reffett <creffett@gentoo.org>2013-01-29 18:52:04 +0000
commitf64958e6307864a86083dcc73fff57e6a7433125 (patch)
tree40466c084833f55a7b5f5949cd6ee9f1dd5b00a1 /app-text
parentapp-office/texmaker: Correct myspell dir path (diff)
downloadgentoo-2-f64958e6307864a86083dcc73fff57e6a7433125.tar.gz
gentoo-2-f64958e6307864a86083dcc73fff57e6a7433125.tar.bz2
gentoo-2-f64958e6307864a86083dcc73fff57e6a7433125.zip
Revision bump, add patch to allow SCons to use environment CC, CFLAGS, and LDFLAGS, remove auto-set CFLAGS such as -g.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/glosung/ChangeLog10
-rw-r--r--app-text/glosung/files/glosung-3.6.2-scons-respectflags.patch64
-rw-r--r--app-text/glosung/glosung-3.6.2-r1.ebuild (renamed from app-text/glosung/glosung-3.6.2.ebuild)6
3 files changed, 77 insertions, 3 deletions
diff --git a/app-text/glosung/ChangeLog b/app-text/glosung/ChangeLog
index 06a7b29cad2f..eba71840ec1c 100644
--- a/app-text/glosung/ChangeLog
+++ b/app-text/glosung/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-text/glosung
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/glosung/ChangeLog,v 1.13 2013/01/21 20:23:46 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/glosung/ChangeLog,v 1.14 2013/01/29 18:52:04 creffett Exp $
+
+*glosung-3.6.2-r1 (29 Jan 2013)
+
+ 29 Jan 2013; Chris Reffett <creffett@gentoo.org>
+ +files/glosung-3.6.2-scons-respectflags.patch, +glosung-3.6.2-r1.ebuild,
+ -glosung-3.6.2.ebuild:
+ Revision bump, add patch to allow SCons to use environment CC, CFLAGS, and
+ LDFLAGS, remove auto-set CFLAGS such as -g.
*glosung-3.6.2 (21 Jan 2013)
diff --git a/app-text/glosung/files/glosung-3.6.2-scons-respectflags.patch b/app-text/glosung/files/glosung-3.6.2-scons-respectflags.patch
new file mode 100644
index 000000000000..15c12bf94888
--- /dev/null
+++ b/app-text/glosung/files/glosung-3.6.2-scons-respectflags.patch
@@ -0,0 +1,64 @@
+--- a/SConstruct
++++ b/SConstruct
+@@ -17,6 +17,7 @@
+
+
+ import os
++import SCons.Util
+
+ version = '3.6.2'
+
+@@ -32,14 +33,23 @@
+ (this option is only for packaging)''')
+
+ env = Environment (
+- LINK = 'gcc',
+- CC = 'gcc',
++ CC = '',
+ CPPPATH = '',
+ LINKFLAGS = '',
+ CCFLAGS = '',
+ ENV = os.environ,
+ TARFLAGS = '-c -j')
+
++if os.environ.has_key('CC'):
++ env['CC'] = os.environ['CC']
++if os.environ.has_key('CFLAGS'):
++ env['CCFLAGS'] += SCons.Util.CLVar(os.environ['CFLAGS'])
++if os.environ.has_key('CXX'):
++ env['CXX'] = os.environ['CXX']
++if os.environ.has_key('CXXFLAGS'):
++ env['CXXFLAGS'] += SCons.Util.CLVar(os.environ['CXXFLAGS'])
++if os.environ.has_key('LDFLAGS'):
++ env['LINKFLAGS'] += SCons.Util.CLVar(os.environ['LDFLAGS'])
+
+ if env['PLATFORM'] == 'win32':
+ prefix = ARGUMENTS.get ('PREFIX', '')
+@@ -58,7 +68,7 @@
+ BuildDir ('build', 'src')
+
+ cpppath = ['#', '#build']
+-ccflags = ['-O2', '-std=c99', '-Wall', '-g', '-Wl,--export-dynamic',
++ccflags = ['-std=c99',
+ # '-DLIBXML_STATIC',
+ '-DVERSION=\\"' + version + '\\"',
+ '-DGLOSUNG_DATA_DIR=\\"' + data_dir + '\\"',
+@@ -74,7 +74,7 @@
+ '-DGLOSUNG_DATA_DIR=\\"' + data_dir + '\\"',
+ '-DPACKAGE_PIXMAPS_DIR=\\"' + pixmap_dir + '\\"']
+
+-linkflags = ['-Wl,--export-dynamic', '-L.']
++linkflags = []
+ # -L/usr/lib'
+ # `pkg-config --libs gtk+-2.0 libxml-2.0 gconf-2.0 libcurl`
+
+@@ -83,9 +83,6 @@
+ ccflags.append ('-pg', '-fprofile-arcs')
+ linkflags.append ('-pg', '-fprofile-arcs')
+
+-if env['PLATFORM'] != 'win32':
+- linkflags.append ('-Wl,--as-needed')
+-
+ #if not (ARGUMENTS.get ('dev')):
+ if (ARGUMENTS.get ('dev')):
+ ccflags += [
diff --git a/app-text/glosung/glosung-3.6.2.ebuild b/app-text/glosung/glosung-3.6.2-r1.ebuild
index 873937dfee6b..1b7e7ad493de 100644
--- a/app-text/glosung/glosung-3.6.2.ebuild
+++ b/app-text/glosung/glosung-3.6.2-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/glosung/glosung-3.6.2.ebuild,v 1.1 2013/01/21 20:23:46 creffett Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/glosung/glosung-3.6.2-r1.ebuild,v 1.1 2013/01/29 18:52:04 creffett Exp $
EAPI=5
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Watch word program for the GNOME2 desktop (watch word (german): losung)"
HOMEPAGE="http://www.godehardt.org/losung.html"
SRC_URI="mirror://sourceforge/glosung/${P}.tar.bz2"
@@ -32,9 +32,11 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}/${PN}-3.6.2-glib-includes.patch"
+ epatch "${FILESDIR}/${PN}-3.6.2-scons-respectflags.patch"
}
src_compile() {
+ tc-export CC
scons ${MAKEOPTS} || die "scons make died"
}