summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2009-06-23 22:23:49 +0000
committerZac Medico <zmedico@gentoo.org>2009-06-23 22:23:49 +0000
commitf19414fe32e1e88e23fe48bc6bbde4abab95202d (patch)
tree596a4c04a481a57a6a71e228a5c74be871556ff1 /app-text
parentNew alpha from upstream. I would carry the patch from alpha1-r1 over if it di... (diff)
downloadgentoo-2-f19414fe32e1e88e23fe48bc6bbde4abab95202d.tar.gz
gentoo-2-f19414fe32e1e88e23fe48bc6bbde4abab95202d.tar.bz2
gentoo-2-f19414fe32e1e88e23fe48bc6bbde4abab95202d.zip
0.6_beta8 bump.
(Portage version: 2.2_rc33_p13678/cvs/Linux i686)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/calibre/ChangeLog7
-rw-r--r--app-text/calibre/calibre-0.6_beta8.ebuild131
2 files changed, 137 insertions, 1 deletions
diff --git a/app-text/calibre/ChangeLog b/app-text/calibre/ChangeLog
index cfacf5e2203a..db36f0494320 100644
--- a/app-text/calibre/ChangeLog
+++ b/app-text/calibre/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/calibre
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/calibre/ChangeLog,v 1.33 2009/06/16 18:52:47 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/calibre/ChangeLog,v 1.34 2009/06/23 22:23:49 zmedico Exp $
+
+*calibre-0.6_beta8 (23 Jun 2009)
+
+ 23 Jun 2009; Zac Medico <zmedico@gentoo.org> +calibre-0.6_beta8.ebuild:
+ 0.6_beta8 bump.
16 Jun 2009; Zac Medico <zmedico@gentoo.org> -calibre-0.4.76.ebuild,
-calibre-0.5.13-r2.ebuild, -files/bug_270746_UnicodeEncodeError.patch:
diff --git a/app-text/calibre/calibre-0.6_beta8.ebuild b/app-text/calibre/calibre-0.6_beta8.ebuild
new file mode 100644
index 000000000000..efa8fcdef319
--- /dev/null
+++ b/app-text/calibre/calibre-0.6_beta8.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/calibre/calibre-0.6_beta8.ebuild,v 1.1 2009/06/23 22:23:49 zmedico Exp $
+
+EAPI=2
+NEED_PYTHON=2.6
+
+inherit python distutils eutils fdo-mime bash-completion
+
+DESCRIPTION="Ebook management application."
+HOMEPAGE="http://calibre.kovidgoyal.net"
+# Snapshots for beta releases are not distributed on upstream mirrors.
+SRC_URI="mirror://gentoo/$P.tar.gz"
+#SRC_URI="http://calibre.kovidgoyal.net/downloads/$P.tar.gz"
+
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~x86"
+
+SLOT="0"
+
+IUSE=""
+
+# libusb-compat is untested
+SHARED_DEPEND=">=dev-lang/python-2.6[sqlite]
+ >=dev-python/setuptools-0.6_rc5
+ >=dev-python/imaging-1.1.6
+ dev-libs/libusb:0
+ >=dev-python/PyQt4-4.4.2[X,svg,webkit]
+ >=dev-python/mechanize-0.1.11
+ >=media-gfx/imagemagick-6.3.5
+ >=x11-misc/xdg-utils-1.0.2
+ >=dev-python/dbus-python-0.82.2
+ >=dev-python/lxml-2.1.5
+ >=dev-python/python-dateutil-1.4.1
+ >=dev-python/beautifulsoup-3.0.5
+ >=dev-python/dnspython-1.6.0
+ >=sys-apps/help2man-1.36.4
+ >=dev-python/pyPdf-1.12
+ >=app-text/pdftk-1.12
+ >=dev-python/cherrypy-3.0.2-r1
+ >=dev-python/cssutils-0.9.5.1
+ >=dev-python/odfpy-0.7"
+
+RDEPEND="$SHARED_DEPEND
+ >=dev-python/reportlab-2.1
+ !dev-python/django-tagging"
+
+DEPEND="$SHARED_DEPEND
+ dev-python/setuptools
+ >=gnome-base/librsvg-2.0.0
+ >=x11-misc/xdg-utils-1.0.2-r2
+ sys-apps/help2man"
+
+src_prepare() {
+ # Removing the post_install call. We'll do that stuff in src_install.
+ sed -i -e "/if 'install'/,/subprocess.check_call/d" \
+ setup.py || die "couldn't remove post_install call"
+ # For help2man to succeed, we need to tell it the path to the tools.
+ sed -i -e "s:\('help2man',\) \(prog\):\1 \'PYTHONPATH=\"${D}$(python_get_sitedir)\" \' + \'${D}usr/bin/\' + \2:" \
+ src/calibre/linux.py || die "sed'ing in the IMAGE path failed"
+ # Avoid sandbox violation in /usr/share/gnome/apps when linux.py
+ # calls xdg-desktop-menu (bug #258938). This also prevents
+ # "${D}"/usr/share/applications/{mimeinfo.cache,defaults.list}
+ # from being installed (we don't want them anyway).
+ sed -i -e "s:xdg-desktop-menu install:xdg-desktop-menu install --mode user:" \
+ src/calibre/linux.py || die "sed'ing in the IMAGE path failed"
+ distutils_src_prepare
+}
+
+src_install() {
+ pushd "${S}"/build
+ ln -s lib\.* lib
+ popd
+ distutils_src_install
+
+ # Create directory before running the postinst script
+ # otherwise it will bail out.
+ dodir /usr/share/icons/hicolor
+ dodir /etc/xdg/menus
+ dodir /usr/share/applications
+ dodir /usr/share/desktop-directories
+ dodir /usr/share/applnk
+ dodir /usr/share/mime/packages
+
+ # Bypass the default kde-config output, and force it to
+ # tell xdg-mime to use a different path.
+ cat - > "${T}/kde-config" <<EOF
+#!/bin/bash
+
+case \$1:\$2 in
+ --version:) echo -e "Qt: 3.3.8\nKDE: 3.5.8\nkde-config: 1.0" ;;
+ --path:mime) echo "${D}/usr/share/mimelnk/" ;;
+esac
+EOF
+
+ chmod +x "${T}/kde-config"
+
+ PATH="${T}:${PATH}" KDEDIRS="${D}/usr" XDG_DATA_DIRS="${D}/usr/share" DESTDIR="${D}" PYTHONPATH="${S}/build/lib" \
+ python "${S}"/src/${PN}/linux.py \
+ --use-destdir --do-not-reload-udev-hal \
+ --group-file="${ROOT}"/etc/group --dont-check-root \
+ || die "post-installation failed."
+
+ # The menu entries end up here due to '--mode user' being added to
+ # xdg-desktop-menu options in src_prepare.
+ domenu "$HOME"/.local/share/applications/*.desktop || \
+ die "failed to install .desktop menu files"
+
+ # Move the bash-completion file and properly install it.
+ mv "${D}"/etc/bash_completion.d/calibre "${S}/" \
+ || die "cannot move the bash-completion file"
+ dobashcompletion "${S}"/calibre
+ find "${D}"/etc -type d -empty -delete
+
+ # Removing junk.
+ # Bundled python modules: Module | Package
+ # ----------------------------
+ # encutils | cssutils
+ # odf | odfpy
+ rm -r "${D}"/usr/share/mime/{subclasses,XMLnamespaces,globs{,2},mime.cache,magic,aliases,types,treemagic,{generic-,}icons} \
+ "${D}"/usr/share/{applnk,desktop-directories} \
+ "${D}$(python_get_sitedir)"/{cherrypy,cssutils,encutils,odf,pyPdf}
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ distutils_pkg_postinst
+ bash-completion_pkg_postinst
+}