summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2010-01-05 21:15:41 +0000
committerSteve Dibb <beandog@gentoo.org>2010-01-05 21:15:41 +0000
commitf0379f20218ea0b36f61d4465f1af145a1286ab2 (patch)
tree8a19ee491cb7ab0bdfad90e5451758dc6cf03e33 /app-text
parentInitial commit. This is a runtime depend of app-office/scribus. (diff)
downloadgentoo-2-f0379f20218ea0b36f61d4465f1af145a1286ab2.tar.gz
gentoo-2-f0379f20218ea0b36f61d4465f1af145a1286ab2.tar.bz2
gentoo-2-f0379f20218ea0b36f61d4465f1af145a1286ab2.zip
Version bump
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/sword/ChangeLog9
-rw-r--r--app-text/sword/sword-1.6.1.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/app-text/sword/ChangeLog b/app-text/sword/ChangeLog
index 18f279972f7e..f5b95ee6f8ed 100644
--- a/app-text/sword/ChangeLog
+++ b/app-text/sword/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/sword
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sword/ChangeLog,v 1.55 2009/12/03 10:54:01 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/sword/ChangeLog,v 1.56 2010/01/05 21:15:41 beandog Exp $
+
+*sword-1.6.1 (05 Jan 2010)
+
+ 05 Jan 2010; Steve Dibb <beandog@gentoo.org> +sword-1.6.1.ebuild:
+ Version bump
03 Dec 2009; Markus Meier <maekke@gentoo.org> sword-1.6.0.ebuild:
amd64 stable, bug #294863
diff --git a/app-text/sword/sword-1.6.1.ebuild b/app-text/sword/sword-1.6.1.ebuild
new file mode 100644
index 000000000000..8e15df44fed7
--- /dev/null
+++ b/app-text/sword/sword-1.6.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/sword/sword-1.6.1.ebuild,v 1.1 2010/01/05 21:15:41 beandog Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Library for Bible reading software."
+HOMEPAGE="http://www.crosswire.org/sword/"
+SRC_URI="http://www.crosswire.org/ftpmirror/pub/sword/source/v1.6/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="curl debug doc icu lucene"
+
+RDEPEND="sys-libs/zlib
+ curl? ( net-misc/curl )
+ icu? ( dev-libs/icu )
+ lucene? ( dev-cpp/clucene )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ strip-flags
+ econf --with-zlib \
+ --with-conf \
+ $(use_with curl) \
+ $(use_enable debug) \
+ $(use_with icu) \
+ $(use_with lucene) || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS CODINGSTYLE ChangeLog README
+ if use doc ;then
+ rm -rf examples/.cvsignore
+ rm -rf examples/cmdline/.cvsignore
+ rm -rf examples/cmdline/.deps
+ cp -R samples examples "${D}/usr/share/doc/${PF}/"
+ fi
+ # global configuration file
+ insinto /etc
+ doins "${FILESDIR}/sword.conf"
+}
+
+pkg_postinst() {
+ echo
+ elog "Check out http://www.crosswire.org/sword/modules/"
+ elog "to download modules that you would like to use with SWORD."
+ elog "Follow module installation instructions found on"
+ elog "the web or in /usr/share/doc/${PF}/"
+ echo
+}