summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-05-14 09:38:33 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-05-14 09:38:33 +0000
commite742a76fede5c088575a950e2f30509672ee0d70 (patch)
tree9386c25d7df4efc56c99ba31f88b9369986daeb3 /app-text
parentx86 stable per bug 363311 (diff)
downloadgentoo-2-e742a76fede5c088575a950e2f30509672ee0d70.tar.gz
gentoo-2-e742a76fede5c088575a950e2f30509672ee0d70.tar.bz2
gentoo-2-e742a76fede5c088575a950e2f30509672ee0d70.zip
Revbump to fix offended keysym. Thanks to Christian Speckner <cnspeckn@physik.uni-wuerzburg.de> for the patch. Bug #339394
(Portage version: 2.1.9.47/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/gv/ChangeLog11
-rw-r--r--app-text/gv/files/gv-3.7.1-aplinedel.patch11
-rw-r--r--app-text/gv/gv-3.7.1-r1.ebuild55
3 files changed, 75 insertions, 2 deletions
diff --git a/app-text/gv/ChangeLog b/app-text/gv/ChangeLog
index 3c9b13285734..adea69853edf 100644
--- a/app-text/gv/ChangeLog
+++ b/app-text/gv/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/gv
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gv/ChangeLog,v 1.85 2010/08/16 02:23:37 jer Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gv/ChangeLog,v 1.86 2011/05/14 09:38:32 hwoarang Exp $
+
+*gv-3.7.1-r1 (14 May 2011)
+
+ 14 May 2011; Markos Chandras <hwoarang@gentoo.org> +gv-3.7.1-r1.ebuild,
+ +files/gv-3.7.1-aplinedel.patch:
+ Revbump to fix offended keysym. Thanks to Christian Speckner
+ <cnspeckn@physik.uni-wuerzburg.de> for the patch. Bug #339394
16 Aug 2010; Jeroen Roovers <jer@gentoo.org> gv-3.7.1.ebuild:
Stable for HPPA (bug #329125).
diff --git a/app-text/gv/files/gv-3.7.1-aplinedel.patch b/app-text/gv/files/gv-3.7.1-aplinedel.patch
new file mode 100644
index 000000000000..3026e426c0e2
--- /dev/null
+++ b/app-text/gv/files/gv-3.7.1-aplinedel.patch
@@ -0,0 +1,11 @@
+diff -ur a/src/gv_misc_res.dat b/src/gv_misc_res.dat
+--- a/src/gv_misc_res.dat 2010-10-15 09:21:36.000000000 +0200
++++ b/src/gv_misc_res.dat 2010-10-15 09:21:48.000000000 +0200
+@@ -476,7 +476,6 @@
+ <Key>BackSpace: GV_Page(up,left-bottom,!page-1,bottom-rightedge)\n\
+ <Key>Insert: GV_Page(page-5) \n\
+ <Key>Delete: GV_Page(page+5) \n\
+- <Key>apLineDel: GV_Page(page+5) \n\
+ <Key>Home: GV_Page(page=0) \n\
+ <Key>End: GV_Page(page=99999) \n\
+ <Key>Prior: GV_Page(page-1) \n\
diff --git a/app-text/gv/gv-3.7.1-r1.ebuild b/app-text/gv/gv-3.7.1-r1.ebuild
new file mode 100644
index 000000000000..e102f5a2772b
--- /dev/null
+++ b/app-text/gv/gv-3.7.1-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gv/gv-3.7.1-r1.ebuild,v 1.1 2011/05/14 09:38:32 hwoarang Exp $
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="gv is used to view PostScript and PDF documents using Ghostscript"
+HOMEPAGE="http://www.gnu.org/software/gv/"
+SRC_URI="mirror://gnu/gv/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="xinerama"
+
+DEPEND="x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXext
+ x11-libs/libXt
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/Xaw3d
+ app-text/ghostscript-gpl
+ xinerama? ( x11-libs/libXinerama )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/gv-3.6.1-a0.patch
+ epatch "${FILESDIR}"/${P}-aplinedel.patch
+
+ if ! use xinerama; then
+ sed -i -e 's:Xinerama:dIsAbLe&:' configure.ac || die
+ fi
+
+ sed -i \
+ -e "s:-dGraphicsAlphaBits=2:\0 -dAlignToPixels=0:" \
+ src/Makefile.am || die #135354
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --enable-scrollbar-code
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+
+ doicon "${FILESDIR}"/gv_icon.xpm
+ make_desktop_entry gv GhostView gv_icon "Graphics;Viewer"
+}