summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-10-29 03:44:26 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-10-29 03:44:26 +0000
commitd935a417af7e778c2014ceefa4bca856da6bbacb (patch)
tree28122ae1e9099bf85b8eef2a9bdd696c4ba18f18 /app-text
parentFixed logging issue. Upstream bug 509. (diff)
downloadgentoo-2-d935a417af7e778c2014ceefa4bca856da6bbacb.tar.gz
gentoo-2-d935a417af7e778c2014ceefa4bca856da6bbacb.tar.bz2
gentoo-2-d935a417af7e778c2014ceefa4bca856da6bbacb.zip
Bump
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/pelican/ChangeLog7
-rw-r--r--app-text/pelican/pelican-3.3.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/app-text/pelican/ChangeLog b/app-text/pelican/ChangeLog
index a34aa6b5cb81..b4c16ce80994 100644
--- a/app-text/pelican/ChangeLog
+++ b/app-text/pelican/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/pelican
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pelican/ChangeLog,v 1.11 2013/06/13 08:48:51 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pelican/ChangeLog,v 1.12 2013/10/29 03:44:26 patrick Exp $
+
+*pelican-3.3 (29 Oct 2013)
+
+ 29 Oct 2013; Patrick Lauer <patrick@gentoo.org> +pelican-3.3.ebuild:
+ Bump
*pelican-3.2.2 (13 Jun 2013)
diff --git a/app-text/pelican/pelican-3.3.ebuild b/app-text/pelican/pelican-3.3.ebuild
new file mode 100644
index 000000000000..47beabdde4a3
--- /dev/null
+++ b/app-text/pelican/pelican-3.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pelican/pelican-3.3.ebuild,v 1.1 2013/10/29 03:44:26 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool to generate a static blog, with restructured text (or markdown) input files."
+HOMEPAGE="http://pelican.notmyidea.org/ http://pypi.python.org/pypi/pelican"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples markdown"
+
+DEPEND="dev-python/feedgenerator[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ markdown? ( dev-python/markdown[${PYTHON_USEDEP}] )
+ virtual/python-argparse[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+DOCS=( README.rst )
+
+python_install_all() {
+ use examples && local EXAMPLES=( samples/. )
+ distutils-r1_python_install_all
+}
+
+# no tests: tests/content not in tarball for 2.8.1
+# for 3.0, should be based on tox (refer to virtualenvwrapper)