summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-10-25 14:05:29 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-10-25 14:05:29 +0000
commitd8bef201fbfa4a81312f100bb8260b39f8b7f927 (patch)
tree8d455c9f4a56a8e8fc792555aad3726951a1f6c4 /app-text
parentremoved --with-gnome (which doesn't exist according to the configure-script, ... (diff)
downloadgentoo-2-d8bef201fbfa4a81312f100bb8260b39f8b7f927.tar.gz
gentoo-2-d8bef201fbfa4a81312f100bb8260b39f8b7f927.tar.bz2
gentoo-2-d8bef201fbfa4a81312f100bb8260b39f8b7f927.zip
updated to 1.1.90, didn't get 1.0.2 to work with pdf and it seems to be better than 1.0.1
Diffstat (limited to 'app-text')
-rw-r--r--app-text/ggv/files/digest-ggv-1.1.901
-rw-r--r--app-text/ggv/ggv-1.1.90.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-text/ggv/files/digest-ggv-1.1.90 b/app-text/ggv/files/digest-ggv-1.1.90
new file mode 100644
index 000000000000..eae5287a0407
--- /dev/null
+++ b/app-text/ggv/files/digest-ggv-1.1.90
@@ -0,0 +1 @@
+MD5 c883d809221cc11a3b5007a6c258ea8f ggv-1.1.90.tar.gz
diff --git a/app-text/ggv/ggv-1.1.90.ebuild b/app-text/ggv/ggv-1.1.90.ebuild
new file mode 100644
index 000000000000..be9ab5ab86f0
--- /dev/null
+++ b/app-text/ggv/ggv-1.1.90.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/ggv/ggv-1.1.90.ebuild,v 1.1 2001/10/25 14:05:29 hallski Exp $
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gnome Ghostview"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/"
+
+RDEPEND=">=gnome-base/gnome-libs-1.4.1.2-r1
+ bonobo? ( >=gnome-base/bonobo-1.0.9-r1 )"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+
+ if [ "`use bonobo`" ] ; then
+ myconf="$myconf --with-bonobo"
+ CFLAGS="${CFLAGS} `gnome-config --cflags bonobo bonobox`"
+ else
+ myconf="$myconf --without-bonobo"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ $myconf || die
+
+ emake || die
+}
+
+src_install() {
+ gconftool --shutdown
+
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+}
+