summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-01-14 07:08:53 +0000
committerHans de Graaff <graaff@gentoo.org>2012-01-14 07:08:53 +0000
commitd78079d3a64d1ff67828114d34fbbc967263f1ab (patch)
treef0612c4e43dc3a96626fdfba06c208866707596a /app-text
parentUpdate old grep style which fails with newer versions #349770 by Diego Elio P... (diff)
downloadgentoo-2-d78079d3a64d1ff67828114d34fbbc967263f1ab.tar.gz
gentoo-2-d78079d3a64d1ff67828114d34fbbc967263f1ab.tar.bz2
gentoo-2-d78079d3a64d1ff67828114d34fbbc967263f1ab.zip
Revision bump to create a stable candidate without ruby19.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/ronn/ChangeLog10
-rw-r--r--app-text/ronn/ronn-0.7.3-r1.ebuild40
-rw-r--r--app-text/ronn/ronn-0.7.3.ebuild6
3 files changed, 51 insertions, 5 deletions
diff --git a/app-text/ronn/ChangeLog b/app-text/ronn/ChangeLog
index a370d94c7e54..03c52e46da57 100644
--- a/app-text/ronn/ChangeLog
+++ b/app-text/ronn/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/ronn
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ronn/ChangeLog,v 1.6 2011/12/27 12:39:41 graaff Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/ronn/ChangeLog,v 1.7 2012/01/14 07:08:53 graaff Exp $
+
+*ronn-0.7.3-r1 (14 Jan 2012)
+
+ 14 Jan 2012; Hans de Graaff <graaff@gentoo.org> ronn-0.7.3.ebuild,
+ +ronn-0.7.3-r1.ebuild:
+ Revision bump to create a stable candidate without ruby19.
27 Dec 2011; Hans de Graaff <graaff@gentoo.org> ronn-0.7.3.ebuild:
Add ruby19. Fix test suite to always use the ruby interpreter tested.
diff --git a/app-text/ronn/ronn-0.7.3-r1.ebuild b/app-text/ronn/ronn-0.7.3-r1.ebuild
new file mode 100644
index 000000000000..2a1acfe6be6a
--- /dev/null
+++ b/app-text/ronn/ronn-0.7.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/ronn/ronn-0.7.3-r1.ebuild,v 1.1 2012/01/14 07:08:53 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="AUTHORS CHANGES README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ronn converts simple, human readable textfiles to roff for terminal display, and also to HTML."
+HOMEPAGE="http://github.com/rtomayko/ronn/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/hpricot-0.8.2
+ >=dev-ruby/mustache-0.7.0
+ >=dev-ruby/rdiscount-1.5.8"
+
+each_ruby_prepare() {
+ # Make sure that we always use the right interpreter during tests.
+ sed -i -e "/output/ s:ronn:${RUBY} bin/ronn:" test/test_ronn.rb
+}
+
+all_ruby_compile() {
+ PATH="${S}/bin:${PATH}" rake man || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/ronn.1 man/ronn-format.7
+}
diff --git a/app-text/ronn/ronn-0.7.3.ebuild b/app-text/ronn/ronn-0.7.3.ebuild
index c83408bd56b1..19def95d60b0 100644
--- a/app-text/ronn/ronn-0.7.3.ebuild
+++ b/app-text/ronn/ronn-0.7.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ronn/ronn-0.7.3.ebuild,v 1.6 2011/12/27 12:39:41 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ronn/ronn-0.7.3.ebuild,v 1.7 2012/01/14 07:08:53 graaff Exp $
EAPI=2
-USE_RUBY="ruby18 ruby19 ree18"
+USE_RUBY="ruby18 ree18"
RUBY_FAKEGEM_TASK_DOC=""
RUBY_FAKEGEM_EXTRADOC="AUTHORS CHANGES README.md"