summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Gurr <tgurr@gentoo.org>2008-11-06 01:23:31 +0000
committerTimo Gurr <tgurr@gentoo.org>2008-11-06 01:23:31 +0000
commitced970df88af5bff09d4a8848d7d490a2dcfce28 (patch)
tree0106da5044cc18788162e0d28920266bab719c48 /app-text
parentDie when make install fails, fixes bug 245454. And not allowing parallel make... (diff)
downloadgentoo-2-ced970df88af5bff09d4a8848d7d490a2dcfce28.tar.gz
gentoo-2-ced970df88af5bff09d4a8848d7d490a2dcfce28.tar.bz2
gentoo-2-ced970df88af5bff09d4a8848d7d490a2dcfce28.zip
Version bump. This version addresses many security issues, see bug #225483. Also fixing bug #237376 and bug #237639, thanks Pacho Ramos for the diff.
(Portage version: 2.2_rc13/cvs/Linux 2.6.27-gentoo-r1 x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/acroread/ChangeLog10
-rw-r--r--app-text/acroread/acroread-8.1.3.ebuild (renamed from app-text/acroread/acroread-8.1.2-r2.ebuild)58
2 files changed, 34 insertions, 34 deletions
diff --git a/app-text/acroread/ChangeLog b/app-text/acroread/ChangeLog
index 2108243448d0..15a0988da81a 100644
--- a/app-text/acroread/ChangeLog
+++ b/app-text/acroread/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-text/acroread
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/acroread/ChangeLog,v 1.119 2008/10/05 20:32:15 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/acroread/ChangeLog,v 1.120 2008/11/06 01:23:31 tgurr Exp $
+
+*acroread-8.1.3 (06 Nov 2008)
+
+ 06 Nov 2008; Timo Gurr <tgurr@gentoo.org> -acroread-8.1.2-r2.ebuild,
+ +acroread-8.1.3.ebuild:
+ Version bump. This version addresses many security issues, see bug
+ #225483. Also fixing bug #237376 and bug #237639, thanks Pacho Ramos for
+ the diff.
05 Oct 2008; Raúl Porcel <armin76@gentoo.org> acroread-8.1.2-r2.ebuild,
acroread-8.1.2-r3.ebuild:
diff --git a/app-text/acroread/acroread-8.1.2-r2.ebuild b/app-text/acroread/acroread-8.1.3.ebuild
index 5a9f912e9947..f86abacefbee 100644
--- a/app-text/acroread/acroread-8.1.2-r2.ebuild
+++ b/app-text/acroread/acroread-8.1.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/acroread/acroread-8.1.2-r2.ebuild,v 1.3 2008/10/05 20:32:15 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/acroread/acroread-8.1.3.ebuild,v 1.1 2008/11/06 01:23:31 tgurr Exp $
-inherit eutils nsplugins
+inherit eutils gnome2-utils nsplugins
DESCRIPTION="Adobe's PDF reader"
HOMEPAGE="http://www.adobe.com/products/acrobat/"
@@ -26,7 +26,7 @@ SRC_URI="${SRC_URI}
LICENSE="Adobe"
SLOT="0"
-KEYWORDS="-* amd64 x86"
+KEYWORDS="-* ~amd64 ~x86"
RESTRICT="strip mirror"
# mozilla-firefox-bin won't work because it doesn't have gtkembedmoz.so
@@ -65,7 +65,6 @@ LAUNCHERS="Adobe/Reader8/bin/acroread"
pkg_setup() {
# x86 binary package, ABI=x86
- # Danny van Dyk <kugelfang@gentoo.org> 2005/03/25
has_multilib_profile && ABI="x86"
}
@@ -154,14 +153,6 @@ src_unpack() {
rm "${S}"/Adobe/Reader8/bin/UNINSTALL
rm "${S}"/Adobe/Reader8/Resource/Support/vnd.*.desktop
- # fix CVE-2008-0883 the sed way, see bug #212367
- local binfile
- for binfile in "${S}"/Adobe/Reader8/bin/* ; do
- sed -i -e '/MkTemp()/,+17d' \
- -e 's/MkTemp/mktemp/g' \
- "${binfile}" || die "sed failed"
- done
-
# replace some configuration sections
for binfile in "${S}"/Adobe/Reader8/bin/* ; do
sed -i -e '/Font-config/,+10d' \
@@ -171,36 +162,33 @@ src_unpack() {
}
src_install() {
- local dir
-
# Install desktop files
- domenu Adobe/Reader8/Resource/Support
- # Install Icons - choose 48x48 since that's what the previous versions
- # supplied.
- doicon Adobe/Reader8/Resource/Icons/48x48
+ domenu Adobe/Reader8/Resource/Support || die "Installing desktop files failed."
+
+ # Install commonly used icon sizes
+ for res in 16x16 22x22 32x32 48x48 64x64 128x128 ; do
+ insinto /usr/share/icons/hicolor/${res}/apps
+ doins Adobe/Reader8/Resource/Icons/${res}/* || die "Installing icons failed."
+ done
- dodir /opt
+ dodir /opt || die "Creating directoy failed."
chown -R --dereference -L root:0 Adobe
cp -dpR Adobe "${D}"opt/
# The Browser_Plugin_HowTo.txt is now in a subdirectory, which
# is named according to the language the user is using.
# Ie. for German, it is in a DEU directory. See bug #118015
- dodoc Adobe/Reader8/Browser/HowTo/*/Browser_Plugin_HowTo.txt
+ dodoc Adobe/Reader8/Browser/HowTo/*/Browser_Plugin_HowTo.txt || die "Installing docs failed."
if use nsplugin ; then
exeinto /opt/netscape/plugins
- doexe Adobe/Reader8/Browser/intellinux/nppdf.so
+ doexe Adobe/Reader8/Browser/intellinux/nppdf.so || die "Installing the browser plugin failed."
inst_plugin /opt/netscape/plugins/nppdf.so
fi
- if ! use ldap ; then
- rm "${D}"${INSTALLDIR}/Adobe/Reader8/Reader/intellinux/plug_ins/PPKLite.api
- fi
-
- dodir /opt/bin
+ dodir /opt/bin || die "Creating directory failed."
for launcher in ${LAUNCHERS} ; do
- dosym /opt/${launcher} /opt/bin/${launcher/*bin\/}
+ dosym /opt/${launcher} /opt/bin/${launcher/*bin\/} || die "Installing launcher symlinks failed."
done
# We need to set a MOZILLA_COMP_PATH for seamonkey and firefox since
@@ -230,13 +218,11 @@ src_install() {
fi
}
-pkg_postinst () {
- use ldap ||
- elog "The Adobe Reader security plugin can be enabled with USE=\"ldap\"."
-
- use nsplugin ||
- elog "The Adobe Reader browser plugin can be enabled with USE=\"nsplugin\"."
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+pkg_postinst () {
local ll lc
lc=0
for ll in ${LINGUA_LIST} ; do
@@ -254,4 +240,10 @@ pkg_postinst () {
ewarn "If you want html support and/or view the Adobe Reader help you have"
ewarn "to re-emerge acroread with USE=\"-minimal\"."
fi
+
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
}