summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-01-18 15:07:22 +0000
committerJustin Lecher <jlec@gentoo.org>2011-01-18 15:07:22 +0000
commitc3c6ee4b952317d6d07a16dd9a2d568fb0930e5a (patch)
treea555a3e0ccf2b3f832423047d0021945247ca8e4 /app-text
parentx86 stable, bug 348987 (diff)
downloadgentoo-2-c3c6ee4b952317d6d07a16dd9a2d568fb0930e5a.tar.gz
gentoo-2-c3c6ee4b952317d6d07a16dd9a2d568fb0930e5a.tar.bz2
gentoo-2-c3c6ee4b952317d6d07a16dd9a2d568fb0930e5a.zip
Fix for buffer overflow in ui.c
(Portage version: 2.2.0_alpha17/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/multitail/ChangeLog8
-rw-r--r--app-text/multitail/files/5.2.6-buffer-overflow.patch13
-rw-r--r--app-text/multitail/multitail-5.2.6-r1.ebuild52
3 files changed, 72 insertions, 1 deletions
diff --git a/app-text/multitail/ChangeLog b/app-text/multitail/ChangeLog
index 8aacb6257e43..8b80fc21de8d 100644
--- a/app-text/multitail/ChangeLog
+++ b/app-text/multitail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/multitail
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/multitail/ChangeLog,v 1.76 2011/01/11 22:28:12 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/multitail/ChangeLog,v 1.77 2011/01/18 15:07:22 jlec Exp $
+
+*multitail-5.2.6-r1 (18 Jan 2011)
+
+ 18 Jan 2011; Justin Lecher <jlec@gentoo.org>
+ +files/5.2.6-buffer-overflow.patch, +multitail-5.2.6-r1.ebuild:
+ Fix for buffer overflow in ui.c
11 Jan 2011; Markus Meier <maekke@gentoo.org> multitail-5.2.6.ebuild:
x86 stable, bug #350735
diff --git a/app-text/multitail/files/5.2.6-buffer-overflow.patch b/app-text/multitail/files/5.2.6-buffer-overflow.patch
new file mode 100644
index 000000000000..9a2ddcefe5a3
--- /dev/null
+++ b/app-text/multitail/files/5.2.6-buffer-overflow.patch
@@ -0,0 +1,13 @@
+diff --git a/ui.c b/ui.c
+index f74f3d3..37889fd 100644
+--- a/ui.c
++++ b/ui.c
+@@ -2465,7 +2465,7 @@ void regexp_error_popup(int rc, regex_t *pre)
+ popup_buffer[sizeof(popup_buffer) - 1] = 0x00;
+ }
+ else
+- strncat(popup_buffer, error, sizeof(popup_buffer));
++ strncat(popup_buffer, error, sizeof(popup_buffer) - sizeof(error));
+
+ myfree(error);
+ }
diff --git a/app-text/multitail/multitail-5.2.6-r1.ebuild b/app-text/multitail/multitail-5.2.6-r1.ebuild
new file mode 100644
index 000000000000..2431909b8390
--- /dev/null
+++ b/app-text/multitail/multitail-5.2.6-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/multitail/multitail-5.2.6-r1.ebuild,v 1.1 2011/01/18 15:07:22 jlec Exp $
+
+EAPI="3"
+
+inherit flag-o-matic toolchain-funcs eutils
+
+DESCRIPTION="Tail with multiple windows"
+HOMEPAGE="http://www.vanheusden.com/multitail/index.html"
+SRC_URI="http://www.vanheusden.com/multitail/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="debug doc examples"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/5.2.2-as-needed.patch \
+ "${FILESDIR}"/${PV}-buffer-overflow.patch
+
+ use x86-interix && epatch "${FILESDIR}"/${P}-interix.patch
+}
+
+src_configure() {
+ tc-export CC
+ use debug && append-flags "-D_DEBUG"
+ use prefix && sed "s:DESTDIR=/:DESTDIR=${EROOT}:g" -i Makefile
+}
+
+src_install () {
+ dobin multitail || die
+
+ insinto /etc
+ doins multitail.conf || die
+
+ dodoc Changes readme.txt thanks.txt || die
+ doman multitail.1 || die
+
+ if use examples; then
+ docinto examples
+ dodoc colors-example.{pl,sh} convert-{geoip,simple}.pl || die
+ fi
+
+ if use doc; then
+ dohtml manual.html || die
+ fi
+}