summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2015-06-05 13:29:03 +0000
committerMichael Weber <xmw@gentoo.org>2015-06-05 13:29:03 +0000
commitc03b565c821b662d58fb767e769dd50248d98b98 (patch)
tree3924deb7bf7e925dbffda4a3c6249d4e03ddef21 /app-text
parentFix dependencies (required vala-0.26 and gstreamer-audio and -video modules). (diff)
downloadgentoo-2-c03b565c821b662d58fb767e769dd50248d98b98.tar.gz
gentoo-2-c03b565c821b662d58fb767e769dd50248d98b98.tar.bz2
gentoo-2-c03b565c821b662d58fb767e769dd50248d98b98.zip
Version bump for mupdf-1.7a
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/llpp/ChangeLog8
-rw-r--r--app-text/llpp/llpp-21.ebuild3
-rw-r--r--app-text/llpp/llpp-21_p20150427.ebuild95
-rw-r--r--app-text/llpp/llpp-9999.ebuild6
4 files changed, 106 insertions, 6 deletions
diff --git a/app-text/llpp/ChangeLog b/app-text/llpp/ChangeLog
index 3e699d22a4fc..312655514767 100644
--- a/app-text/llpp/ChangeLog
+++ b/app-text/llpp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/llpp
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/llpp/ChangeLog,v 1.68 2015/04/17 14:51:10 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/llpp/ChangeLog,v 1.69 2015/06/05 13:29:03 xmw Exp $
+
+*llpp-21_p20150427 (05 Jun 2015)
+
+ 05 Jun 2015; Michael Weber <xmw@gentoo.org> +llpp-21_p20150427.ebuild,
+ llpp-21.ebuild, llpp-9999.ebuild:
+ Version bump for mupdf-1.7a
17 Apr 2015; Michael Weber <xmw@gentoo.org> llpp-21.ebuild:
Adjust mupdf dependency
diff --git a/app-text/llpp/llpp-21.ebuild b/app-text/llpp/llpp-21.ebuild
index 56dc35e25c1d..0494508bc188 100644
--- a/app-text/llpp/llpp-21.ebuild
+++ b/app-text/llpp/llpp-21.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/llpp/llpp-21.ebuild,v 1.5 2015/04/17 14:51:10 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/llpp/llpp-21.ebuild,v 1.6 2015/06/05 13:29:03 xmw Exp $
EAPI=5
@@ -57,7 +57,6 @@ src_compile() {
local cclib=""
local slib=""
local spath=( ${EROOT}usr/$(get_libdir) $($(tc-getPKG_CONFIG) --libs-only-L --static mupdf x11 ${egl} | sed 's:-L::g') )
- ewarn ${spath}
for slib in $($(tc-getPKG_CONFIG) --libs-only-l --static mupdf x11 ${egl} fontconfig) -ljpeg -ljbig2dec ; do
case ${slib} in
-lm|-ldl|-lpthread)
diff --git a/app-text/llpp/llpp-21_p20150427.ebuild b/app-text/llpp/llpp-21_p20150427.ebuild
new file mode 100644
index 000000000000..9a64a752e3da
--- /dev/null
+++ b/app-text/llpp/llpp-21_p20150427.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/llpp/llpp-21_p20150427.ebuild,v 1.1 2015/06/05 13:29:03 xmw Exp $
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs vcs-snapshot
+
+DESCRIPTION="graphical PDF viewer which aims to superficially resemble less(1)"
+HOMEPAGE="http://repo.or.cz/w/llpp.git"
+SRC_URI="http://repo.or.cz/w/llpp.git/snapshot/66868744188151eaa433d42c807e1efc5f623aa4.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+ocamlopt static"
+#IUSE="egl +ocamlopt static"
+
+LIB_DEPEND=">=app-text/mupdf-1.7a:0=[static-libs]
+ media-libs/openjpeg:2[static-libs]
+ media-libs/fontconfig:1.0[static-libs]
+ media-libs/freetype:2[static-libs]
+ media-libs/jbig2dec[static-libs]
+ sys-libs/zlib[static-libs]
+ virtual/jpeg:0[static-libs]
+ x11-libs/libX11[static-libs]"
+# egl? ( media-libs/mesa[static-libs] )
+RDEPEND="x11-misc/xsel
+ !static? ( ${LIB_DEPEND//\[static-libs]} )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND}
+ app-arch/bzip2[static-libs]
+ media-libs/libXcm[static-libs]
+ x11-libs/libXau[static-libs]
+ x11-libs/libXdmcp[static-libs]
+ x11-libs/libXmu[static-libs] )
+ >=dev-lang/ocaml-4.02[ocamlopt?]
+ dev-ml/lablgl[glut,ocamlopt?]"
+
+RESTRICT="!ocamlopt? ( strip )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-20-WM_CLASS.patch
+}
+
+src_compile() {
+ local ocaml=$(usex ocamlopt ocamlopt.opt ocamlc.opt)
+ local cmo=$(usex ocamlopt cmx cmo)
+ local cma=$(usex ocamlopt cmxa cma)
+ local ccopt="$(freetype-config --cflags ) -O -include ft2build.h -D_GNU_SOURCE -DUSE_FONTCONFIG"
+ #if use egl ; then
+ # ccopt+=" -DUSE_EGL $(pkg-config --cflags egl)"
+ # local egl="egl"
+ #fi
+ if use static ; then
+ local cclib=""
+ local slib=""
+ local spath=( ${EROOT}usr/$(get_libdir) $($(tc-getPKG_CONFIG) --libs-only-L --static mupdf x11 ${egl} | sed 's:-L::g') )
+ for slib in $($(tc-getPKG_CONFIG) --libs-only-l --static mupdf x11 ${egl} fontconfig) -ljpeg -ljbig2dec ; do
+ case ${slib} in
+ -lm|-ldl|-lpthread)
+ einfo "${slib}: shared"
+ cclib+="${slib} " ;;
+ *)
+ local ccnew=$(find ${spath} -name "lib${slib/-l}.a")
+ einfo "${slib}: use ${ccnew}"
+ cclib+="${ccnew} " ;;
+ esac
+ done
+ else
+ local cclib="$($(tc-getPKG_CONFIG) --libs mupdf x11 ${egl} fontconfig) -lpthread"
+ fi
+
+ verbose() { echo "$@" >&2 ; "$@" || die ; }
+ verbose ocaml str.cma keystoml.ml < KEYS > help.ml
+ verbose printf 'let version ="%s";;\n' ${PV} >> help.ml
+ verbose ${ocaml} -c -o link.o -ccopt "${ccopt}" link.c
+ verbose ${ocaml} -c -o bo.${cmo} le/bo.ml
+ verbose ${ocaml} -c -o help.${cmo} help.ml
+ verbose ${ocaml} -c -o utils.${cmo} utils.ml
+ verbose ${ocaml} -c -o wsi.cmi wsi.mli
+ verbose ${ocaml} -c -o wsi.${cmo} wsi.ml
+ verbose ${ocaml} -c -o parser.${cmo} parser.ml
+ verbose ${ocaml} -c -o config.${cmo} -I +lablGL config.ml
+ verbose ${ocaml} -c -pp "sed -f pp.sed" -o main.${cmo} -I +lablGL main.ml
+ verbose ${ocaml} $(usex ocamlopt "" -custom) -o llpp -I +lablGL\
+ str.${cma} unix.${cma} lablgl.${cma} link.o \
+ -cclib "${cclib}" \
+ bo.${cmo} help.${cmo} utils.${cmo} parser.${cmo} wsi.${cmo} config.${cmo} main.${cmo}
+}
+
+src_install() {
+ dobin ${PN} misc/${PN}ac
+ dodoc KEYS README Thanks fixme
+}
diff --git a/app-text/llpp/llpp-9999.ebuild b/app-text/llpp/llpp-9999.ebuild
index 2d494efa7fe1..7cfb60378160 100644
--- a/app-text/llpp/llpp-9999.ebuild
+++ b/app-text/llpp/llpp-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/llpp/llpp-9999.ebuild,v 1.28 2015/03/17 07:46:15 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/llpp/llpp-9999.ebuild,v 1.29 2015/06/05 13:29:03 xmw Exp $
EAPI=5
@@ -15,7 +15,7 @@ SLOT="0"
KEYWORDS=""
IUSE="+ocamlopt static"
-LIB_DEPEND=">=app-text/mupdf-1.5:0=[static-libs]
+LIB_DEPEND=">=app-text/mupdf-1.7a:0=[static-libs]
media-libs/openjpeg:2[static-libs]
media-libs/fontconfig:1.0[static-libs]
media-libs/freetype:2[static-libs]
@@ -50,7 +50,7 @@ src_compile() {
local cclib=""
local slib=""
local spath=( ${EROOT}usr/$(get_libdir) $($(tc-getPKG_CONFIG) --libs-only-L --static mupdf x11 | sed 's:-L::g') )
- for slib in $($(tc-getPKG_CONFIG) --libs-only-l --static mupdf x11) -ljpeg -ljbig2dec ; do
+ for slib in $($(tc-getPKG_CONFIG) --libs-only-l --static mupdf x11 fontconfig) -ljpeg -ljbig2dec ; do
case ${slib} in
-lm|-ldl|-lpthread)
einfo "${slib}: shared"