summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-09-18 18:54:25 +0000
committerNick Hadaway <raker@gentoo.org>2002-09-18 18:54:25 +0000
commitb931499298a0163e76e66975e8aad1ec74eaf8fd (patch)
tree7b090927f83920ae65ad5808431cff14e7be03ce /app-text
parentVersion bumped, includes openmosix-2.4.19-4 and evms 1.1.0 (diff)
downloadgentoo-2-b931499298a0163e76e66975e8aad1ec74eaf8fd.tar.gz
gentoo-2-b931499298a0163e76e66975e8aad1ec74eaf8fd.tar.bz2
gentoo-2-b931499298a0163e76e66975e8aad1ec74eaf8fd.zip
Added latest version of ESP ghostscript into portage. Currently masked
for testing. Please report on bug #7787 if it works or doesn't work for you.
Diffstat (limited to 'app-text')
-rw-r--r--app-text/ghostscript/ChangeLog14
-rw-r--r--app-text/ghostscript/files/digest-ghostscript-7.05.53
-rw-r--r--app-text/ghostscript/ghostscript-7.05.5.ebuild69
3 files changed, 85 insertions, 1 deletions
diff --git a/app-text/ghostscript/ChangeLog b/app-text/ghostscript/ChangeLog
index c196741dedb9..4fcc1c4f95f9 100644
--- a/app-text/ghostscript/ChangeLog
+++ b/app-text/ghostscript/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for app-text/ghostscript
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript/ChangeLog,v 1.14 2002/08/16 12:57:35 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript/ChangeLog,v 1.15 2002/09/18 18:54:25 raker Exp $
+
+*ghostscript-7.05.5 (18 Sep 2002)
+
+ 18 Sep 2002; Nick Hadaway <raker@gentoo.org>
+ ghostscript-7.05.5.ebuild, files/digest-ghostscript-7.05.5 :
+ Version bump. The 7.05.5 release fixes some problems in the configure
+ script, makes several drivers more portable, and updates several drivers
+ including the CUPS, Deskjet, and Lexmark drivers. IJS (hp inkjet) and
+ OMNI (IBM) support enabled. Installs gimp-print driver if X is
+ enabled in use variables. (Didn't want to create another use
+ variable and gimp-print is important to high quality printing)
+ Currently masked. Please test especially in a cups environment.
*ghostscript-7.05.3 (19 Jul 2002)
diff --git a/app-text/ghostscript/files/digest-ghostscript-7.05.5 b/app-text/ghostscript/files/digest-ghostscript-7.05.5
new file mode 100644
index 000000000000..2391cd241233
--- /dev/null
+++ b/app-text/ghostscript/files/digest-ghostscript-7.05.5
@@ -0,0 +1,3 @@
+MD5 984b8b08389e79f7da3b714238652d34 espgs-7.05.5-source.tar.bz2 5368020
+MD5 1521fab85ca3e8ce3ce781d4970e6c79 gnu-gs-fonts-std-6.0.tar.gz 1881193
+MD5 33457d3f37de7ef03d2eea05a9e6aa4f gnu-gs-fonts-other-6.0.tar.gz 796086
diff --git a/app-text/ghostscript/ghostscript-7.05.5.ebuild b/app-text/ghostscript/ghostscript-7.05.5.ebuild
new file mode 100644
index 000000000000..46a8d8ea533e
--- /dev/null
+++ b/app-text/ghostscript/ghostscript-7.05.5.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript/ghostscript-7.05.5.ebuild,v 1.1 2002/09/18 18:54:25 raker Exp $
+
+S=${WORKDIR}/espgs-${PV}
+
+DESCRIPTION="ESP Ghostscript -- an enhanced version of GNU Ghostscript with better printer support"
+SRC_URI="ftp://ftp.easysw.com/pub/ghostscript/espgs-${PV}-source.tar.bz2
+ftp://ftp.easysw.com/pub/ghostscript/gnu-gs-fonts-std-6.0.tar.gz
+ftp://ftp.easysw.com/pub/ghostscript/gnu-gs-fonts-other-6.0.tar.gz"
+HOMEPAGE="http://www.easysw.com/"
+
+SLOT="0"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="x86 ppc sparc sparc64"
+
+DEPEND=">=media-libs/jpeg-6b
+ >=media-libs/libpng-1.2.1
+ >=sys-libs/zlib-1.1.4
+ X? ( virtual/x11 >=media-gfx/gimp-print-4.2.1 )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+
+ unpack espgs-${PV}-source.tar.bz2 || die
+ unpack gnu-gs-fonts-std-6.0.tar.gz || die
+ unpack gnu-gs-fonts-other-6.0.tar.gz || die
+
+ # Brother HL-12XX support
+ cp ${FILESDIR}/gs7.05-gdevhl12.c ${S}/src/gdevhl12.c || die
+ mv ${S}/src/Makefile.in ${S}/src/Makefile.in.orig
+ sed 's#^\(DEVICE_DEVS6=.*\)$#\1 $(DD)hl1240.dev $(DD)hl1250.dev#' \
+ < ${S}/src/Makefile.in.orig > ${S}/src/Makefile.in || die
+
+}
+
+src_compile() {
+
+ local myconf
+ myconf="--with-ijs --with-omni"
+
+ use X && myconf="${myconf} --with-x --with-gimp-print" \
+ || myconf="${myconf} --without-x --without-gimp-print"
+
+ use cups && myconf="${myconf} --enable-cups" \
+ || myconf="${myconf} --disable-cups"
+
+ econf ${myconf} || die "./configure failed"
+
+ make || die "make failed"
+}
+
+src_install() {
+
+ einstall install_prefix=${D} || die "make install failed"
+
+ cd ${WORKDIR}
+ cp -a fonts ${D}/usr/share/ghostscript || die
+ cd ${S}
+
+ rm -fr ${D}/usr/share/ghostscript/7.05/doc || die
+ dodoc doc/README doc/COPYING doc/COPYING.LGPL
+ dohtml doc/*.html doc/*.htm
+ insinto /usr/share/emacs/site-lisp
+ doins doc/gsdoc.el || die
+
+}
+
+