summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Hanselmann <hansmi@gentoo.org>2004-12-15 22:50:04 +0000
committerMichael Hanselmann <hansmi@gentoo.org>2004-12-15 22:50:04 +0000
commitb6e67ef63ccbbfc3480f7990b127fb115e4f55b2 (patch)
tree26ead84f9911143f453adc1c601e5f4ff60556d6 /app-text
parentBUG #72945: missing digest for 32bit library. (Manifest recommit) (diff)
downloadgentoo-2-b6e67ef63ccbbfc3480f7990b127fb115e4f55b2.tar.gz
gentoo-2-b6e67ef63ccbbfc3480f7990b127fb115e4f55b2.tar.bz2
gentoo-2-b6e67ef63ccbbfc3480f7990b127fb115e4f55b2.zip
Fixed compilation error in xmalloc.c and added to ~ppc.
Diffstat (limited to 'app-text')
-rw-r--r--app-text/bogosort/ChangeLog6
-rw-r--r--app-text/bogosort/bogosort-0.4.2.ebuild13
-rw-r--r--app-text/bogosort/files/xmalloc.patch15
3 files changed, 31 insertions, 3 deletions
diff --git a/app-text/bogosort/ChangeLog b/app-text/bogosort/ChangeLog
index a78f64ace680..bcb06b918b61 100644
--- a/app-text/bogosort/ChangeLog
+++ b/app-text/bogosort/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/bogosort
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bogosort/ChangeLog,v 1.1 2004/12/14 22:58:49 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/bogosort/ChangeLog,v 1.2 2004/12/15 22:50:04 hansmi Exp $
+
+ 15 Dec 2004; Michael Hanselmann <hansmi@gentoo.org> +files/xmalloc.patch,
+ bogosort-0.4.2.ebuild:
+ Fixed compilation error in xmalloc.c and added to ~ppc.
*bogosort-0.4.2 (14 Dec 2004)
diff --git a/app-text/bogosort/bogosort-0.4.2.ebuild b/app-text/bogosort/bogosort-0.4.2.ebuild
index a664071a224b..43f716fdb190 100644
--- a/app-text/bogosort/bogosort-0.4.2.ebuild
+++ b/app-text/bogosort/bogosort-0.4.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bogosort/bogosort-0.4.2.ebuild,v 1.1 2004/12/14 22:58:49 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/bogosort/bogosort-0.4.2.ebuild,v 1.2 2004/12/15 22:50:04 hansmi Exp $
+
+inherit libtool eutils
DESCRIPTION="A file sorting program which uses the bogosort algorithm"
HOMEPAGE="http://www.lysator.liu.se/~qha/bogosort/"
@@ -8,12 +10,19 @@ SRC_URI="ftp://ulrik.haugen.se/pub/unix/bogosort/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~sparc ~mips"
+KEYWORDS="~x86 ~sparc ~mips ~ppc"
IUSE=""
DEPEND=""
RDEPEND=""
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/xmalloc.patch
+}
+
src_install() {
make DESTDIR="${D}" install
dodoc README NEWS ChangeLog AUTHORS
diff --git a/app-text/bogosort/files/xmalloc.patch b/app-text/bogosort/files/xmalloc.patch
new file mode 100644
index 000000000000..41545ca34ba8
--- /dev/null
+++ b/app-text/bogosort/files/xmalloc.patch
@@ -0,0 +1,15 @@
+--- xmalloc.c.orig 2004-12-15 23:44:16.880786468 +0100
++++ xmalloc.c 2004-12-15 23:44:21.846546805 +0100
+@@ -68,12 +68,6 @@
+ The caller may set it to some other value. */
+ int xmalloc_exit_failure = EXIT_FAILURE;
+
+-#if __STDC__ && (HAVE_VPRINTF || HAVE_DOPRNT)
+-void error (int, int, const char *, ...);
+-#else
+-void error ();
+-#endif
+-
+ static VOID *
+ fixup_null_alloc (n)
+ size_t n;