summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2012-06-19 22:00:59 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2012-06-19 22:00:59 +0000
commit96748855f7ad029a691b456a1d31fd93d1cdf3f9 (patch)
treea05cf324f210b70b95ae535eaae675431a4e49ac /app-text
parentFix building against net-libs/geoip[-static-libs] by Diego Elio Pettenò (bug... (diff)
downloadgentoo-2-96748855f7ad029a691b456a1d31fd93d1cdf3f9.tar.gz
gentoo-2-96748855f7ad029a691b456a1d31fd93d1cdf3f9.tar.bz2
gentoo-2-96748855f7ad029a691b456a1d31fd93d1cdf3f9.zip
Use upstreamed lcms automagic patch (and respective ebuild usage)
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/poppler/ChangeLog6
-rw-r--r--app-text/poppler/files/poppler-0.20.1-lcms-automagic.patch107
-rw-r--r--app-text/poppler/poppler-0.20.1.ebuild15
3 files changed, 107 insertions, 21 deletions
diff --git a/app-text/poppler/ChangeLog b/app-text/poppler/ChangeLog
index ef4fb528d12e..829f2da9a575 100644
--- a/app-text/poppler/ChangeLog
+++ b/app-text/poppler/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/poppler
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/ChangeLog,v 1.324 2012/06/17 14:32:37 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/ChangeLog,v 1.325 2012/06/19 22:00:59 reavertm Exp $
+
+ 19 Jun 2012; Maciej Mrozowski <reavertm@gentoo.org>
+ files/poppler-0.20.1-lcms-automagic.patch, poppler-0.20.1.ebuild:
+ Use upstreamed lcms automagic patch (and respective ebuild usage)
17 Jun 2012; Raúl Porcel <armin76@gentoo.org> poppler-0.18.4-r1.ebuild:
alpha/ia64/s390/sh/sparc stable wrt #412701
diff --git a/app-text/poppler/files/poppler-0.20.1-lcms-automagic.patch b/app-text/poppler/files/poppler-0.20.1-lcms-automagic.patch
index 08b194ceae31..641a4ab68b17 100644
--- a/app-text/poppler/files/poppler-0.20.1-lcms-automagic.patch
+++ b/app-text/poppler/files/poppler-0.20.1-lcms-automagic.patch
@@ -1,35 +1,114 @@
-diff -ruN poppler-0.20.0/CMakeLists.txt my/CMakeLists.txt
---- poppler-0.20.0/CMakeLists.txt 2012-05-10 21:08:51.000000000 +0200
-+++ my/CMakeLists.txt 2012-05-18 01:14:34.103419581 +0200
-@@ -29,6 +29,7 @@
+From 8f6d84fd882907ff433c8eacebbe1d5a559d4e3b Mon Sep 17 00:00:00 2001
+From: Maciej Mrozowski <reavertm@gmail.com>
+Date: Fri, 18 May 2012 01:47:55 +0200
+Subject: [PATCH] [Buildsystem] CMake: Provide ENABLE_CMS=[auto/lcms1/lcms2] option to distinguish between available liblcms implementations when both are present during configure phase. 'auto' (default) prefers lcms2. Autotools: add --enable-cms=[auto/lcms1/lcms2].
+
+---
+ CMakeLists.txt | 20 +++++++++++++-------
+ configure.ac | 31 +++++++++++++++----------------
+ 2 files changed, 28 insertions(+), 23 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 9f4830b..8b07470 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -28,7 +28,7 @@ option(ENABLE_SPLASH "Build the Splash graphics backend." ON)
+ option(ENABLE_UTILS "Compile poppler command line utils." ON)
option(ENABLE_CPP "Compile poppler cpp wrapper." ON)
option(ENABLE_LIBOPENJPEG "Use libopenjpeg for JPX streams." ON)
- option(ENABLE_LCMS "Use liblcms for color management." ON)
-+option(ENABLE_LCMS2 "Use liblcms2 for color management." ON)
+-option(ENABLE_LCMS "Use liblcms for color management." ON)
++set(ENABLE_CMS "auto" CACHE STRING "Use color management system. Possible values: auto, lcms1, lcms2. 'auto' prefers lcms2 over lcms1 if both are available. Unset to disable color management system.")
option(ENABLE_LIBCURL "Build libcurl based HTTP support." OFF)
option(ENABLE_ZLIB "Build with zlib (not totally safe)." OFF)
option(USE_FIXEDPOINT "Use fixed point arithmetic in the Splash backend" OFF)
-@@ -136,16 +137,14 @@
+@@ -136,16 +136,22 @@ if(ENABLE_LIBOPENJPEG)
set(ENABLE_LIBOPENJPEG ${LIBOPENJPEG_FOUND})
set(HAVE_OPENJPEG_H ON)
endif(ENABLE_LIBOPENJPEG)
-if(ENABLE_LCMS)
-+if(ENABLE_LCMS2)
++if(ENABLE_CMS STREQUAL "auto")
find_package(LCMS2)
- if(LCMS2_FOUND)
- set(USE_CMS ${LCMS2_FOUND})
- else(LCMS2_FOUND)
-- find_package(LCMS)
-- set(USE_CMS ${LCMS_FOUND})
-- set(USE_LCMS1 ${LCMS_FOUND})
++ set(USE_CMS ${LCMS2_FOUND})
++ if(NOT LCMS2_FOUND)
+ find_package(LCMS)
+ set(USE_CMS ${LCMS_FOUND})
+ set(USE_LCMS1 ${LCMS_FOUND})
- endif(LCMS2_FOUND)
-endif(ENABLE_LCMS)
-+ set(USE_CMS ${LCMS2_FOUND})
-+elseif(ENABLE_LCMS)
++ endif(NOT LCMS2_FOUND)
++elseif(ENABLE_CMS STREQUAL "lcms1")
+ find_package(LCMS)
+ set(USE_CMS ${LCMS_FOUND})
+ set(USE_LCMS1 ${LCMS_FOUND})
-+endif(ENABLE_LCMS2)
++elseif(ENABLE_CMS STREQUAL "lcms2")
++ find_package(LCMS2)
++ set(USE_CMS ${LCMS2_FOUND})
++endif()
if(ENABLE_LIBCURL)
find_package(CURL)
include_directories(${CURL_INCLUDE_DIR})
+diff --git a/configure.ac b/configure.ac
+index f9919d9..a4b4f18 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -660,7 +660,7 @@ AC_ARG_ENABLE(utils,
+ AM_CONDITIONAL(BUILD_UTILS, test x$enable_utils = xyes)
+
+ AC_ARG_ENABLE(compile-warnings,
+- AC_HELP_STRING([--enable-compile-warnings=@<:@no/yes/kde@:>@]
++ AC_HELP_STRING([--enable-compile-warnings=@<:@no/yes/kde@:>@],
+ [Turn on compiler warnings.]),,
+ [enable_compile_warnings="yes"])
+
+@@ -669,31 +669,30 @@ dnl Color Management
+ dnl
+
+ AC_ARG_ENABLE(cms,
+- AC_HELP_STRING([--disable-cms],
+- [Don't use color management system.]),
+- enable_cms=$enableval,
+- enable_cms="try")
+-if test x$enable_cms = xyes; then
++ AC_HELP_STRING([--enable-cms=@<:@auto/lcms1/lcms2/none@:>@],
++ [Use color management system. 'auto' prefers lcms2 over lcms1 if both are available [[default=auto]]]),
++ [enable_cms=$enableval],
++ [enable_cms="auto"])
++if test x$enable_cms = xauto; then
+ PKG_CHECK_MODULES(LCMS, lcms2, [lcms2=yes], [lcms2=no])
+ if test x$lcms2 = xno; then
+- PKG_CHECK_MODULES(LCMS, lcms)
+- fi
+-elif test x$enable_cms = xtry; then
+- PKG_CHECK_MODULES(LCMS, lcms2,[lcms2=yes],[lcms2=no])
+- if test x$lcms2 = xyes; then
+- enable_cms=yes
+- else
+- PKG_CHECK_MODULES(LCMS, lcms,[enable_cms=yes],[enable_cms=no])
++ PKG_CHECK_MODULES(LCMS, lcms, [lcms1=yes], [lcms1=no])
+ fi
++elif test x$enable_cms = xlcms1; then
++ PKG_CHECK_MODULES(LCMS, lcms, [lcms1=yes], [lcms1=no])
++elif test x$enable_cms = xlcms2; then
++ PKG_CHECK_MODULES(LCMS, lcms2, [lcms2=yes], [lcms2=no])
+ fi
+
+-if test "x$enable_cms" = "xyes"; then
++if test x$lcms1 = xyes || test x$lcms2 = xyes; then
++ enable_cms=yes
+ AC_DEFINE(USE_CMS, 1, [Defines if use cms])
+- if test "x$lcms2" != "xyes"; then
++ if test x$lcms1 = xyes; then
+ lcms1=yes;
+ AC_DEFINE(USE_LCMS1, 1, [Defines if use lcms1])
+ fi
+ fi
++
+ AM_CONDITIONAL(USE_CMS, test x$enable_cms = xyes)
+ AM_CONDITIONAL(USE_LCMS1, test x$lcms1 = xyes)
+
+--
+1.7.3.4
+
diff --git a/app-text/poppler/poppler-0.20.1.ebuild b/app-text/poppler/poppler-0.20.1.ebuild
index 298a9d8ba8a3..2905152b3bd9 100644
--- a/app-text/poppler/poppler-0.20.1.ebuild
+++ b/app-text/poppler/poppler-0.20.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/poppler-0.20.1.ebuild,v 1.1 2012/06/14 11:46:29 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/poppler/poppler-0.20.1.ebuild,v 1.2 2012/06/19 22:00:59 reavertm Exp $
EAPI="4"
@@ -50,24 +50,22 @@ RDEPEND="${COMMON_DEPEND}
cjk? ( >=app-text/poppler-data-0.4.4 )
"
-DOCS=(AUTHORS ChangeLog NEWS README README-XPDF TODO)
-
PATCHES=(
- "${FILESDIR}/${PN}-0.20.1-lcms-automagic.patch"
+ "${FILESDIR}/${P}-lcms-automagic.patch"
)
+DOCS=(AUTHORS ChangeLog NEWS README README-XPDF TODO)
+
src_configure() {
mycmakeargs=(
-DBUILD_GTK_TESTS=OFF
-DBUILD_QT4_TESTS=OFF
-DBUILD_CPP_TESTS=OFF
- -DENABLE_LCMS=OFF
-DENABLE_SPLASH=ON
-DENABLE_ZLIB=ON
$(cmake-utils_use_enable curl LIBCURL)
$(cmake-utils_use_enable cxx CPP)
$(cmake-utils_use_enable jpeg2k LIBOPENJPEG)
- $(cmake-utils_use_enable lcms LCMS2)
$(cmake-utils_use_enable utils)
$(cmake-utils_use_enable xpdf-headers XPDF_HEADERS)
$(cmake-utils_use_with cairo)
@@ -77,6 +75,11 @@ src_configure() {
$(cmake-utils_use_with qt4)
$(cmake-utils_use_with tiff)
)
+ if use lcms; then
+ mycmakeargs+=(-DENABLE_CMS=lcms2)
+ else
+ mycmakeargs+=(-DENABLE_CMS=)
+ fi
cmake-utils_src_configure
}