summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-03-08 23:01:39 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-03-08 23:01:39 +0000
commit934b96bb4c1357f02ba85eced44c90185a8453ab (patch)
treeb4f049c7097deddede886e9b10e9704ea5f7c07b /app-text
parentPrint more warning after merging (diff)
downloadgentoo-2-934b96bb4c1357f02ba85eced44c90185a8453ab.tar.gz
gentoo-2-934b96bb4c1357f02ba85eced44c90185a8453ab.tar.bz2
gentoo-2-934b96bb4c1357f02ba85eced44c90185a8453ab.zip
Version bump
Diffstat (limited to 'app-text')
-rw-r--r--app-text/sablotron/ChangeLog7
-rw-r--r--app-text/sablotron/files/digest-sablotron-0.971
-rw-r--r--app-text/sablotron/sablotron-0.97.ebuild33
3 files changed, 40 insertions, 1 deletions
diff --git a/app-text/sablotron/ChangeLog b/app-text/sablotron/ChangeLog
index 237f3d6cf18e..98a717585846 100644
--- a/app-text/sablotron/ChangeLog
+++ b/app-text/sablotron/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/sablotron
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/ChangeLog,v 1.12 2003/02/12 05:34:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/ChangeLog,v 1.13 2003/03/08 23:01:39 aliz Exp $
+
+*sablotron-0.97 (09 Mar 2003)
+
+ 09 Mar 2003; Daniel Ahlberg <aliz@gentoo.org> :
+ Version bump.
21 Jan 2003; Rajiv Manglani <rajiv@gentoo.org> : added ~ppc.
diff --git a/app-text/sablotron/files/digest-sablotron-0.97 b/app-text/sablotron/files/digest-sablotron-0.97
new file mode 100644
index 000000000000..3e6cf6784eb4
--- /dev/null
+++ b/app-text/sablotron/files/digest-sablotron-0.97
@@ -0,0 +1 @@
+MD5 253d5e7738d85beecc2c274478431529 Sablot-0.97.tar.gz 438425
diff --git a/app-text/sablotron/sablotron-0.97.ebuild b/app-text/sablotron/sablotron-0.97.ebuild
new file mode 100644
index 000000000000..9b24e2ae8edf
--- /dev/null
+++ b/app-text/sablotron/sablotron-0.97.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-0.97.ebuild,v 1.1 2003/03/08 23:01:39 aliz Exp $
+
+S=${WORKDIR}/Sablot-${PV}
+DESCRIPTION="An XSLT Parser in C++"
+SRC_URI="http://download-2.gingerall.cz/download/sablot/Sablot-${PV}.tar.gz"
+HOMEPAGE="http://www.gingerall.com/charlie-bin/get/webGA/act/sablotron.act"
+
+SLOT="0"
+LICENSE="MPL-1.1"
+KEYWORDS="~x86 ~sparc ~ppc"
+
+DEPEND=">=dev-libs/expat-1.95.1
+ dev-perl/XML-Parser"
+
+src_compile() {
+ local myconf
+ use perl && myconf="--enable-perlconnect"
+
+ # rphillips
+ # fixes bug #3876
+ export LDFLAGS="-lstdc++"
+
+ econf ${myconf}
+ make || die
+}
+
+src_install() {
+ einstall
+ dodoc README* RELEASE
+ dodoc src/TODO
+}